aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-01-22 21:03:35 -0800
committerKhem Raj <raj.khem@gmail.com>2020-01-22 21:30:45 -0800
commite9014dfd0c35c499ac2c83a0ae147f98ec00b175 (patch)
tree5a2a78c370bf8a0dc2923baac417e97e3c0ad75b
parente4a2593a2193922ef23e62d43affe15b50d825d7 (diff)
downloadmeta-openembedded-contrib-e9014dfd0c35c499ac2c83a0ae147f98ec00b175.tar.gz
ntop: Pass PYTHON_CONFIG to configure
This aids cross-building, otherwise configure goes into weeks to find these especially python-config and starts to poke at host files e.g. if /etc/debian_release exists then it errors out, but if it does not then it deploys a workaround and continues build, as a result we see ntop fail the build on debian-like build hosts but not on others eg. archlinux Ensure that linking with libpython happens therefore use python3-config --libs --embed Fixes checking for arm-yoe-linux-gnueabi-python-config... no checking for python-config... no Please install python-dev and rerun configure Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-support/ntop/ntop/embed-libs.patch20
-rw-r--r--meta-networking/recipes-support/ntop/ntop_5.0.1.bb3
2 files changed, 22 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/ntop/ntop/embed-libs.patch b/meta-networking/recipes-support/ntop/ntop/embed-libs.patch
new file mode 100644
index 0000000000..2d1ab73717
--- /dev/null
+++ b/meta-networking/recipes-support/ntop/ntop/embed-libs.patch
@@ -0,0 +1,20 @@
+Use --embed option so that it can return libpython as well
+
+% ../recipe-sysroot-native/usr/bin/python3-native/python3-config --libs --embed
+-lpython3.8 -lcrypt -lpthread -ldl -lutil -lm -lm
+[kraj@apollo /mnt/b/yoe/build/tmp/work/cortexa7t2hf-neon-vfpv4-yoe-linux-gnueabi/ntop/5.0.1-r0/ntop-5.0.1]
+% ../recipe-sysroot-native/usr/bin/python3-native/python3-config --libs
+-lcrypt -lpthread -ldl -lutil -lm -lm
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/configure.in
++++ b/configure.in
+@@ -1463,7 +1463,7 @@ dnl>
+ fi
+
+ if test "x$PYTHON_CONFIG" != "x"; then
+- PYTHON_LIBS="`$PYTHON_CONFIG --libs`"
++ PYTHON_LIBS="`$PYTHON_CONFIG --libs --embed`"
+ if test "x$PYTHON_LIBS" = "x"; then
+ AC_MSG_RESULT(Python[-devel] support is present but misconfigured)
+ else
diff --git a/meta-networking/recipes-support/ntop/ntop_5.0.1.bb b/meta-networking/recipes-support/ntop/ntop_5.0.1.bb
index 2d37969a70..d835e399b3 100644
--- a/meta-networking/recipes-support/ntop/ntop_5.0.1.bb
+++ b/meta-networking/recipes-support/ntop/ntop_5.0.1.bb
@@ -19,6 +19,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/ntop/ntop-${PV}.tar.gz \
file://0001-nDPI-Include-sys-types.h.patch \
file://0001-plugins-Makefile.am-fix-for-automake-1.16.1.patch \
file://fix-missing-return-from-non-void-function.patch \
+ file://embed-libs.patch \
"
SRC_URI[md5sum] = "01710b6925a8a5ffe1a41b8b512ebd69"
SRC_URI[sha256sum] = "7e8e84cb14d2173beaca4d4cb991a14d84a4bef84ec37b2276bc363f45c52ef8"
@@ -35,7 +36,7 @@ PACKAGECONFIG[snmp] = "--enable-snmp=yes NETSNMP=${STAGING_BINDIR_CROSS}/net-snm
--disable-snmp,net-snmp,"
PACKAGECONFIG[plugins] = "--enable-plugins=yes, --disable-plugins, ,"
-EXTRA_OECONF += "ac_cv_file_aclocal_m4=yes ac_cv_file_depcomp=no"
+EXTRA_OECONF += "ac_cv_file_aclocal_m4=yes ac_cv_file_depcomp=no PYTHON_CONFIG=python3-config"
do_configure() {
cp ${STAGING_DATADIR_NATIVE}/aclocal/libtool.m4 libtool.m4.in