aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-01-21 16:53:28 -0800
committerKhem Raj <raj.khem@gmail.com>2020-01-22 09:56:34 -0800
commite2b0b89b8010b5e2f51cda5d93121b8c63c7b9a2 (patch)
treeb979b885086433eaded75db6025708bb3ace1a11
parent84233fc1111881d2c2397fe3451fed42bb1ffc14 (diff)
downloadmeta-openembedded-contrib-e2b0b89b8010b5e2f51cda5d93121b8c63c7b9a2.tar.gz
python3-ldap: Fix build dependencies to use python3
Address files via ${S} Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-devtools/python/python3-ldap_3.2.0.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-networking/recipes-devtools/python/python3-ldap_3.2.0.bb b/meta-networking/recipes-devtools/python/python3-ldap_3.2.0.bb
index 2ad70ace4a..f46ddbf449 100644
--- a/meta-networking/recipes-devtools/python/python3-ldap_3.2.0.bb
+++ b/meta-networking/recipes-devtools/python/python3-ldap_3.2.0.bb
@@ -9,7 +9,7 @@ OpenLDAP 2.x libraries. Errors will appear as exceptions."
LICENSE = "PSF"
HOMEPAGE = "http://www.python-ldap.org/"
-DEPENDS = "python openldap cyrus-sasl"
+DEPENDS = "python3 openldap cyrus-sasl"
PYPI_PACKAGE = "python-ldap"
inherit pypi setuptools3
@@ -19,8 +19,8 @@ SRC_URI[md5sum] = "fe22522208dc9b06d16eb70f8553eaab"
SRC_URI[sha256sum] = "7d1c4b15375a533564aad3d3deade789221e450052b21ebb9720fb822eccdb8e"
do_configure_prepend() {
- sed -i -e 's:^library_dirs =.*::' setup.cfg
- sed -i -e 's:^include_dirs =.*:include_dirs = =/usr/include/sasl/:' setup.cfg
+ sed -i -e 's:^library_dirs =.*::' ${S}/setup.cfg
+ sed -i -e 's:^include_dirs =.*:include_dirs = =/usr/include/sasl/:' ${S}/setup.cfg
}
RDEPENDS_${PN} = " \