aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-04-11 21:29:11 -0700
committerKhem Raj <raj.khem@gmail.com>2024-04-11 23:32:36 -0700
commitdf35bef3ae6411900efdfc3ea5ade23820e9af2f (patch)
treef4322c64f10cddb2c9ca6c501435cd56dfd8a714
parent291df68dfd390fab32f5e3d88b25eb0c81d8d0f2 (diff)
downloadmeta-openembedded-contrib-df35bef3ae6411900efdfc3ea5ade23820e9af2f.tar.gz
libteam: Add missing dependencies revealed by ptests
Fixes ptests provided kernel has team driver enabled Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/libteam/libteam_1.31.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/libteam/libteam_1.31.bb b/meta-oe/recipes-support/libteam/libteam_1.31.bb
index 023cea9039..6fe10abe01 100644
--- a/meta-oe/recipes-support/libteam/libteam_1.31.bb
+++ b/meta-oe/recipes-support/libteam/libteam_1.31.bb
@@ -35,7 +35,13 @@ FILES:${PN}-utils = "${bindir}/bond2team \
"
RDEPENDS:${PN}-utils = "bash"
-RDEPENDS:${PN}-ptest = "python3-core"
+RDEPENDS:${PN}-ptest = "python3-core libteam-utils"
+# Ensure kernel has these mods enabled features/net/team/team.scc
+RRECOMMENDS:${PN} += "kernel-module-team kernel-module-team-mode-activebackup \
+ kernel-module-team-mode-broadcast \
+ kernel-module-team-mode-loadbalance \
+ kernel-module-team-mode-random \
+ kernel-module-team-mode-roundrobin"
do_install_ptest() {
install ${S}/scripts/team_basic_test.py ${D}${PTEST_PATH}/