aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-07-10 17:42:57 +0100
committerKhem Raj <raj.khem@gmail.com>2018-07-12 07:19:43 -0700
commitce13d1976da3ffcbb8099c2d7bf47cd31f80d90f (patch)
tree7e534d5720cfb48fabe501fdc012933beb126041
parent9f292d50183baa1951dc2ff3b9b691852b89eadb (diff)
downloadmeta-openembedded-contrib-ce13d1976da3ffcbb8099c2d7bf47cd31f80d90f.tar.gz
python3-bandit: add the Bandit security scanner
Bandit is a security scanner for Python code. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-bandit_1.4.0.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-bandit_1.4.0.bb b/meta-python/recipes-devtools/python/python3-bandit_1.4.0.bb
new file mode 100644
index 0000000000..2d24c8b0f7
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-bandit_1.4.0.bb
@@ -0,0 +1,12 @@
+SUMMARY = "Security oriented static analyser for python code."
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
+
+SRC_URI[md5sum] = "f74155cb9921be857693b32d2531e857"
+SRC_URI[sha256sum] = "cb977045497f83ec3a02616973ab845c829cdab8144ce2e757fe031104a9abd4"
+
+DEPENDS = "python3-pyyaml python3-six python3-stevedore"
+
+inherit setuptools3 pypi
+
+BBCLASSEXTEND = "native"