aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-01-23 16:29:16 -0800
committerKhem Raj <raj.khem@gmail.com>2020-01-24 09:25:34 -0800
commitbbf25b62da8dc694c3e0543f276db034ebe8b1e4 (patch)
tree5b52bb3c632e9a281e44c320a36350ff7bb3d450
parent5c453ae57830b379355a3bddb4bd9d556584d411 (diff)
downloadmeta-openembedded-contrib-bbf25b62da8dc694c3e0543f276db034ebe8b1e4.tar.gz
nmap: Use py3 in depends/rdepends
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-security/nmap/nmap_7.80.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-security/nmap/nmap_7.80.bb b/meta-oe/recipes-security/nmap/nmap_7.80.bb
index 2ac600c782..96af17efdf 100644
--- a/meta-oe/recipes-security/nmap/nmap_7.80.bb
+++ b/meta-oe/recipes-security/nmap/nmap_7.80.bb
@@ -28,7 +28,7 @@ PACKAGECONFIG[libz] = "--with-libz=${STAGING_LIBDIR}/.., --without-libz, zlib, z
#disable/enable packages
PACKAGECONFIG[nping] = ",--without-nping,"
PACKAGECONFIG[ncat] = ",--without-ncat,"
-PACKAGECONFIG[ndiff] = ",--without-ndiff,python"
+PACKAGECONFIG[ndiff] = ",--without-ndiff,python3"
PACKAGECONFIG[update] = ",--without-nmap-update,"
EXTRA_OECONF = "--with-libdnet=included --with-liblinear=included --without-subversion --with-liblua=included"
@@ -49,4 +49,4 @@ do_configure() {
FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR} ${datadir}/ncat"
-RDEPENDS_${PN} = "python"
+RDEPENDS_${PN} = "python3"