aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-04-10 16:03:02 -0700
committerKhem Raj <raj.khem@gmail.com>2024-04-10 16:06:31 -0700
commit9d220eb5e91d7aa48effe02d59f2465821179f83 (patch)
tree3029610f172c734fb78b13a62bbdc35dcbda6661
parent382389f356bf819bf40f47cae0a980e8ebeeb03e (diff)
downloadmeta-openembedded-contrib-9d220eb5e91d7aa48effe02d59f2465821179f83.tar.gz
python3-pint: Switch to using github SRC_URI
It fixes some but not all ptest failures Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-pint_0.23.bb12
1 files changed, 9 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pint_0.23.bb b/meta-python/recipes-devtools/python/python3-pint_0.23.bb
index ad3e13e5dd..370cd7017b 100644
--- a/meta-python/recipes-devtools/python/python3-pint_0.23.bb
+++ b/meta-python/recipes-devtools/python/python3-pint_0.23.bb
@@ -8,9 +8,12 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=bccf824202692270a1e0829a62e3f47b"
PYPI_PACKAGE := "Pint"
-inherit pypi ptest python_setuptools_build_meta
+inherit ptest python_setuptools_build_meta
-SRC_URI[sha256sum] = "e1509b91606dbc52527c600a4ef74ffac12fff70688aff20e9072409346ec9b4"
+SRCREV = "f2e4081aee38f850938048beac7fb69c4908bc5e"
+SRC_URI = "git://github.com/hgrecco/pint;protocol=https;branch=master"
+S = "${WORKDIR}/git"
+#SRC_URI[sha256sum] = "e1509b91606dbc52527c600a4ef74ffac12fff70688aff20e9072409346ec9b4"
DEPENDS += "python3-setuptools-scm-native"
@@ -26,10 +29,13 @@ RDEPENDS:${PN} += " \
"
RDEPENDS:${PN}-ptest += " \
+ python3-appdirs \
+ python3-flexcache \
+ python3-flexparser \
python3-pytest \
"
do_install_ptest() {
install -d ${D}${PTEST_PATH}/testsuite
- cp -rf ${S}/pint/testsuite/* ${D}${PTEST_PATH}/testsuite/
+ cp -rf ${S}/pint/* ${D}${PTEST_PATH}/
}