aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoralperak <alperyasinak1@gmail.com>2024-04-11 13:57:01 +0300
committerKhem Raj <raj.khem@gmail.com>2024-04-11 23:32:35 -0700
commit91731183b559069e3004f85aa4a66b7d93967ee2 (patch)
treefc8d541d1b9db6dd43f3dca5a30f719edec95b95
parent7bb28628991ec9be9610540401f7c6cc4c19997f (diff)
downloadmeta-openembedded-contrib-91731183b559069e3004f85aa4a66b7d93967ee2.tar.gz
python3-flexcache: enable ptest
* Ptest tested on qemux86-64 and qemuarm64 * Add ptest into PTESTS_FAST_META_PYTHON Ptest result: ============= qemux86-64: Testsuite summary TOTAL: 19 PASS: 19 SKIP: 0 XFAIL: 0 FAIL: 0 XPASS: 0 ERROR: 0 DURATION: 9 END: /usr/lib/python3-flexcache/ptest 2024-04-11T10:48 STOP: ptest-runner TOTAL: 1 FAIL: 0 qemuarm64: Testsuite summary TOTAL: 19 PASS: 19 SKIP: 0 XFAIL: 0 FAIL: 0 XPASS: 0 ERROR: 0 DURATION: 9 END: /usr/lib/python3-flexcache/ptest 2024-04-11T10:51 STOP: ptest-runner TOTAL: 1 FAIL: 0 Signed-off-by: alperak <alperyasinak1@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/conf/include/ptest-packagelists-meta-python.inc1
-rw-r--r--meta-python/recipes-devtools/python/python3-flexcache/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-flexcache_0.3.bb17
3 files changed, 20 insertions, 1 deletions
diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc b/meta-python/conf/include/ptest-packagelists-meta-python.inc
index 19566e4661..acb09aacad 100644
--- a/meta-python/conf/include/ptest-packagelists-meta-python.inc
+++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc
@@ -19,6 +19,7 @@ PTESTS_FAST_META_PYTHON = "\
python3-click \
python3-dominate \
python3-execnet \
+ python3-flexcache \
python3-freezegun \
python3-geojson \
python3-google-auth-oauthlib \
diff --git a/meta-python/recipes-devtools/python/python3-flexcache/run-ptest b/meta-python/recipes-devtools/python/python3-flexcache/run-ptest
new file mode 100644
index 0000000000..8d2017d39c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-flexcache/run-ptest
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-flexcache_0.3.bb b/meta-python/recipes-devtools/python/python3-flexcache_0.3.bb
index 509a6a42eb..165783c9f5 100644
--- a/meta-python/recipes-devtools/python/python3-flexcache_0.3.bb
+++ b/meta-python/recipes-devtools/python/python3-flexcache_0.3.bb
@@ -5,6 +5,21 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=32f547dac365c355d2cdbcd7ebea9144"
DEPENDS += "python3-setuptools-scm-native"
SRC_URI[sha256sum] = "18743bd5a0621bfe2cf8d519e4c3bfdf57a269c15d1ced3fb4b64e0ff4600656"
-inherit pypi python_setuptools_build_meta
+inherit pypi python_setuptools_build_meta ptest
PYPI_PACKAGE = "flexcache"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS:${PN}-ptest += " \
+ python3-pytest \
+ python3-unittest-automake-output \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/testsuite
+ cp -rf ${S}/flexcache/testsuite/* ${D}${PTEST_PATH}/testsuite/
+}
+
RDEPENDS:${PN} = "python3-typing-extensions"