aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2018-04-07 23:09:12 -0700
committerArmin Kuster <akuster808@gmail.com>2018-04-13 12:43:42 -0700
commit72d710cadcf0bc17fe676618daddbab8e1282fb2 (patch)
tree76160d6c2d8ddf5bd251b1881b2762d60cf69175
parent1eb1f5588146fcd4d555ecd2de420a7f8e186aa0 (diff)
downloadmeta-openembedded-contrib-72d710cadcf0bc17fe676618daddbab8e1282fb2.tar.gz
syslog-ng: refresh patches
WARNING: syslog-ng-3.8.1-r0 do_patch: Some of the context lines in patches were ignored. This can lead to incorrectly applied patches. The context lines in the patches can be updated with devtool: devtool modify <recipe> devtool finish --force-patch-refresh <recipe> <layer_path> Then the updated patches and the source tree (in devtool's workspace) should be reviewed to make sure the patches apply in the correct place and don't introduce duplicate lines (which can, and does happen when some of the context is ignored). Further information: http://lists.openembedded.org/pipermail/openembedded-core/2018-March/148675.html https://bugzilla.yoctoproject.org/show_bug.cgi?id=10450 Details: Applying patch configure.ac-add-option-enable-thread-tls-to-manage-.patch patching file configure.ac Hunk #1 succeeded at 147 with fuzz 2 (offset 27 lines). Hunk #2 succeeded at 489 (offset 105 lines). Now at patch configure.ac-add-option-enable-thread-tls-to-manage-.patch Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/syslog-ng/files/Fix-the-memory-leak-problem-when-HAVE_ENVIRON-defined.patch8
-rw-r--r--meta-oe/recipes-support/syslog-ng/files/configure.ac-add-option-enable-thread-tls-to-manage-.patch19
-rw-r--r--meta-oe/recipes-support/syslog-ng/files/fix-config-libnet.patch15
-rw-r--r--meta-oe/recipes-support/syslog-ng/files/fix-invalid-ownership.patch13
4 files changed, 24 insertions, 31 deletions
diff --git a/meta-oe/recipes-support/syslog-ng/files/Fix-the-memory-leak-problem-when-HAVE_ENVIRON-defined.patch b/meta-oe/recipes-support/syslog-ng/files/Fix-the-memory-leak-problem-when-HAVE_ENVIRON-defined.patch
index 2ac9c0be0f..5d481f232e 100644
--- a/meta-oe/recipes-support/syslog-ng/files/Fix-the-memory-leak-problem-when-HAVE_ENVIRON-defined.patch
+++ b/meta-oe/recipes-support/syslog-ng/files/Fix-the-memory-leak-problem-when-HAVE_ENVIRON-defined.patch
@@ -4,9 +4,11 @@ Upstream-Status: Pending
Signed-off-by: Xufeng Zhang <xufeng.zhang@windriver.com>
---
---- a/lib/gprocess.c
-+++ b/lib/gprocess.c
-@@ -1421,6 +1421,18 @@
+Index: syslog-ng-3.8.1/lib/gprocess.c
+===================================================================
+--- syslog-ng-3.8.1.orig/lib/gprocess.c
++++ syslog-ng-3.8.1/lib/gprocess.c
+@@ -1432,6 +1432,18 @@ g_process_startup_ok(void)
void
g_process_finish(void)
{
diff --git a/meta-oe/recipes-support/syslog-ng/files/configure.ac-add-option-enable-thread-tls-to-manage-.patch b/meta-oe/recipes-support/syslog-ng/files/configure.ac-add-option-enable-thread-tls-to-manage-.patch
index cc8d11044a..c172e4e747 100644
--- a/meta-oe/recipes-support/syslog-ng/files/configure.ac-add-option-enable-thread-tls-to-manage-.patch
+++ b/meta-oe/recipes-support/syslog-ng/files/configure.ac-add-option-enable-thread-tls-to-manage-.patch
@@ -10,13 +10,13 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
configure.ac | 17 +++++++++++------
1 file changed, 11 insertions(+), 6 deletions(-)
-diff --git a/configure.ac b/configure.ac
-index 474e094..cedca54 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -120,6 +120,9 @@ AC_ARG_ENABLE(memtrace,
- AC_ARG_ENABLE(ssl,
- [ --enable-ssl Enable SSL support.],,enable_ssl="auto")
+Index: syslog-ng-3.8.1/configure.ac
+===================================================================
+--- syslog-ng-3.8.1.orig/configure.ac
++++ syslog-ng-3.8.1/configure.ac
+@@ -147,6 +147,9 @@ AC_ARG_ENABLE(gprof,
+ AC_ARG_ENABLE(memtrace,
+ [ --enable-memtrace Enable alternative leak debugging code.])
+AC_ARG_ENABLE(thread-tls,
+ [ --enable-thread-tls Enable Thread Transport Layer Security support.],,enable_thread_tls="no")
@@ -24,7 +24,7 @@ index 474e094..cedca54 100644
AC_ARG_ENABLE(dynamic-linking,
[ --enable-dynamic-linking Link everything dynamically.],,enable_dynamic_linking="auto")
-@@ -381,12 +384,14 @@ dnl ***************************************************************************
+@@ -486,12 +489,14 @@ dnl ************************************
dnl Is the __thread keyword available?
dnl ***************************************************************************
@@ -45,6 +45,3 @@ index 474e094..cedca54 100644
dnl ***************************************************************************
dnl How to do static linking?
---
-1.9.1
-
diff --git a/meta-oe/recipes-support/syslog-ng/files/fix-config-libnet.patch b/meta-oe/recipes-support/syslog-ng/files/fix-config-libnet.patch
index 755803c213..553f4a5171 100644
--- a/meta-oe/recipes-support/syslog-ng/files/fix-config-libnet.patch
+++ b/meta-oe/recipes-support/syslog-ng/files/fix-config-libnet.patch
@@ -10,11 +10,11 @@ Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
configure.ac | 27 +++++++++++++++++----------
1 files changed, 17 insertions(+), 10 deletions(-)
-diff --git a/configure.ac b/configure.ac
-index b1e18b4..8e13025 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -73,6 +73,9 @@ AC_CONFIG_HEADERS(config.h)
+Index: syslog-ng-3.8.1/configure.ac
+===================================================================
+--- syslog-ng-3.8.1.orig/configure.ac
++++ syslog-ng-3.8.1/configure.ac
+@@ -104,6 +104,9 @@ AC_CONFIG_HEADERS(config.h)
dnl ***************************************************************************
dnl Arguments
@@ -24,7 +24,7 @@ index b1e18b4..8e13025 100644
AC_ARG_WITH(libnet,
[ --with-libnet=path use path to libnet-config script],
,
-@@ -768,22 +771,26 @@ dnl ***************************************************************************
+@@ -893,22 +896,26 @@ dnl ************************************
dnl libnet headers/libraries
dnl ***************************************************************************
AC_MSG_CHECKING(for LIBNET)
@@ -61,6 +61,3 @@ index b1e18b4..8e13025 100644
if test "x$enable_spoof_source" = "xauto"; then
AC_MSG_CHECKING(whether to enable spoof source support)
if test "x$LIBNET_LIBS" != "x"; then
---
-1.7.1
-
diff --git a/meta-oe/recipes-support/syslog-ng/files/fix-invalid-ownership.patch b/meta-oe/recipes-support/syslog-ng/files/fix-invalid-ownership.patch
index faf967247f..54ecce57e3 100644
--- a/meta-oe/recipes-support/syslog-ng/files/fix-invalid-ownership.patch
+++ b/meta-oe/recipes-support/syslog-ng/files/fix-invalid-ownership.patch
@@ -10,11 +10,11 @@ Signed-off-by: Ming Liu <ming.liu@windriver.com>
scl/Makefile.am | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
-diff --git a/scl/Makefile.am b/scl/Makefile.am
-index 57fad5d..2a29ca5 100644
---- a/scl/Makefile.am
-+++ b/scl/Makefile.am
-@@ -14,7 +14,7 @@ scl-install-data-local:
+Index: syslog-ng-3.8.1/scl/Makefile.am
+===================================================================
+--- syslog-ng-3.8.1.orig/scl/Makefile.am
++++ syslog-ng-3.8.1/scl/Makefile.am
+@@ -27,7 +27,7 @@ scl-install-data-local:
fi; \
done
$(mkinstalldirs) $(DESTDIR)/$(scldir)
@@ -23,6 +23,3 @@ index 57fad5d..2a29ca5 100644
chmod -R u+rwX $(DESTDIR)/$(scldir)
scl-uninstall-local:
---
-1.7.1
-