aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2023-10-19 00:19:07 +0200
committerMartin Jansa <martin.jansa@gmail.com>2024-04-14 20:55:40 +0200
commit704ee4ab2a8b6ae5b0637fd2bb9a75855a9a044c (patch)
tree324b9a960b3e3d298e4df68b519deb9fa5215e5c
parent67c993023d1e8a36113a33dca6f336e324621f47 (diff)
downloadmeta-openembedded-contrib-704ee4ab2a8b6ae5b0637fd2bb9a75855a9a044c.tar.gz
com.webos.app.minimal: drop all the debug output again and drop unused enact-dev-native
* it wasn't very useful in the end as io_uring calls didn't appear even in the strace -f -v anyway Signed-off-by: Martin Jansa <martin.jansa@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/nodejs/com.webos.app.minimal.bb17
-rw-r--r--meta-oe/recipes-devtools/nodejs/enact-dev-native.bb25
2 files changed, 2 insertions, 40 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/com.webos.app.minimal.bb b/meta-oe/recipes-devtools/nodejs/com.webos.app.minimal.bb
index 54a05a9407..c1fa2365a4 100644
--- a/meta-oe/recipes-devtools/nodejs/com.webos.app.minimal.bb
+++ b/meta-oe/recipes-devtools/nodejs/com.webos.app.minimal.bb
@@ -6,9 +6,7 @@ SRC_URI = "git://github.com/shr-project/com.webos.app.minimal;protocol=https;bra
"
S = "${WORKDIR}/git"
-DEPENDS = "nodejs-native strace-native"
-
-#export PSEUDO_DEBUG = "nfoPcvdDyerpswikVx"
+DEPENDS = "nodejs-native"
do_configure() {
:
@@ -18,19 +16,8 @@ do_compile() {
:
}
-#PSEUDO_IGNORE_PATHS = ""
-
do_install() {
-cat >webpack.config.js <<EOF
-module.exports = {
- infrastructureLogging: {
- level: 'verbose',
- debug: true,
- },
- stats: 'verbose'
-};
-EOF
- DEBUG=* NODE_DEBUG_NATIVE=* NODE_DEBUG=* strace -f -v ${STAGING_BINDIR_NATIVE}/node --trace-event-categories=node.fs.sync,node.fs.async,node,v8,node.async_hooks,node.bootstrap,node.console,node.threadpoolwork.sync,node.threadpoolwork.async,node.environment,node.fs_dir.sync,node.fs_dir.async,node.promises.rejections,node.vm.script node_modules/webpack-cli/bin/cli.js -o ${D}/test --mode=production --json=compilation-stats.json
+ ${STAGING_BINDIR_NATIVE}/node node_modules/webpack-cli/bin/cli.js -o ${D}/test
}
FILES:${PN} += "test"
diff --git a/meta-oe/recipes-devtools/nodejs/enact-dev-native.bb b/meta-oe/recipes-devtools/nodejs/enact-dev-native.bb
deleted file mode 100644
index d7413f28db..0000000000
--- a/meta-oe/recipes-devtools/nodejs/enact-dev-native.bb
+++ /dev/null
@@ -1,25 +0,0 @@
-LICENSE = "CLOSED"
-
-DEPENDS = "nodejs-native"
-
-inherit native
-
-SRC_URI = "git://github.com/enactjs/cli.git;branch=master;protocol=https;destsuffix=git/cli"
-S = "${WORKDIR}/git"
-
-PV = "6.0.1"
-SRCREV = "6f04791935d250337a081e327f6f90d503fe9c19"
-
-do_configure[noexec] = "1"
-
-do_compile[network] = "1"
-do_compile() {
- ${STAGING_BINDIR_NATIVE}/npm install -C ${S}/cli
-}
-
-do_install() {
- install -d ${D}${base_prefix}/opt
- cp -R --no-dereference --preserve=mode,links -v ${S}/* ${D}${base_prefix}/opt
-}
-
-SYSROOT_DIRS += "${base_prefix}/opt"