aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames Feist <james.feist@linux.intel.com>2018-10-11 13:47:04 -0700
committerKhem Raj <raj.khem@gmail.com>2018-10-11 13:52:06 -0700
commit69e5fa1485aa58ad1d664070b0d9e4db413fdd62 (patch)
treeef82c44632c22f40bb7f6f94719acd90ef062b4e
parente4baf298cd658b37fd90134dc54a92c75fd117d9 (diff)
downloadmeta-openembedded-contrib-69e5fa1485aa58ad1d664070b0d9e4db413fdd62.tar.gz
nlohmann-json: Add symlink to json.hpp and update to 3.3.0
nlohmann-json has examples in their repo that refer to the header as json.hpp directly, as such many packages that require nlohmann-json expect json.hpp and not nlohmann/json.hpp as the cmake file installs. Create symlink so that access is available by either option. Also update to release 3.3.0. Signed-off-by: James Feist <james.feist@linux.intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_git.bb10
1 files changed, 8 insertions, 2 deletions
diff --git a/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_git.bb b/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_git.bb
index a89b659ae8..65e49bc95b 100644
--- a/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_git.bb
+++ b/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_git.bb
@@ -6,9 +6,9 @@ LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=9a8ae1c2d606c432a2aa2e2de15be22a"
SRC_URI = "git://github.com/nlohmann/json.git"
-PV = "3.2.0+git${SRCPV}"
+PV = "3.3.0+git${SRCPV}"
-SRCREV = "8c20571136f2d5351b379a06ad6591bd980880fe"
+SRCREV = "aafad2be1f3cd259a1e79d2f6fcf267d1ede9ec7"
S = "${WORKDIR}/git"
@@ -21,3 +21,9 @@ EXTRA_OECMAKE += "-DJSON_BuildTests=OFF"
RDEPENDS_${PN}-dev = ""
BBCLASSEXTEND = "native nativesdk"
+
+# other packages commonly reference the file directly as "json.hpp"
+# create symlink to allow this usage
+do_install_append() {
+ ln -s nlohmann/json.hpp ${D}${includedir}/json.hpp
+}