aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2023-10-19 00:29:57 +0200
committerMartin Jansa <martin.jansa@gmail.com>2024-04-14 20:55:40 +0200
commit6255d57985a6fdbdffc5bbd800d0429549fe68c6 (patch)
treedf51a85a2655867c50cde01f2b3e0deee05c0f31
parentc9ea01149acebabdd01b9ecb19491c078bda0c85 (diff)
downloadmeta-openembedded-contrib-6255d57985a6fdbdffc5bbd800d0429549fe68c6.tar.gz
com.webos.app.minimal: add strace with -ff
* it would be interesting to compare the strace output with and without UV_USE_IO_URING (and no other changes)
-rw-r--r--meta-oe/recipes-devtools/nodejs/com.webos.app.minimal.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/com.webos.app.minimal.bb b/meta-oe/recipes-devtools/nodejs/com.webos.app.minimal.bb
index 722381d321..d50366843e 100644
--- a/meta-oe/recipes-devtools/nodejs/com.webos.app.minimal.bb
+++ b/meta-oe/recipes-devtools/nodejs/com.webos.app.minimal.bb
@@ -6,7 +6,7 @@ SRC_URI = "git://github.com/shr-project/com.webos.app.minimal;protocol=https;bra
"
S = "${WORKDIR}/git"
-DEPENDS = "nodejs-native"
+DEPENDS = "nodejs-native strace-native"
do_configure() {
:
@@ -18,7 +18,7 @@ do_compile() {
do_install() {
export UV_USE_IO_URING=0
- ${STAGING_BINDIR_NATIVE}/node node_modules/webpack-cli/bin/cli.js -o ${D}/test
+ strace -ff -v ${STAGING_BINDIR_NATIVE}/node node_modules/webpack-cli/bin/cli.js -o ${D}/test
}
FILES:${PN} += "test"