aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOvidiu Panait <ovidiu.panait@windriver.com>2018-07-12 15:38:50 +0800
committerKhem Raj <raj.khem@gmail.com>2018-07-12 08:12:03 -0700
commit41c23d32ca8bbaf27cf86905928baa5be07fff0f (patch)
tree2e92e593e1f824cb923acea122cb260f8d847dcb
parentdf080427eb2f1ce22f752535a769383b214b5989 (diff)
downloadmeta-openembedded-contrib-41c23d32ca8bbaf27cf86905928baa5be07fff0f.tar.gz
openhpi: close socket in saHpiSessionClose
Upstream issue: https://github.com/open-hpi/openhpi/issues/1918 The saHpiSessionClose doesn't close the socket and leaks the file descriptor. Signed-off-by: Catalin Enache <catalin.enache@windriver.com> Signed-off-by: Ovidiu Panait <ovidiu.panait@windriver.com> Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-daemons/openhpi/files/0001-session-close-socket.patch37
-rw-r--r--meta-networking/recipes-daemons/openhpi/openhpi_3.6.1.bb1
2 files changed, 38 insertions, 0 deletions
diff --git a/meta-networking/recipes-daemons/openhpi/files/0001-session-close-socket.patch b/meta-networking/recipes-daemons/openhpi/files/0001-session-close-socket.patch
new file mode 100644
index 0000000000..2cefd55be2
--- /dev/null
+++ b/meta-networking/recipes-daemons/openhpi/files/0001-session-close-socket.patch
@@ -0,0 +1,37 @@
+From b8bc6bfdb5e7fb5b46d3a830e04632939bee6b98 Mon Sep 17 00:00:00 2001
+From: Catalin Enache <catalin.enache@windriver.com>
+Date: Fri, 9 Feb 2018 16:35:11 +0200
+Subject: [PATCH] saHpiSessionClose: close socket
+
+saHpiSessionClose leaks file descriptors
+
+Upstream issue: https://github.com/open-hpi/openhpi/issues/1918
+
+Upstream-Status: Pending
+
+Signed-off-by: Catalin Enache <catalin.enache@windriver.com>
+Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
+---
+ baselib/session.cpp | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/baselib/session.cpp b/baselib/session.cpp
+index c5edfc8..4ece1b7 100644
+--- a/baselib/session.cpp
++++ b/baselib/session.cpp
+@@ -126,6 +126,12 @@ cSession::cSession()
+
+ cSession::~cSession()
+ {
++ cClientStreamSock * sock;
++ gpointer ptr = wrap_g_static_private_get( &m_sockets );
++ if ( ptr ) {
++ sock = reinterpret_cast<cClientStreamSock *>(ptr);
++ sock->Close();
++ }
+ wrap_g_static_private_free( &m_sockets );
+ }
+
+--
+2.10.2
+
diff --git a/meta-networking/recipes-daemons/openhpi/openhpi_3.6.1.bb b/meta-networking/recipes-daemons/openhpi/openhpi_3.6.1.bb
index ecf71d70f6..596578e118 100644
--- a/meta-networking/recipes-daemons/openhpi/openhpi_3.6.1.bb
+++ b/meta-networking/recipes-daemons/openhpi/openhpi_3.6.1.bb
@@ -44,6 +44,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.gz \
file://fix-narrowing-warning.patch \
file://0001-plugins-Check-for-PTHREAD_RECURSIVE_MUTEX_INITIALIZE.patch \
file://0001-ipmidirect-Replace-__STRING.patch \
+ file://0001-session-close-socket.patch \
"
SRC_URI[md5sum] = "4718b16e0f749b5ad214a9b04f45dd23"