aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2023-10-17 21:46:39 +0200
committerMartin Jansa <martin.jansa@gmail.com>2024-04-14 20:55:40 +0200
commit25a51b8cf12864a08ad8474c7c0a0c66de34ae46 (patch)
treed478115df0a672b3b3a603ca551ef6c73745044d
parent2744ce64240f0a8f969cdabe396746d0b4858097 (diff)
downloadmeta-openembedded-contrib-25a51b8cf12864a08ad8474c7c0a0c66de34ae46.tar.gz
com.webos.app.minimal: enable nodejs trace, NODE_DEBUG_NATIVE and disable PSEUDO_DEBUG
-rw-r--r--meta-oe/recipes-devtools/nodejs/com.webos.app.minimal.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/com.webos.app.minimal.bb b/meta-oe/recipes-devtools/nodejs/com.webos.app.minimal.bb
index a70ca3eea4..4b7f2bd65c 100644
--- a/meta-oe/recipes-devtools/nodejs/com.webos.app.minimal.bb
+++ b/meta-oe/recipes-devtools/nodejs/com.webos.app.minimal.bb
@@ -8,7 +8,7 @@ S = "${WORKDIR}/git"
DEPENDS = "nodejs-native"
-export PSEUDO_DEBUG = "nfoPcvdDyerpswikVx"
+#export PSEUDO_DEBUG = "nfoPcvdDyerpswikVx"
do_configure() {
:
@@ -19,7 +19,7 @@ do_compile() {
}
do_install() {
- NODE_DEBUG=* ${STAGING_BINDIR_NATIVE}/node node_modules/webpack-cli/bin/cli.js -o ${D}/test
+ NODE_DEBUG_NATIVE=* NODE_DEBUG=* ${STAGING_BINDIR_NATIVE}/node --trace-event-categories=node.fs.sync,node.fs.async,node,v8,node.async_hooks,node.bootstrap,node.console,node.threadpoolwork.sync,node.threadpoolwork.async,node.environment,node.fs_dir.sync,node.fs_dir.async,node.promises.rejections,node.vm.script node_modules/webpack-cli/bin/cli.js -o ${D}/test
}
FILES:${PN} += "test"