aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-04-11 15:10:48 -0700
committerKhem Raj <raj.khem@gmail.com>2024-04-11 23:32:36 -0700
commit04eefd302d58c403e011ad34d1d346703a364a53 (patch)
tree03b4838d73d3a4a5d79997dda19ddc666fb53598
parent95f914bd5e02d72d09288127625ff8a8eeab6235 (diff)
downloadmeta-openembedded-contrib-04eefd302d58c403e011ad34d1d346703a364a53.tar.gz
libxml++: Delete recipe for 2.42.1
We already have libxml++-5 provided and some of the dependencies for libxml++ (older version of glibmm) are not available. Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/conf/include/ptest-packagelists-meta-oe.inc1
-rw-r--r--meta-oe/recipes-core/libxml/libxml++/libxml++_ptest.patch80
-rw-r--r--meta-oe/recipes-core/libxml/libxml++/run-ptest3
-rw-r--r--meta-oe/recipes-core/libxml/libxml++_2.42.1.bb35
-rw-r--r--meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb1
5 files changed, 0 insertions, 120 deletions
diff --git a/meta-oe/conf/include/ptest-packagelists-meta-oe.inc b/meta-oe/conf/include/ptest-packagelists-meta-oe.inc
index 673b41f440..48f3412b7a 100644
--- a/meta-oe/conf/include/ptest-packagelists-meta-oe.inc
+++ b/meta-oe/conf/include/ptest-packagelists-meta-oe.inc
@@ -65,7 +65,6 @@ PTESTS_PROBLEMS_META_OE ="\
libdbi-perl \
libjcat \
libteam \
- libxml++ \
oprofile \
ostree \
psqlodbc \
diff --git a/meta-oe/recipes-core/libxml/libxml++/libxml++_ptest.patch b/meta-oe/recipes-core/libxml/libxml++/libxml++_ptest.patch
deleted file mode 100644
index 2172c147c3..0000000000
--- a/meta-oe/recipes-core/libxml/libxml++/libxml++_ptest.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-Upstream-Status: Pending
-
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -40,5 +40,8 @@ EXTRA_DIST = \
- tools/conf_tests/have_exception_ptr.cc \
- untracked/README
-
-+install-ptest:
-+ make -C examples install-ptest
-+
- # Optional: auto-generate the ChangeLog file from the git log on make dist
- include $(top_srcdir)/build/dist-changelog.am
---- a/examples/Makefile.am
-+++ b/examples/Makefile.am
-@@ -19,6 +19,8 @@ AM_CPPFLAGS = -I$(top_builddir) -I$(top_
- AM_CXXFLAGS = $(LIBXMLXX_WXXFLAGS)
- LDADD = $(top_builddir)/libxml++/libxml++-$(LIBXMLXX_API_VERSION).la $(LIBXMLXX_LIBS)
-
-+LOG_DRIVER = $(SHELL) ../macros/test-driver
-+
- check_PROGRAMS = \
- dom_build/dom_build \
- dom_parse_entities/dom_parse_entities \
-@@ -37,6 +39,23 @@ check_PROGRAMS = \
- schemavalidation/schemavalidation \
- textreader/textreader
-
-+check_DOTLIBS = \
-+ dom_build/.libs/dom_build \
-+ dom_parse_entities/.libs/dom_parse_entities \
-+ dom_parser/.libs/dom_parser \
-+ dom_parser_raw/.libs/dom_parser_raw \
-+ dom_read_write/.libs/dom_read_write \
-+ dom_xinclude/.libs/dom_xinclude \
-+ dom_xpath/.libs/dom_xpath \
-+ dtdvalidation/.libs/dtdvalidation \
-+ import_node/.libs/import_node \
-+ sax_exception/.libs/sax_exception \
-+ sax_parser/.libs/sax_parser \
-+ sax_parser_build_dom/.libs/sax_parser_build_dom \
-+ sax_parser_entities/.libs/sax_parser_entities \
-+ schemavalidation/.libs/schemavalidation \
-+ textreader/.libs/textreader
-+
- # Shell scripts that call the example programs.
- check_SCRIPTS = \
- dom_build/make_check.sh \
-@@ -154,10 +173,10 @@ dist_noinst_DATA = \
- # file are located in different directories.
- dom_read_write/make_check.sh: Makefile
- $(AM_V_GEN)echo '# Generated and used by "make check"' >$@
-- $(AM_V_at)echo 'dom_read_write/dom_read_write "$(srcdir)/dom_read_write/example.xml" dom_read_write/example_output.xml >/dev/null' >>$@
-+ $(AM_V_at)echo 'cd dom_read_write && .libs/dom_read_write "example.xml" example_output.xml >/dev/null' >>$@
- $(AM_V_at)chmod +x $@
-
--script_template = cd "$(srcdir)/<!progname!>" && "$(abs_builddir)/<!progname!>/<!progname!>" >/dev/null
-+script_template = cd "<!progname!>" && ".libs/<!progname!>" >/dev/null
- standard_scripts = $(filter-out dom_read_write/make_check.sh,$(check_SCRIPTS))
-
- # All other script files are generated like so:
-@@ -169,3 +188,18 @@ $(standard_scripts): Makefile
- CLEANFILES = \
- dom_read_write/example_output.xml \
- $(check_SCRIPTS)
-+
-+buildtest: all
-+ $(MAKE) $(AM_MAKEFLAGS) $(check_PROGRAMS) $(check_SCRIPTS)
-+ $(MAKE) $(AM_MAKEFLAGS) buildtest-TESTS
-+
-+install-ptest:
-+ $(MKDIR_P) $(DESTDIR)/examples
-+ cp --parents $(check_DOTLIBS) $(DESTDIR)/examples
-+ cp --parents $(check_SCRIPTS) $(DESTDIR)/examples
-+ cd $(srcdir) && cp --parents $(dist_noinst_DATA) $(DESTDIR)/examples
-+ cp Makefile $(DESTDIR)/examples
-+ $(MKDIR_P) $(DESTDIR)/macros
-+ cp $(top_srcdir)/build/test-driver $(DESTDIR)/macros
-+ sed -i -e 's|^Makefile:|_Makefile:|' $(DESTDIR)/examples/Makefile
-+
diff --git a/meta-oe/recipes-core/libxml/libxml++/run-ptest b/meta-oe/recipes-core/libxml/libxml++/run-ptest
deleted file mode 100644
index 236f667538..0000000000
--- a/meta-oe/recipes-core/libxml/libxml++/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-cd examples
-make -k check-TESTS
diff --git a/meta-oe/recipes-core/libxml/libxml++_2.42.1.bb b/meta-oe/recipes-core/libxml/libxml++_2.42.1.bb
deleted file mode 100644
index 7347e30f34..0000000000
--- a/meta-oe/recipes-core/libxml/libxml++_2.42.1.bb
+++ /dev/null
@@ -1,35 +0,0 @@
-SUMMARY = "C++ wrapper for libxml library"
-DESCRIPTION = "C++ wrapper for libxml library"
-HOMEPAGE = "http://libxmlplusplus.sourceforge.net"
-BUGTRACKER = "http://bugzilla.gnome.org/buglist.cgi?product=libxml%2B%2B"
-SECTION = "libs"
-LICENSE = "LGPL-2.1-or-later"
-LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34 "
-
-SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"
-SRC_URI = "${GNOME_MIRROR}/${BPN}/${SHRT_VER}/${BP}.tar.xz \
- file://libxml++_ptest.patch \
- file://run-ptest \
-"
-SRC_URI[sha256sum] = "9b59059abe5545d28ceb388a55e341095f197bd219c73e6623aeb6d801e00be8"
-
-DEPENDS = "libxml2 glibmm mm-common-native"
-
-inherit autotools pkgconfig ptest
-
-EXTRA_OECONF = "--disable-documentation"
-
-do_configure:prepend() {
- mm-common-prepare --copy --force ${S}
-}
-
-do_compile_ptest() {
- oe_runmake -C examples buildtest
-}
-
-PTEST_PARALLEL_MAKE = ""
-
-FILES:${PN}-doc += "${datadir}/devhelp"
-FILES:${PN}-dev += "${libdir}/libxml++-2.6/include/libxml++config.h"
-
-RDEPENDS:${PN}-ptest += "make"
diff --git a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
index bc15373b65..8a63f5b203 100644
--- a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
+++ b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
@@ -184,7 +184,6 @@ RDEPENDS:packagegroup-meta-oe-core = "\
libnfc \
libsigc++-2.0 \
libsigc++-3 \
- libxml++ \
mdbus2 \
distro-feed-configs \
mm-common \