aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Arnold <stephen.arnold42@gmail.com>2016-01-26 17:29:21 -0800
committerArmin Kuster <akuster808@gmail.com>2016-04-17 12:42:43 -0700
commit8b03f47c22d8104bb0a1613c0db77c37ac891d8a (patch)
treea4658942a19db83a4034c0ef1c4fb17563bf9cf1
parentbeaa9a80c435f1fabd13c38a365804714338e66e (diff)
downloadmeta-openembedded-contrib-8b03f47c22d8104bb0a1613c0db77c37ac891d8a.tar.gz
net-snmp: fix cross-compile breakage, add libnl pkgconfig option
This patch enhances a previously unapplied patch on jethro, plus adds some flexibility in terms of required deps and a few cleanups. Signed-off-by: Stephen Arnold <stephen.arnold42@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb10
1 files changed, 8 insertions, 2 deletions
diff --git a/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb b/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb
index b32d842de9..93eb0252d2 100644
--- a/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb
+++ b/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb
@@ -27,7 +27,7 @@ SRC_URI[sha256sum] = "e8dfc79b6539b71a6ff335746ce63d2da2239062ad41872fff4354cafe
inherit autotools update-rc.d siteinfo systemd pkgconfig
-EXTRA_OEMAKE = "INSTALL_PREFIX=${D}"
+EXTRA_OEMAKE = "INSTALL_PREFIX=${D} OTHERLDFLAGS='${LDFLAGS}' HOST_CPPFLAGS='${BUILD_CPPFLAGS}'"
PARALLEL_MAKE = ""
CCACHE = ""
@@ -36,12 +36,13 @@ TARGET_CC_ARCH += "${LDFLAGS}"
PACKAGECONFIG ??= ""
PACKAGECONFIG[elfutils] = "--with-elf, --without-elf, elfutils"
+PACKAGECONFIG[libnl] = "--with-nl, --without-nl, libnl"
EXTRA_OECONF = "--disable-embedded-perl \
--with-perl-modules=no \
- --enable-shared \
--disable-manuals \
--with-defaults \
+ --with-install-prefix=${D} \
--with-persistent-directory=${localstatedir}/lib/net-snmp \
${@base_conditional('SITEINFO_ENDIANNESS', 'le', '--with-endianness=little', '--with-endianness=big', d)}"
@@ -51,10 +52,15 @@ EXTRA_OECONF += "--with-mib-modules=smux"
CACHED_CONFIGUREVARS = " \
ac_cv_header_valgrind_valgrind_h=no \
ac_cv_header_valgrind_memcheck_h=no \
+ ac_cv_ETC_MNTTAB=/etc/mtab \
+ lt_cv_shlibpath_overrides_runpath=yes \
"
do_configure_prepend() {
export PERLPROG="${bindir}/env perl"
+ sed -i -e "s|I/usr/include|I${STAGING_INCDIR}|g" \
+ "${S}"/configure \
+ "${S}"/configure.d/config_os_libs2
}
do_install_append() {