aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-11-15 22:01:31 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2013-12-30 13:31:48 +0100
commit96992c9e80f42104fc893f867ff89e72a0c20245 (patch)
treeca4c1142101ddd31d409e1f795b67a2a1525643a
parentc49357a5a572abb4ad4e41906887238d503a233a (diff)
downloadmeta-openembedded-contrib-96992c9e80f42104fc893f867ff89e72a0c20245.tar.gz
rfkill: Fix build when WORKDIR is included in some git checkout
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-connectivity/rfkill/rfkill/dont.call.git.rev-parse.on.parent.dir.patch31
-rw-r--r--meta-oe/recipes-connectivity/rfkill/rfkill_0.4.bb3
2 files changed, 33 insertions, 1 deletions
diff --git a/meta-oe/recipes-connectivity/rfkill/rfkill/dont.call.git.rev-parse.on.parent.dir.patch b/meta-oe/recipes-connectivity/rfkill/rfkill/dont.call.git.rev-parse.on.parent.dir.patch
new file mode 100644
index 0000000000..2b83689127
--- /dev/null
+++ b/meta-oe/recipes-connectivity/rfkill/rfkill/dont.call.git.rev-parse.on.parent.dir.patch
@@ -0,0 +1,31 @@
+When WORKDIR is included in some other git checkout, version.sh calls git rev-parse
+and it returns some description from that upper git checkout even when rfkill is
+being built from release tarball.
+
+When returned description doesn't match with expected v0.4, version.sh exits
+without creating version.c
+ # on git builds check that the version number above
+ # is correct...
+ [ "${descr%%-*}" = "v$VERSION" ] || exit 2
+
+and build fails a bit later:
+ | NOTE: make -j 32 -e MAKEFLAGS=
+ | CC rfkill.o
+ | GEN version.c
+ | make: *** [version.c] Error 2
+ | make: *** Waiting for unfinished jobs....
+ | ERROR: oe_runmake failed
+
+Don't try git rev-parse, if there isn't .git in ${S}.
+
+--- a/version.sh 2013-11-15 03:43:12.587744366 -0800
++++ b/version.sh 2013-11-15 03:42:40.699743320 -0800
+@@ -12,7 +12,7 @@
+
+ if test "x$SUFFIX" != 'x'; then
+ v="$VERSION$SUFFIX"
+-elif head=`git rev-parse --verify HEAD 2>/dev/null`; then
++elif test -d .git && head=`git rev-parse --verify HEAD 2>/dev/null`; then
+ git update-index --refresh --unmerged > /dev/null
+ descr=$(git describe 2>/dev/null || echo "v$VERSION")
+
diff --git a/meta-oe/recipes-connectivity/rfkill/rfkill_0.4.bb b/meta-oe/recipes-connectivity/rfkill/rfkill_0.4.bb
index f90736dff0..1c2930a5cd 100644
--- a/meta-oe/recipes-connectivity/rfkill/rfkill_0.4.bb
+++ b/meta-oe/recipes-connectivity/rfkill/rfkill_0.4.bb
@@ -6,7 +6,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=c6036d0eb7edbfced28c4160e5d3fa94"
PR = "r1"
SRC_URI = "http://wireless.kernel.org/download/${PN}/${P}.tar.bz2 \
- file://0001-rfkill-makefile-don-t-use-t-the-OE-install-wrapper-d.patch"
+ file://0001-rfkill-makefile-don-t-use-t-the-OE-install-wrapper-d.patch \
+ file://dont.call.git.rev-parse.on.parent.dir.patch"
SRC_URI[md5sum] = "727892c0fb35c80ee3849fbe89b45350"
SRC_URI[sha256sum] = "ca10e4827a5f0a36e093aee6ad81b5febf81f8097d7d858889ac51ff364168c1"