aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2019-05-17 21:49:19 +0000
committerKhem Raj <raj.khem@gmail.com>2019-05-20 09:49:00 -0700
commitd776e6e353ba2f34b2fef6b83a887735e85b9f1f (patch)
treeb405e2b94747a815c929e51aa07f9edc3f3dc191
parente7eacaecbd581ca2cc98f3e21667f4b3448f67d4 (diff)
downloadmeta-openembedded-contrib-d776e6e353ba2f34b2fef6b83a887735e85b9f1f.tar.gz
triggerhappy: fix issues
* using PN instead of BPN in S causes all tasks to fail: make: *** No targets specified and no makefile found. Stop. * using github archives is bad, because they are regenerated from time to time with different checksums * set PV, because this isn't exactly 0.5.0, because of the debian changes mostly the systemd support * fix indentation Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/triggerhappy/triggerhappy_git.bb (renamed from meta-oe/recipes-extended/triggerhappy/triggerhappy_0.5.0.bb)22
1 files changed, 11 insertions, 11 deletions
diff --git a/meta-oe/recipes-extended/triggerhappy/triggerhappy_0.5.0.bb b/meta-oe/recipes-extended/triggerhappy/triggerhappy_git.bb
index 037ce063e1..24df750e01 100644
--- a/meta-oe/recipes-extended/triggerhappy/triggerhappy_0.5.0.bb
+++ b/meta-oe/recipes-extended/triggerhappy/triggerhappy_git.bb
@@ -4,12 +4,12 @@ HOMEPAGE = "https://github.com/wertarbyte/triggerhappy"
LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
-SRC_URI = "https://github.com/wertarbyte/triggerhappy/archive/debian/0.5.0-1.tar.gz"
+# matches debian/0.5.0-1 tag
+SRCREV = "44a173195986d0d853316cb02a58785ded66c12b"
+PV = "0.5.0+git${SRCPV}"
+SRC_URI = "git://github.com/wertarbyte/${BPN}.git;branch=debian"
-SRC_URI[md5sum] = "77f90a18c775e47c4c5e9e08987ca32f"
-SRC_URI[sha256sum] = "9150bafbf7f2de7d57e6cc154676c33da98dc11ac6442e1ca57e5dce82bd4292"
-
-S = "${WORKDIR}/${PN}-debian-${PV}-1"
+S = "${WORKDIR}/git"
inherit autotools-brokensep pkgconfig update-rc.d systemd
@@ -21,12 +21,12 @@ INITSCRIPT_PARAMS = "defaults"
SYSTEMD_SERVICE_${PN} = "triggerhappy.service triggerhappy.socket"
FILES_${PN} = "\
-${sbindir}/thd \
-${sbindir}/th-cmd \
-${sysconfdir}/triggerhappy/triggers.d \
-${nonarch_base_libdir}/udev/rules.d/80-triggerhappy.rules \
-${sysconfdir}/init.d/triggerhappy \
-${systemd_unitdir}/system \
+ ${sbindir}/thd \
+ ${sbindir}/th-cmd \
+ ${sysconfdir}/triggerhappy/triggers.d \
+ ${nonarch_base_libdir}/udev/rules.d/80-triggerhappy.rules \
+ ${sysconfdir}/init.d/triggerhappy \
+ ${systemd_unitdir}/system \
"
CONFFILES_${PN} = "${sysconfdir}/udev/rules.d/80-triggerhappy.rules"