aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-11-18 20:55:29 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2012-11-29 11:04:53 +0100
commit9b3ae30b8ccac10bf84091d2d5754e85236c7272 (patch)
treeb50b81a28a476a084ac44f7fc54c43aae0d2b35a
parentc39af8cb6fd8d678258c6cafbd7f7635d8f71600 (diff)
downloadmeta-openembedded-contrib-9b3ae30b8ccac10bf84091d2d5754e85236c7272.tar.gz
e-wm: add work around for illume2 issues from r78978
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-efl/recipes-efl/e17/e-wm_svn.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/meta-efl/recipes-efl/e17/e-wm_svn.bb b/meta-efl/recipes-efl/e17/e-wm_svn.bb
index 615e0f2ce9..3faa387cd4 100644
--- a/meta-efl/recipes-efl/e17/e-wm_svn.bb
+++ b/meta-efl/recipes-efl/e17/e-wm_svn.bb
@@ -4,7 +4,7 @@ LICENSE = "MIT BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=76de290eb3fdda12121830191c152a7d"
SRCNAME = "e"
PV = "0.16.999.060+svnr${SRCPV}"
-PR = "r7"
+PR = "r8"
SRCREV = "${EFL_SRCREV}"
inherit e update-alternatives gettext
@@ -46,6 +46,13 @@ do_install_append() {
install -m 644 ${WORKDIR}/applications.menu ${D}/${sysconfdir}/xdg/menus/
for I in `find ${D}/${libdir}/enlightenment -name "*.a" -print`; do rm -f $I; done
for I in `find ${D}/${libdir}/enlightenment -name "*.la" -print`; do rm -f $I; done
+
+ # work around for issue caused in r78978, more infor in:
+ # http://sourceforge.net/mailarchive/forum.php?thread_name=20121118194904.GA3438%40jama.jama.net&forum_name=enlightenment-devel
+ mv ${D}/${libdir}/enlightenment/modules/policies ${D}/${libdir}/enlightenment/modules/illume2/ \
+ || echo "illume2 policies are in correct place now"
+ mv ${D}/${libdir}/enlightenment/modules/keyboards ${D}/${libdir}/enlightenment/modules/illume2/ \
+ || echo "illume2 keyboards are in correct place now"
}
RDEPENDS_${PN} += "\