aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-05-17 09:30:42 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2012-05-17 09:30:42 +0200
commit86321c31730f5d6159b93da8278c9e00a4c92b14 (patch)
tree8f20a41c83fd75a8ab077d7fa2d87240f04a6037
parent690a67b2d75d0cd44a0004c5db40c7b6e952a106 (diff)
downloadmeta-openembedded-contrib-86321c31730f5d6159b93da8278c9e00a4c92b14.tar.gz
meta-systemd: add layer
This is where the systemd related recipes and appends are going to live Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--meta-systemd/README20
-rw-r--r--meta-systemd/conf/layer.conf28
2 files changed, 48 insertions, 0 deletions
diff --git a/meta-systemd/README b/meta-systemd/README
new file mode 100644
index 0000000000..efed2eece8
--- /dev/null
+++ b/meta-systemd/README
@@ -0,0 +1,20 @@
+This layer depends on:
+
+URI: git://git.openembedded.org/openembedded-core
+branch: master
+revision: HEAD
+
+And we're working to break the dependency on this one:
+
+URI: git://git.openembedded.org/meta-openembedded
+branch: master
+revision: HEAD
+
+Send pull requests to openembedded-devel@lists.openembedded.org with '[meta-oe][meta-systemd]' in the subject'
+
+When sending single patches, please use something like 'git send-email -1 --to openembedded-devel@lists.openembedded.org --subject-prefix=meta-oe][meta-systemd][PATCH'
+
+You are encouraged to fork the mirror on github https://github.com/openembedded/meta-oe/ to share your patches, this is preferred for patch sets consisting of more than one patch. Other services like gitorious, repo.or.cz or self hosted setups are of course accepted as well, 'git fetch <remote>' works the same on all of them. We recommend github because it is free, easy to use, has been proven to be reliable and has a really good web GUI.
+
+Main layer maintainer: Koen Kooi <koen@dominion.thruhere.net>
+
diff --git a/meta-systemd/conf/layer.conf b/meta-systemd/conf/layer.conf
new file mode 100644
index 0000000000..d07d2aded0
--- /dev/null
+++ b/meta-systemd/conf/layer.conf
@@ -0,0 +1,28 @@
+# It really depends on order of the layers appearing in BBLAYERS
+# variable in toplevel bblayers.conf file, where bitbake will search
+# for .inc files and others where bitbake uses BBPATH since it will
+# search the directories from first to last as specified in BBPATH
+# Therefore if you want a given layer to be considered high priority
+# for the .inc and .conf etc. then consider it adding at the beginning
+# of BBPATH. For bblayers bitbake will use BBFILES_PRIORITY to resolve
+# the recipe contention so the order of directories in BBFILES does
+# not matter.
+
+# We have a conf and classes directory, append to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have a recipes directory, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "systemd-layer"
+BBFILE_PATTERN_systemd := "^${LAYERDIR}/"
+
+# Define the priority for recipes (.bb files) from this layer,
+# choosing carefully how this layer interacts with all of the
+# other layers.
+
+BBFILE_PRIORITY_systemd-layer = "7"
+
+SIGGEN_EXCLUDERECIPES_ABISAFE += " \
+ systemd-serialgetty \
+"