aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-01-31 17:38:58 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-02-01 08:24:08 +0100
commit6396ac4454d2d8096f9622bb6979834f9d649085 (patch)
treef4b34016a70db442a5dd4eee7245039b7ad4a9a7
parentc029d4a268de1ac7076fbeb9e337e96fdb1b226d (diff)
downloadmeta-openembedded-contrib-6396ac4454d2d8096f9622bb6979834f9d649085.tar.gz
busybox: fix busybox-syslog systemd service file
The service file had the 'Wants' in 'Service' group instead of the 'Unit' group. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--meta-oe/recipes-core/busybox/busybox/busybox-syslog.service.in2
-rw-r--r--meta-oe/recipes-core/busybox/busybox_1.19.3.bbappend2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-core/busybox/busybox/busybox-syslog.service.in b/meta-oe/recipes-core/busybox/busybox/busybox-syslog.service.in
index db90082596..27b9831da0 100644
--- a/meta-oe/recipes-core/busybox/busybox/busybox-syslog.service.in
+++ b/meta-oe/recipes-core/busybox/busybox/busybox-syslog.service.in
@@ -1,12 +1,12 @@
[Unit]
Description=System Logging Service
+Wants=busybox-klogd.service
[Service]
ExecStartPre=/bin/systemctl stop systemd-kmsg-syslogd.service
EnvironmentFile=-/etc/default/busybox-syslog
ExecStart=@base_sbindir@/syslogd -n $OPTIONS
Sockets=syslog.socket
-Wants=busybox-klogd.service
[Install]
WantedBy=multi-user.target
diff --git a/meta-oe/recipes-core/busybox/busybox_1.19.3.bbappend b/meta-oe/recipes-core/busybox/busybox_1.19.3.bbappend
index 46177e3dd4..7e72a43a44 100644
--- a/meta-oe/recipes-core/busybox/busybox_1.19.3.bbappend
+++ b/meta-oe/recipes-core/busybox/busybox_1.19.3.bbappend
@@ -1,6 +1,6 @@
inherit systemd
-PRINC := "${@int(PRINC) + 1}"
+PRINC := "${@int(PRINC) + 2}"
# look for files in the layer first
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"