aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-08-01 11:51:02 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2012-08-07 12:21:23 +0200
commit878a0c84727a3f709400a93289bef7025432a946 (patch)
treed005d8384da1480ce5dc6a8c9f339e01fadaf846
parent910feab3e7cae1a74562c930be032566824968eb (diff)
downloadmeta-openembedded-contrib-878a0c84727a3f709400a93289bef7025432a946.tar.gz
python-pyqt: import from oe-classic
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/python/python-pyqt-4.8.4/assistantclient-fix.patch13
-rw-r--r--meta-oe/recipes-devtools/python/python-pyqt-4.8.4/fix_qthelp_ftbfs.diff15
-rw-r--r--meta-oe/recipes-devtools/python/python-pyqt-4.8.4/fix_the_QAssitant_ftbfs.diff29
-rw-r--r--meta-oe/recipes-devtools/python/python-pyqt-4.8.4/pyqt-generated.patch24
-rw-r--r--meta-oe/recipes-devtools/python/python-pyqt-4.8.4/qreal_float_support.diff248
-rw-r--r--meta-oe/recipes-devtools/python/python-pyqt_4.8.4.bb115
6 files changed, 444 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-pyqt-4.8.4/assistantclient-fix.patch b/meta-oe/recipes-devtools/python/python-pyqt-4.8.4/assistantclient-fix.patch
new file mode 100644
index 0000000000..15f83d23b0
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-pyqt-4.8.4/assistantclient-fix.patch
@@ -0,0 +1,13 @@
+Index: PyQt-x11-gpl-4.8.3/sip/QtAssistant/qassistantclient.sip
+===================================================================
+--- PyQt-x11-gpl-4.8.3.orig/sip/QtAssistant/qassistantclient.sip
++++ PyQt-x11-gpl-4.8.3/sip/QtAssistant/qassistantclient.sip
+@@ -33,7 +33,7 @@
+ class QAssistantClient : QObject
+ {
+ %TypeHeaderCode
+-#include <qassistantclient.h>
++#include <QtAssistant/qassistantclient.h>
+ %End
+
+ %ConvertToSubClassCode
diff --git a/meta-oe/recipes-devtools/python/python-pyqt-4.8.4/fix_qthelp_ftbfs.diff b/meta-oe/recipes-devtools/python/python-pyqt-4.8.4/fix_qthelp_ftbfs.diff
new file mode 100644
index 0000000000..e7a68829ad
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-pyqt-4.8.4/fix_qthelp_ftbfs.diff
@@ -0,0 +1,15 @@
+Description: Fix QtHelp FTBFS with ld --no-add-needed.
+Author: Felix Geyer <debfx-pkg@fobos.de>
+
+--- python-qt4-4.8.1.orig/configure.py
++++ python-qt4-4.8.1/configure.py
+@@ -364,7 +364,8 @@ class ConfigurePyQt4:
+ pyqt_modules.append("QtCore")
+
+ check_module("QtGui", "qwidget.h", "new QWidget()")
+- check_module("QtHelp", "qhelpengine.h", "new QHelpEngine(\"foo\")")
++ check_module("QtHelp", "qhelpengine.h", "new QHelpEngine(\"foo\")",
++ extra_libs=["QtCore"])
+ check_module("QtMultimedia", "QAudioDeviceInfo",
+ "new QAudioDeviceInfo()")
+ check_module("QtNetwork", "qhostaddress.h", "new QHostAddress()")
diff --git a/meta-oe/recipes-devtools/python/python-pyqt-4.8.4/fix_the_QAssitant_ftbfs.diff b/meta-oe/recipes-devtools/python/python-pyqt-4.8.4/fix_the_QAssitant_ftbfs.diff
new file mode 100644
index 0000000000..96e3062471
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-pyqt-4.8.4/fix_the_QAssitant_ftbfs.diff
@@ -0,0 +1,29 @@
+From aa85ab2be6be7cb3c4df68139a8271fc4c8c11c8 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Picca=20Fr=C3=A9d=C3=A9ric-Emmanuel?= <picca@synchrotron-soleil.fr>
+Date: Tue, 1 Mar 2011 21:49:23 +0100
+Subject: [PATCH] * fix the QAssitant ftbfs
+
+---
+ configure.py | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.py b/configure.py
+index 7ed9582..185ec9f 100644
+--- a/configure.py
++++ b/configure.py
+@@ -354,10 +354,10 @@ class ConfigurePyQt4:
+
+ if opts.mwg_ssl_dir:
+ ass_lib_dirs = [os.path.join(opts.mwg_ssl_dir, "lib")]
+- ass_libs = ["ssleay32", "libeay32"]
++ ass_libs = ["ssleay32", "libeay32", "QtCore"]
+ else:
+ ass_lib_dirs = None
+- ass_libs = None
++ ass_libs = ["QtCore"]
+
+ # Note that the order in which we check is important for the
+ # consolidated module - a module's dependencies must be checked first.
+--
+1.7.4.1
+
diff --git a/meta-oe/recipes-devtools/python/python-pyqt-4.8.4/pyqt-generated.patch b/meta-oe/recipes-devtools/python/python-pyqt-4.8.4/pyqt-generated.patch
new file mode 100644
index 0000000000..0af5549535
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-pyqt-4.8.4/pyqt-generated.patch
@@ -0,0 +1,24 @@
+diff -uNr PyQt-x11-gpl-4.8.4.orig/QtGui/sipQtGuiQSystemTrayIcon.cpp PyQt-x11-gpl-4.8.4/QtGui/sipQtGuiQSystemTrayIcon.cpp
+--- PyQt-x11-gpl-4.8.4.orig/QtGui/sipQtGuiQSystemTrayIcon.cpp 2012-08-01 16:37:34.000000000 +0200
++++ PyQt-x11-gpl-4.8.4/QtGui/sipQtGuiQSystemTrayIcon.cpp 2012-08-01 17:05:45.000000000 +0200
+@@ -957,8 +957,6 @@
+ qtgui_untrack(sipCpp);
+ #line 959 "QtGui/sipQtGuiQSystemTrayIcon.cpp"
+
+- QSystemTrayIcon *sipCpp = reinterpret_cast<QSystemTrayIcon *>(sipCppV);
+-
+ if (QThread::currentThread() == sipCpp->thread())
+ delete sipCpp;
+ else
+diff -uNr PyQt-x11-gpl-4.8.4.orig/QtGui/sipQtGuiQGraphicsScene.cpp PyQt-x11-gpl-4.8.4/QtGui/sipQtGuiQGraphicsScene.cpp
+--- PyQt-x11-gpl-4.8.4.orig/QtGui/sipQtGuiQGraphicsScene.cpp 2012-08-01 16:37:35.000000000 +0200
++++ PyQt-x11-gpl-4.8.4/QtGui/sipQtGuiQGraphicsScene.cpp 2012-08-01 17:26:58.000000000 +0200
+@@ -4016,8 +4016,6 @@
+ qtgui_untrack(sipCpp);
+ #line 4018 "QtGui/sipQtGuiQGraphicsScene.cpp"
+
+- QGraphicsScene *sipCpp = reinterpret_cast<QGraphicsScene *>(sipCppV);
+-
+ if (QThread::currentThread() == sipCpp->thread())
+ delete sipCpp;
+ else
diff --git a/meta-oe/recipes-devtools/python/python-pyqt-4.8.4/qreal_float_support.diff b/meta-oe/recipes-devtools/python/python-pyqt-4.8.4/qreal_float_support.diff
new file mode 100644
index 0000000000..abdf70fab0
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-pyqt-4.8.4/qreal_float_support.diff
@@ -0,0 +1,248 @@
+## 03_qreal_float_support.dpatch by Michael Casadevall <sonicmctails@gmail.com>
+Index: python-qt4-4.8.3/configure.py
+===================================================================
+--- python-qt4-4.8.3.orig/configure.py 2011-02-24 10:33:30.000000000 +0200
++++ python-qt4-4.8.3/configure.py 2011-02-24 10:33:18.000000000 +0200
+@@ -2004,8 +2004,9 @@
+ out << "PyQt_NoOpenGLES\\n";
+ #endif
+
+- if (sizeof (qreal) != sizeof (double))
++#if defined(QT_NO_FPU) || defined(QT_ARCH_ARM) || defined(QT_ARCH_WINDOWSCE)
+ out << "PyQt_qreal_double\\n";
++#endif
+
+ return 0;
+ }
+Index: python-qt4-4.8.3/sip/QtCore/qlist.sip
+===================================================================
+--- python-qt4-4.8.3.orig/sip/QtCore/qlist.sip 2011-02-24 10:33:27.000000000 +0200
++++ python-qt4-4.8.3/sip/QtCore/qlist.sip 2011-02-24 10:33:18.000000000 +0200
+@@ -811,3 +811,227 @@
+ return sipGetState(sipTransferObj);
+ %End
+ };
++
++// If we're on an architecture where qreal != double, then we need to also
++// explicately handle doubles. On architectures where qreal == double, they
++// will automaticially be cast upwards
++
++%If (!PyQt_qreal_double)
++
++%If (Qt_4_3_0 -)
++// QList<QPair<double, double> > is implemented as a Python list of 2-element tuples.
++%MappedType QList<QPair<double, double> >
++{
++%TypeHeaderCode
++#include <qlist.h>
++#include <qpair.h>
++%End
++
++%ConvertFromTypeCode
++ // Create the list.
++ PyObject *l;
++
++ if ((l = PyList_New(sipCpp->size())) == NULL)
++ return NULL;
++
++ // Set the list elements.
++ for (int i = 0; i < sipCpp->size(); ++i)
++ {
++ const QPair<double, double> &p = sipCpp->at(i);
++ PyObject *pobj;
++
++ if ((pobj = Py_BuildValue((char *)"dd", p.first, p.second)) == NULL)
++ {
++ Py_DECREF(l);
++
++ return NULL;
++ }
++
++ PyList_SET_ITEM(l, i, pobj);
++ }
++
++ return l;
++%End
++
++%ConvertToTypeCode
++ SIP_SSIZE_T len;
++
++ // Check the type if that is all that is required.
++ if (sipIsErr == NULL)
++ {
++ if (!PySequence_Check(sipPy) || (len = PySequence_Size(sipPy)) < 0)
++ return 0;
++
++ for (SIP_SSIZE_T i = 0; i < len; ++i)
++ {
++ PyObject *tup = PySequence_ITEM(sipPy, i);
++
++ if (!PySequence_Check(tup) || PySequence_Size(tup) != 2)
++ return 0;
++ }
++
++ return 1;
++ }
++
++ QList<QPair<double, double> > *ql = new QList<QPair<double, double> >;
++ len = PySequence_Size(sipPy);
++
++ for (SIP_SSIZE_T i = 0; i < len; ++i)
++ {
++ PyObject *tup = PySequence_ITEM(sipPy, i);
++
++ double first = PyFloat_AsDouble(PySequence_ITEM(tup, 0));
++ double second = PyFloat_AsDouble(PySequence_ITEM(tup, 1));
++
++ ql->append(QPair<double, double>(first, second));
++ }
++
++ *sipCppPtr = ql;
++
++ return sipGetState(sipTransferObj);
++%End
++};
++%End
++%If (Qt_4_3_0 -)
++// QList<QPair<double, TYPE> > is implemented as a Python list of 2-element tuples.
++template<double, TYPE>
++%MappedType QList<QPair<double, TYPE> >
++{
++%TypeHeaderCode
++#include <qlist.h>
++#include <qpair.h>
++%End
++
++%ConvertFromTypeCode
++ // Create the list.
++ PyObject *l;
++
++ if ((l = PyList_New(sipCpp->size())) == NULL)
++ return NULL;
++
++ // Set the list elements.
++ for (int i = 0; i < sipCpp->size(); ++i)
++ {
++ const QPair<double, TYPE> &p = sipCpp->at(i);
++ TYPE *t = new TYPE(p.second);
++ PyObject *pobj;
++
++ if ((pobj = sipBuildResult(NULL, "(dB)", p.first, t, sipClass_TYPE, sipTransferObj)) == NULL)
++ {
++ Py_DECREF(l);
++ delete t;
++
++ return NULL;
++ }
++
++ PyList_SET_ITEM(l, i, pobj);
++ }
++
++ return l;
++%End
++
++%ConvertToTypeCode
++ SIP_SSIZE_T len;
++
++ // Check the type if that is all that is required.
++ if (sipIsErr == NULL)
++ {
++ if (!PySequence_Check(sipPy) || (len = PySequence_Size(sipPy)) < 0)
++ return 0;
++
++ for (SIP_SSIZE_T i = 0; i < len; ++i)
++ {
++ PyObject *tup = PySequence_ITEM(sipPy, i);
++
++ if (!PySequence_Check(tup) || PySequence_Size(tup) != 2)
++ return 0;
++
++ if (!sipCanConvertToInstance(PySequence_ITEM(tup, 1), sipClass_TYPE, SIP_NOT_NONE))
++ return 0;
++ }
++
++ return 1;
++ }
++
++ QList<QPair<double, TYPE> > *ql = new QList<QPair<double, TYPE> >;
++ len = PySequence_Size(sipPy);
++
++ for (SIP_SSIZE_T i = 0; i < len; ++i)
++ {
++ PyObject *tup = PySequence_ITEM(sipPy, i);
++ double d;
++ int state;
++
++ d = PyFloat_AsDouble(PySequence_ITEM(tup, 0));
++ TYPE *t = reinterpret_cast<TYPE *>(sipConvertToInstance(PySequence_ITEM(tup, 1), sipClass_TYPE, sipTransferObj, SIP_NOT_NONE, &state, sipIsErr));
++
++ if (*sipIsErr)
++ {
++ sipReleaseInstance(t, sipClass_TYPE, state);
++
++ delete ql;
++ return 0;
++ }
++
++ ql->append(QPair<double, TYPE>(d, *t));
++
++ sipReleaseInstance(t, sipClass_TYPE, state);
++ }
++
++ *sipCppPtr = ql;
++
++ return sipGetState(sipTransferObj);
++%End
++};
++%End
++
++// QList<double> is implemented as a Python list of doubles.
++%MappedType QList<double>
++{
++%TypeHeaderCode
++#include <qlist.h>
++%End
++
++%ConvertFromTypeCode
++ // Create the list.
++ PyObject *l;
++
++ if ((l = PyList_New(sipCpp->size())) == NULL)
++ return NULL;
++
++ // Set the list elements.
++ for (int i = 0; i < sipCpp->size(); ++i)
++ {
++ PyObject *pobj;
++
++ if ((pobj = PyFloat_FromDouble(sipCpp->value(i))) == NULL)
++ {
++ Py_DECREF(l);
++
++ return NULL;
++ }
++
++ PyList_SET_ITEM(l, i, pobj);
++ }
++
++ return l;
++%End
++
++%ConvertToTypeCode
++ // Check the type if that is all that is required.
++ if (sipIsErr == NULL)
++ return (PySequence_Check(sipPy) && PySequence_Size(sipPy) >= 0);
++
++ QList<double> *ql = new QList<double>;
++ SIP_SSIZE_T len = PySequence_Size(sipPy);
++
++ for (SIP_SSIZE_T i = 0; i < len; ++i)
++ ql->append(PyFloat_AsDouble(PySequence_ITEM(sipPy, i)));
++
++ *sipCppPtr = ql;
++
++ return sipGetState(sipTransferObj);
++%End
++};
++
++%End
diff --git a/meta-oe/recipes-devtools/python/python-pyqt_4.8.4.bb b/meta-oe/recipes-devtools/python/python-pyqt_4.8.4.bb
new file mode 100644
index 0000000000..8bae09eef5
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-pyqt_4.8.4.bb
@@ -0,0 +1,115 @@
+DESCRIPTION = "Python Qt4 Bindings"
+HOMEPAGE = "http://riverbankcomputing.co.uk"
+AUTHOR = "Phil Thomson @ riverbank.co.uk"
+SECTION = "devel/python"
+LICENSE = "GPLv2 & GPLv3 & GPL_EXCEPTION"
+LIC_FILES_CHKSUM = "\
+ file://GPL_EXCEPTION.TXT;md5=b73b0be471db679533dc94781c14af58 \
+ file://GPL_EXCEPTION_ADDENDUM.TXT;md5=c1e04ec2aa0911061005a801abf81e40 \
+ file://OPENSOURCE-NOTICE.TXT;md5=6ad9123620cc04a22c394753ad4767d7 \
+ file://LICENSE-MERGED-GPL2-GPL3;md5=53ced8933428255115039368cdca0aef \
+ file://LICENSE.GPL2;md5=59bccd9d4dcaae9e668798337b91a022 \
+ file://LICENSE.GPL3;md5=da83bb3624af9ff4808aa9ffc49fc582 \
+"
+
+DEPENDS = "sip-native python-sip"
+RDEPENDS_${PN} = "python-core"
+SRCNAME = "pyqt"
+
+PYQT_OE_VERSION = "Qt_4_7_1"
+
+SRC_URI = "\
+ http://www.riverbankcomputing.co.uk/static/Downloads/PyQt4/PyQt-x11-gpl-${PV}.tar.gz \
+ \
+ file://fix_qthelp_ftbfs.diff \
+ file://fix_the_QAssitant_ftbfs.diff \
+ file://assistantclient-fix.patch \
+ file://pyqt-generated.patch;apply=no \
+"
+SRC_URI[md5sum] = "97c5dc1042feb5b3fe20baabad055af1"
+SRC_URI[sha256sum] = "fcfa3ecc0b4fad6d93227751b36a6f81ea104ee19dd26905f52de59f060b3e98"
+S = "${WORKDIR}/PyQt-x11-gpl-${PV}"
+
+# arm and mips machines need some extra patches
+SRC_URI_append_arm = "\
+ file://qreal_float_support.diff \
+"
+
+SRC_URI_append_mipsel = "\
+ file://qreal_float_support.diff \
+"
+
+inherit qt4x11 sip distutils-base
+
+PARALLEL_MAKE = ""
+
+QMAKE_PROFILES = "pyqt.pro"
+# NOTE: has to match with MIN(qt version we have in OE, last known Qt version by SIP/PyQt)
+EXTRA_SIPTAGS = "-tWS_X11 -t${PYQT_OE_VERSION} -xVendorID -xPyQt_SessionManager -xPyQt_Accessibility"
+EXTRA_OEMAKE = " MAKEFLAGS= "
+
+# arm and mips need extra params for the qreal issue
+EXTRA_SIPTAGS_append_arm = " -x PyQt_qreal_double"
+EXTRA_SIPTAGS_append_mipsel = " -x PyQt_qreal_double"
+
+SIP_MODULES = "QtCore QtDeclarative QtGui QtNetwork QtSql QtSvg QtXml QtWebKit"
+MAKE_MODULES = "qpy ${SIP_MODULES}"
+
+EXTRA_QMAKEVARS_POST += "\
+ INCLUDEPATH+=${OE_QMAKE_INCDIR_QT}/Qt \
+ INCLUDEPATH+=${STAGING_INCDIR}/${PYTHON_DIR} \
+ INCLUDEPATH+=../qpy/QtCore \
+ INCLUDEPATH+=../qpy/QtGui \
+ INCLUDEPATH+=../qpy/QtDeclarative \
+ INCLUDEPATH+=${OE_QMAKE_INCDIR_QT}/QtCore \
+ INCLUDEPATH+=${OE_QMAKE_INCDIR_QT}/QtGui \
+ INCLUDEPATH+=${OE_QMAKE_INCDIR_QT}/QtDeclarative \
+ INCLUDEPATH+=${OE_QMAKE_INCDIR_QT}/QtWebKit \
+ INCLUDEPATH+=${OE_QMAKE_INCDIR_QT}/QtNetwork \
+"
+FIX_QREAL = "\
+"
+
+do_generate_prepend() {
+ for i in ${FIX_QREAL}; do
+ sed -i -e s,qreal,float,g sip/$i
+ done
+}
+
+do_configure_prepend() {
+ printf "TEMPLATE=subdirs\nSUBDIRS=${MAKE_MODULES}\n" >pyqt.pro
+ printf "TEMPLATE=subdirs\nSUBDIRS=QtCore QtDeclarative QtGui\n" >qpy/qpy.pro
+ ln -sf ./qpycore.pro qpy/QtCore/QtCore.pro
+ ln -sf ./qpydeclarative.pro qpy/QtDeclarative/QtDeclarative.pro
+ ln -sf ./qpygui.pro qpy/QtGui/QtGui.pro
+ echo "INCLUDEPATH+=${S}/QtCore" >>qpy/QtCore/QtCore.pro
+ echo "INCLUDEPATH+=${S}/QtGui" >>qpy/QtGui/QtGui.pro
+ echo "INCLUDEPATH+=${S}/QtDeclarative" >>qpy/QtDeclarative/QtDeclarative.pro
+ echo "LIBS+=-L../qpy/QtGui/ -lqpygui" >>QtGui/QtGui.pro
+ echo "LIBS+=-L../qpy/QtCore/ -lqpycore" >>QtCore/QtCore.pro
+ echo "LIBS+=-L../qpy/QtDeclarative/ -lqpydeclarative" >>QtDeclarative/QtDeclarative.pro
+ # hack for broken generated code (duplicated sipCpp declaration).
+ patch -p1 < ${WORKDIR}/pyqt-generated.patch
+}
+
+do_install() {
+ install -d ${D}${libdir}/${PYTHON_DIR}/site-packages/PyQt4
+ for module in ${SIP_MODULES}
+ do
+ echo "from PyQt4.${module} import *\n" >> ${D}${libdir}/${PYTHON_DIR}/site-packages/PyQt4/Qt.py
+ install -m 0755 ${module}/lib${module}.so ${D}${libdir}/${PYTHON_DIR}/site-packages/PyQt4/${module}.so
+ done
+ cp -pPR elementtree ${D}${libdir}/${PYTHON_DIR}/site-packages/PyQt4/
+ cp __init__.py ${D}${libdir}/${PYTHON_DIR}/site-packages/PyQt4/
+
+ install -d ${STAGING_SIPDIR}/qt/
+ install -d ${STAGING_LIBDIR}/${PYTHON_DIR}/site-packages
+ for module in ${SIP_MODULES}
+ do
+ install -m 0644 ${S}/sip/${module}/*.sip ${STAGING_SIPDIR}/qt/
+ install -m 0755 ${module}/lib${module}.so ${STAGING_LIBDIR}/${PYTHON_DIR}/site-packages/${module}.so
+ done
+}
+
+FILES_${PN} = "${libdir}/${PYTHON_DIR}/site-packages"
+