aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2012-08-07 11:08:50 +0200
committerDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2012-08-07 16:48:55 +0200
commit4f16b77efe96d5a089c24ce670de9e784ee59bd5 (patch)
treea07f2ed3c01d3f356182f62138c6265b5dbba66d
parent3734e39ff57795d2e40a0ac2add0d7e15fe404c5 (diff)
downloadmeta-openembedded-contrib-4f16b77efe96d5a089c24ce670de9e784ee59bd5.tar.gz
gpsd: update to 3.7
Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org>
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd/0002-SConstruct-respect-sysroot-also-in-SPLINTOPTS_for_3.7.patch30
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd/0004-SConstruct-remove-rpath_for_3.7.patch42
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd_3.7.bb (renamed from meta-oe/recipes-navigation/gpsd/gpsd_3.5.bb)12
3 files changed, 77 insertions, 7 deletions
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd/0002-SConstruct-respect-sysroot-also-in-SPLINTOPTS_for_3.7.patch b/meta-oe/recipes-navigation/gpsd/gpsd/0002-SConstruct-respect-sysroot-also-in-SPLINTOPTS_for_3.7.patch
new file mode 100644
index 0000000000..40baa01947
--- /dev/null
+++ b/meta-oe/recipes-navigation/gpsd/gpsd/0002-SConstruct-respect-sysroot-also-in-SPLINTOPTS_for_3.7.patch
@@ -0,0 +1,30 @@
+From f5f262be8ae54bd0c0f52802f2007ec89163756f Mon Sep 17 00:00:00 2001
+From: Martin Jansa <Martin.Jansa@gmail.com>
+Date: Tue, 24 Apr 2012 11:52:35 +0200
+Subject: [PATCH 1/2] SConstruct: respect sysroot also in SPLINTOPTS
+
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org>
+---
+ SConstruct | 5 ++++-
+ 1 files changed, 4 insertions(+), 1 deletions(-)
+
+diff --git a/SConstruct b/SConstruct
+index a25e88a..a1bddb9 100644
+--- a/SConstruct
++++ b/SConstruct
+@@ -1277,7 +1277,10 @@ def Utility(target, source, action):
+
+ # Report splint warnings
+ # Note: test_bits.c is unsplintable because of the PRI64 macros.
+-splintopts = "-I/usr/include/libusb-1.0 +quiet"
++if not env['sysroot']:
++ splintopts = "-I/usr/include/libusb-1.0 +quiet"
++else:
++ splintopts = "-I%s/usr/include/libusb-1.0 +quiet" % env['sysroot']
+ # splint does not know about multi-arch, work around that
+ ma_status, ma = _getstatusoutput('dpkg-architecture -qDEB_HOST_MULTIARCH')
+ if ma_status == 0:
+--
+1.7.5.4
+
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd/0004-SConstruct-remove-rpath_for_3.7.patch b/meta-oe/recipes-navigation/gpsd/gpsd/0004-SConstruct-remove-rpath_for_3.7.patch
new file mode 100644
index 0000000000..83b98bb5ed
--- /dev/null
+++ b/meta-oe/recipes-navigation/gpsd/gpsd/0004-SConstruct-remove-rpath_for_3.7.patch
@@ -0,0 +1,42 @@
+From 7d736bbd517c12d19d7b85a5b0db84732b2f86da Mon Sep 17 00:00:00 2001
+From: Martin Jansa <Martin.Jansa@gmail.com>
+Date: Tue, 24 Apr 2012 16:24:35 +0200
+Subject: [PATCH 2/2] SConstruct: remove rpath
+
+* even with correct prefix (without DESTDIR) included it's redundant
+ WARNING: QA Issue: libgps:
+ /work/armv4t-oe-linux-gnueabi/gpsd/gpsd-3.5-r0/packages-split/libgps/usr/lib/libgps.so.20.0
+ contains probably-redundant RPATH /usr/lib
+* and with prefix from scons.bbclass it's invalid
+ WARNING: QA Issue: package libgps contains bad RPATH
+ /OE/shr-core/tmp-eglibc/work/armv4t-oe-linux-gnueabi/gpsd/gpsd-3.5-r0/image/usr/lib
+ in file
+ /OE/shr-core/tmp-eglibc/work/armv4t-oe-linux-gnueabi/gpsd/gpsd-3.5-r0/packages-split/libgps/usr/lib/libgps.so.20.0
+
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org>
+---
+ SConstruct | 7 +++++--
+ 1 files changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/SConstruct b/SConstruct
+index a1bddb9..3e7c607 100644
+--- a/SConstruct
++++ b/SConstruct
+@@ -1205,8 +1205,11 @@ if qt_env:
+
+ # We don't use installdir here in order to avoid having DESTDIR affect the rpath
+ if env["shared"] and env["chrpath"]:
+- env.AddPostAction(binaryinstall, '$CHRPATH -r "%s" "$TARGET"' \
+- % (installdir('libdir', False), ))
++ if not env['sysroot']:
++ env.AddPostAction(binaryinstall, '$CHRPATH -r "%s" "$TARGET"' \
++ % (installdir('libdir', False), ))
++ else:
++ env.AddPostAction(binaryinstall, '$CHRPATH -d "$TARGET"')
+
+ if not env['debug'] and not env['profiling'] and env['strip']:
+ env.AddPostAction(binaryinstall, '$STRIP $TARGET')
+--
+1.7.5.4
+
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.5.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.7.bb
index 1e3ac0cfe2..af08ceb53f 100644
--- a/meta-oe/recipes-navigation/gpsd/gpsd_3.5.bb
+++ b/meta-oe/recipes-navigation/gpsd/gpsd_3.7.bb
@@ -5,21 +5,19 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d217a23f408e91c94359447735bc1800"
DEPENDS = "dbus dbus-glib ncurses python libusb1 chrpath-native"
PROVIDES = "virtual/gpsd"
-PR = "r5"
+PR = "r0"
SRC_URI = "http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz \
- file://0001-SConstruct-respect-sysroot-setting-when-prepending-L.patch \
- file://0002-SConstruct-respect-sysroot-also-in-SPLINTOPTS.patch \
- file://0003-Revert-The-strptime-prototype-is-not-provided-unless.patch \
- file://0004-SConstruct-remove-rpath.patch \
+ file://0002-SConstruct-respect-sysroot-also-in-SPLINTOPTS_for_3.7.patch \
+ file://0004-SConstruct-remove-rpath_for_3.7.patch \
file://0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch \
file://0001-SConstruct-disable-html-and-man-docs-building-becaus.patch \
file://gpsd-default \
file://gpsd \
file://60-gpsd.rules \
"
-SRC_URI[md5sum] = "e96881798a0ab67aa3cd5f3249f0e536"
-SRC_URI[sha256sum] = "5ebb0b00c49421eb8fbead81342e5ce63e82065e5ff27da586f10e342b999171"
+SRC_URI[md5sum] = "52d9785eaf1a51298bb8900dbde88f98"
+SRC_URI[sha256sum] = "7800c478ee9d7ca7a502b0f892828561b1fbf7bc69d9d38c447c82c3628302ac"
inherit scons update-rc.d python-dir pythonnative