aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2012-07-24 17:55:38 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-07-25 09:18:12 +0200
commit3b38fe66a86e4db8d5427dc600912c481b529372 (patch)
tree65257a385704b831051c41febc5e26b2cd87eea0
parentaf95968d96d3e943b2a33134727f48017b6885c4 (diff)
downloadmeta-openembedded-contrib-3b38fe66a86e4db8d5427dc600912c481b529372.tar.gz
netperf: correct paths in the example scripts
Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--meta-oe/recipes-benchmark/netperf/netperf_2.4.4.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/netperf/netperf_2.4.4.bb b/meta-oe/recipes-benchmark/netperf/netperf_2.4.4.bb
index 6a3a81c514..15174ca29f 100644
--- a/meta-oe/recipes-benchmark/netperf/netperf_2.4.4.bb
+++ b/meta-oe/recipes-benchmark/netperf/netperf_2.4.4.bb
@@ -13,6 +13,8 @@ SRC_URI="ftp://ftp.netperf.org/netperf/archive/netperf-${PV}.tar.bz2 \
SRC_URI[md5sum] = "0e942f22864e601406a994420231075b"
SRC_URI[sha256sum] = "28e76af491ea3696885e4558ae2f5628a4b9ebdbefc2f1d9cf1b35db2813e497"
+PR = "r1"
+
inherit update-rc.d autotools
S = "${WORKDIR}/netperf-${PV}"
@@ -20,6 +22,14 @@ S = "${WORKDIR}/netperf-${PV}"
# cpu_set.patch plus _GNU_SOURCE makes src/netlib.c compile with CPU_ macros
CFLAGS_append = " -DDO_UNIX -DDO_IPV6 -D_GNU_SOURCE"
+do_configure_prepend () {
+ sed -i -e 's,^ *NETHOME=.*$,NETHOME=${bindir},' \
+ -e 's,^ *NETPERF=\./netperf$,NETPERF=${bindir}/netperf,' \
+ -e 's,^ *NETPERF=/usr/bin/netperf$,NETPERF=${bindir}/netperf,' \
+ -e 's,^ *NETPERF_CMD=.*$,NETPERF_CMD=${bindir}/netperf,' \
+ doc/examples/*_script
+}
+
do_install() {
install -d ${D}${sbindir} ${D}${bindir} ${D}${sysconfdir}/init.d
install -m 4755 src/netperf ${D}${bindir}