aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnders Darander <anders@chargestorm.se>2012-04-11 06:17:01 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-04-11 11:10:32 +0200
commit21b04f590feb7dbd9e5932153b3ec46e38ecaecb (patch)
treea7bb07fb82eaacb43ee204e11395a1f66f94529e
parent8a9e1dc63d9aadb3da17edfd31da9ccf833bfeb1 (diff)
downloadmeta-openembedded-contrib-21b04f590feb7dbd9e5932153b3ec46e38ecaecb.tar.gz
sqlite: cp instead of mv in do_configure
The use of mv in do_configure() made bitbake error out if a second run of do_configure was requested. Copy the file instead. Signed-off-by: Anders Darander <anders@chargestorm.se> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--meta-oe/recipes-support/sqlite/sqlite_2.8.17.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/sqlite/sqlite_2.8.17.bb b/meta-oe/recipes-support/sqlite/sqlite_2.8.17.bb
index b8e03c4d87..733bb9e0f7 100644
--- a/meta-oe/recipes-support/sqlite/sqlite_2.8.17.bb
+++ b/meta-oe/recipes-support/sqlite/sqlite_2.8.17.bb
@@ -22,7 +22,7 @@ inherit autotools pkgconfig
do_configure() {
echo "main.mk is patched, no need to configure"
# make pkgconfig.bbclass pick this up
- mv ${WORKDIR}/sqlite.pc ${S}
+ cp ${WORKDIR}/sqlite.pc ${S}
}
do_compile() {