aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhiquan Li <zhiquan.li@windriver.com>2015-10-23 18:07:35 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-11-11 10:47:20 +0100
commitf08b9e8e7d9740f8353d70aa9c2a0989951bed1d (patch)
treef256771c2b0870adc71020ca8e37f80a1c575536
parent4a680e64f4570d38ffdfca51b67e6347ac91a361 (diff)
downloadmeta-openembedded-contrib-f08b9e8e7d9740f8353d70aa9c2a0989951bed1d.tar.gz
snort: fix m4 causes out of memory during configure
There is an incorrect m4_define() in configure.in which will result in an infinite recursion, and it doesn't make sense, since snort 2.9.7 it has been commented out. We follow this solution to fix it. Signed-off-by: Zhiquan Li <zhiquan.li@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-networking/recipes-connectivity/snort/snort/m4-oom-during-configure.patch21
-rw-r--r--meta-networking/recipes-connectivity/snort/snort_2.9.6.0.bb16
2 files changed, 24 insertions, 13 deletions
diff --git a/meta-networking/recipes-connectivity/snort/snort/m4-oom-during-configure.patch b/meta-networking/recipes-connectivity/snort/snort/m4-oom-during-configure.patch
new file mode 100644
index 0000000000..2250611536
--- /dev/null
+++ b/meta-networking/recipes-connectivity/snort/snort/m4-oom-during-configure.patch
@@ -0,0 +1,21 @@
+Upstream-Status: Backport
+
+There is an incorrect m4_define() in configure.in which will result in an
+infinite recursion, and it doesn't make sense, since snort 2.9.7 it has been
+commented out. We follow this solution to fix it.
+
+Signed-off-by: Zhiquan Li <zhiquan.li@windriver.com>
+
+--- a/configure.in 2015-10-22 13:58:50.743367251 +0800
++++ b/configure.in 2015-10-22 13:59:13.855366117 +0800
+@@ -1100,8 +1100,8 @@
+ # Define PKG_CHECK_MODULES if it doesnt already exist.
+ #file_ This prevents './configure' from erroring on machines that dont have
+ # 'pkgconfig' installed.
+-m4_ifdef([PKG_CHECK_MODULES],[], [m4_define([PKG_CHECK_MODULES],
+- [echo "PKG_CHECK_MODULES not defined"])])
++#m4_ifdef([PKG_CHECK_MODULES],[], [m4_define([PKG_CHECK_MODULES],
++# [echo "PKG_CHECK_MODULES not defined"])])
+
+ if test "x$enable_rzb_saac" = "xyes"; then
+ AC_CHECK_PROG(PKG_CONFIG,pkg-config,yes)
diff --git a/meta-networking/recipes-connectivity/snort/snort_2.9.6.0.bb b/meta-networking/recipes-connectivity/snort/snort_2.9.6.0.bb
index 66653c6c38..65dc524a86 100644
--- a/meta-networking/recipes-connectivity/snort/snort_2.9.6.0.bb
+++ b/meta-networking/recipes-connectivity/snort/snort_2.9.6.0.bb
@@ -6,19 +6,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=78fa8ef966b48fbf9095e13cc92377c5"
DEPENDS = "libpcap libpcre daq libdnet util-linux"
-# Blacklist:
-#
-# http://errors.yoctoproject.org/Errors/Details/8936/
-#
-# snort failure is again very nasty, because it's m4 which eats all
-# available memory and swap before it's killed by OOM killer.
-#
-# Luckily it always picked m4
-#
-# [Wed Feb 18 19:00:51 2015] Out of memory: Kill process 28522 (m4) score 961 or sacrifice child
-# [Wed Feb 18 19:10:51 2015] Out of memory: Kill process 45228 (m4) score 958 or sacrifice child
-# ...
-PNBLACKLIST[snort] ?= "BROKEN: autotools processing causes OOM condition on configure"
SRC_URI = " ${GENTOO_MIRROR}/${BP}.tar.gz;name=tarball \
file://snort.init \
@@ -26,6 +13,7 @@ SRC_URI = " ${GENTOO_MIRROR}/${BP}.tar.gz;name=tarball \
file://disable-dap-address-space-id.patch \
file://0001-libpcap-search-sysroot-for-headers.patch \
file://not-hardcoded-libdir.patch \
+ file://m4-oom-during-configure.patch \
"
SRC_URI[tarball.md5sum] = "18111f6de3989ca89add36077a7c2659"
@@ -45,6 +33,8 @@ EXTRA_OECONF = " \
--disable-static-daq \
--with-dnet-includes=${STAGING_INCDIR} \
--with-dnet-libraries=${STAGING_LIBDIR} \
+ --with-libpcre-includes=${STAGING_INCDIR} \
+ --with-libpcre-libraries=${STAGING_INCDIR} \
"
# if you want to disable it, you need to patch configure.in first