aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoralperak <alperyasinak1@gmail.com>2024-03-08 08:51:34 +0300
committerKhem Raj <raj.khem@gmail.com>2024-03-08 10:07:29 -0800
commita5fd08e401cbfe835206cc3305cb0ce954671aa3 (patch)
treef2aca3b032cb771bc06edbe8d6f370f8e93767b5
parent8cf55e279fd08f71f281fc8e5f2dabd638d3fa79 (diff)
downloadmeta-openembedded-contrib-a5fd08e401cbfe835206cc3305cb0ce954671aa3.tar.gz
python3-pytest-localserver: added recipe which is also include ptest
pytest-localserver is a plugin for the pytest testing framework which enables you to test server connections locally. * Tested on qemux86-64 and qemuarm64 * Add ptest into PTESTS_SLOW_META_PYTHON Ptest result: ============== qemux86-64: Testsuite summary TOTAL: 55 PASS: 54 SKIP: 1 XFAIL: 0 FAIL: 0 XPASS: 0 ERROR: 0 DURATION: 44 END: /usr/lib/python3-pytest-localserver/ptest 2024-03-07T20:33 STOP: ptest-runner TOTAL: 1 FAIL: 0 qemuarm64: Testsuite summary TOTAL: 55 PASS: 54 SKIP: 1 XFAIL: 0 FAIL: 0 XPASS: 0 ERROR: 0 DURATION: 38 END: /usr/lib/python3-pytest-localserver/ptest 2024-03-07T20:41 STOP: ptest-runner TOTAL: 1 FAIL: 0 Signed-off-by: alperak <alperyasinak1@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/conf/include/ptest-packagelists-meta-python.inc1
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-localserver/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-localserver_0.8.1.bb29
3 files changed, 33 insertions, 0 deletions
diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc b/meta-python/conf/include/ptest-packagelists-meta-python.inc
index 20ca2763c6..ce5ccf22d5 100644
--- a/meta-python/conf/include/ptest-packagelists-meta-python.inc
+++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc
@@ -80,6 +80,7 @@ PTESTS_SLOW_META_PYTHON = "\
python3-arrow \
python3-lz4 \
python3-marshmallow \
+ python3-pytest-localserver \
python3-traitlets \
python3-yappi \
"
diff --git a/meta-python/recipes-devtools/python/python3-pytest-localserver/run-ptest b/meta-python/recipes-devtools/python/python3-pytest-localserver/run-ptest
new file mode 100644
index 0000000000..8d2017d39c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-localserver/run-ptest
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-pytest-localserver_0.8.1.bb b/meta-python/recipes-devtools/python/python3-pytest-localserver_0.8.1.bb
new file mode 100644
index 0000000000..669817829d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-localserver_0.8.1.bb
@@ -0,0 +1,29 @@
+SUMMARY = "pytest plugin to test server connections locally."
+HOMEPAGE = "https://github.com/pytest-dev/pytest-localserver"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b8da7a541d738b054dcbf70c31530432"
+
+DEPENDS += "python3-setuptools-scm-native"
+
+inherit pypi python_setuptools_build_meta ptest
+
+SRC_URI[sha256sum] = "66569c34fef31a5750b16effd1cd1288a7a90b59155d005e7f916accd3dee4f1"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS:${PN}-ptest += " \
+ python3-pytest \
+ python3-requests \
+ python3-unittest-automake-output \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
+
+RDEPENDS:${PN} += " \
+ python3-werkzeug \
+"