aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan McGregor <dan.mcgregor@usask.ca>2016-03-04 08:47:58 -0600
committerDan McGregor <dan.mcgregor@usask.ca>2016-07-06 12:57:45 -0600
commit46d1cb456f1c090e87e59207722361b80249fcca (patch)
tree4b179518a913540a077d17820aff5bd2a70fedf3
parent5ab2a7f670f8ddf23563029ade68af877404c3fb (diff)
downloadmeta-openembedded-contrib-46d1cb456f1c090e87e59207722361b80249fcca.tar.gz
python-cryptography: update to 1.2.3
-rw-r--r--meta-python/recipes-devtools/python/python-cryptography-vectors_1.2.3.bb14
-rw-r--r--meta-python/recipes-devtools/python/python-cryptography_1.2.3.bb49
2 files changed, 63 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-cryptography-vectors_1.2.3.bb b/meta-python/recipes-devtools/python/python-cryptography-vectors_1.2.3.bb
new file mode 100644
index 0000000000..43e91f4b1a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-cryptography-vectors_1.2.3.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Test vectors for the cryptography package."
+SECTION = "devel/python"
+LICENSE = "Apache-2.0 | BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4"
+DEPENDS = "python-cryptography"
+SRCNAME = "cryptography_vectors"
+
+SRC_URI = "https://pypi.python.org/packages/source/c/cryptography-vectors/${SRCNAME}-${PV}.tar.gz"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+SRC_URI[md5sum] = "3c16f3dd4dc5d38b42d889b10b8b379d"
+SRC_URI[sha256sum] = "71f2757ea5444c228d7db6c3808ff658bd44a91e612820b3dc2f9daeeee30a6a"
+
+inherit setuptools
diff --git a/meta-python/recipes-devtools/python/python-cryptography_1.2.3.bb b/meta-python/recipes-devtools/python/python-cryptography_1.2.3.bb
new file mode 100644
index 0000000000..b8357e2a7c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-cryptography_1.2.3.bb
@@ -0,0 +1,49 @@
+SUMMARY = "Provides cryptographic recipes and primitives to Python developers"
+LICENSE = "Apache-2.0 | BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4"
+DEPENDS += " python-cffi-native python-cffi python-enum34 python-six python-pyasn1"
+SRCNAME = "cryptography"
+
+SRC_URI = "file://run-ptest"
+
+SRC_URI[md5sum] = "5474d2b3e8c7555a60852e48d2743f85"
+SRC_URI[sha256sum] = "8eb11c77dd8e73f48df6b2f7a7e16173fe0fe8fdfe266232832e88477e08454e"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} = "\
+ python-pyasn1\
+ python-six\
+ python-cffi\
+ python-enum34\
+ python-setuptools\
+ python-pycparser\
+ python-subprocess\
+ python-threading\
+ python-numbers\
+ python-contextlib\
+ python-ipaddress\
+ python-pyasn1\
+ python-idna\
+"
+
+RDEPENDS_${PN}-ptest = "\
+ ${PN}\
+ python-pytest\
+ python-pretend\
+ python-iso8601\
+ python-cryptography-vectors\
+"
+
+inherit ptest
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+ install -d ${D}${PTEST_PATH}/tests/hazmat
+ cp -rf ${S}/tests/hazmat/* ${D}${PTEST_PATH}/tests/hazmat/
+}
+
+FILES_${PN}-dbg += " \
+ ${libdir}/python2.7/site-packages/${SRCNAME}/hazmat/bindings/.debug \
+ "