aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2018-01-21 11:20:32 -0500
committerArmin Kuster <akuster808@gmail.com>2018-01-22 20:09:53 -0800
commit594d12f429c98c6e05aa2c3b9cc44f319d640696 (patch)
treefe628c4098b53299c12a4a0111733b1ba42abe36
parent91a936feda22928d035a73bfd26909fd80a912e0 (diff)
downloadmeta-openembedded-contrib-594d12f429c98c6e05aa2c3b9cc44f319d640696.tar.gz
Remove deprecated ${PYTHON_PN}-importlib from the RDEPENDS
The ${PYTHON_PN}-importlib package was removed as part of the migration to the json manifest file. The functionality is now part of core Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/python/python-pygobject_3.22.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-astroid_1.6.0.bb1
-rw-r--r--meta-python/recipes-devtools/python/python-behave_1.2.5.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-can.inc1
-rw-r--r--meta-python/recipes-devtools/python/python-dbusmock_0.16.7.bb1
-rw-r--r--meta-python/recipes-devtools/python/python-django.inc1
-rw-r--r--meta-python/recipes-devtools/python/python-pandas_0.22.0.bb1
-rw-r--r--meta-python/recipes-devtools/python/python-pyroute2.inc1
-rw-r--r--meta-python/recipes-devtools/python/python-pyserial_3.4.bb2
9 files changed, 3 insertions, 9 deletions
diff --git a/meta-oe/recipes-devtools/python/python-pygobject_3.22.0.bb b/meta-oe/recipes-devtools/python/python-pygobject_3.22.0.bb
index 9d2e165548..7ddf4e552f 100644
--- a/meta-oe/recipes-devtools/python/python-pygobject_3.22.0.bb
+++ b/meta-oe/recipes-devtools/python/python-pygobject_3.22.0.bb
@@ -26,7 +26,7 @@ BBCLASSEXTEND = "native"
EXTRA_OECONF = "--disable-cairo --with-python=${PYTHON}"
-RDEPENDS_${PN} += "python-setuptools python-importlib"
+RDEPENDS_${PN} += "python-setuptools"
RDEPENDS_${PN}_class-native = ""
do_install_append() {
diff --git a/meta-python/recipes-devtools/python/python-astroid_1.6.0.bb b/meta-python/recipes-devtools/python/python-astroid_1.6.0.bb
index 42208bcb10..fd98630e1b 100644
--- a/meta-python/recipes-devtools/python/python-astroid_1.6.0.bb
+++ b/meta-python/recipes-devtools/python/python-astroid_1.6.0.bb
@@ -4,7 +4,6 @@ require python-astroid.inc
RDEPENDS_${PN}_class-target += " \
${PYTHON_PN}-enum34 \
${PYTHON_PN}-backports-functools-lru-cache \
- ${PYTHON_PN}-importlib \
${PYTHON_PN}-re \
${PYTHON_PN}-singledispatch \
"
diff --git a/meta-python/recipes-devtools/python/python-behave_1.2.5.bb b/meta-python/recipes-devtools/python/python-behave_1.2.5.bb
index 541a79d7bd..3db2016eb1 100644
--- a/meta-python/recipes-devtools/python/python-behave_1.2.5.bb
+++ b/meta-python/recipes-devtools/python/python-behave_1.2.5.bb
@@ -5,6 +5,6 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=d950439e8ea6ed233e4288f5e1a49c06"
SRC_URI[md5sum] = "3af4bc2886d2be982e41bfaba61da3bc"
SRC_URI[sha256sum] = "81b731ac5187e31e4aad2594944fa914943683a9818320846d037c5ebd6d5d0b"
-RDEPENDS_${PN} += "python-difflib python-setuptools python-pkgutil python-misc python-argparse python-xml python-importlib python-enum34 python-parse python-parse-type python-six"
+RDEPENDS_${PN} += "python-difflib python-setuptools python-pkgutil python-misc python-argparse python-xml python-enum34 python-parse python-parse-type python-six"
inherit pypi setuptools
diff --git a/meta-python/recipes-devtools/python/python-can.inc b/meta-python/recipes-devtools/python/python-can.inc
index 8cdd4d38fd..2b15af40a1 100644
--- a/meta-python/recipes-devtools/python/python-can.inc
+++ b/meta-python/recipes-devtools/python/python-can.inc
@@ -10,7 +10,6 @@ PYPI_PACKAGE="python-can"
RDEPENDS_${PN}_class-target += "\
${PYTHON_PN}-ctypes \
- ${PYTHON_PN}-importlib \
${PYTHON_PN}-logging \
${PYTHON_PN}-misc \
${PYTHON_PN}-netserver \
diff --git a/meta-python/recipes-devtools/python/python-dbusmock_0.16.7.bb b/meta-python/recipes-devtools/python/python-dbusmock_0.16.7.bb
index fb8c0aa602..ec8c54aacc 100644
--- a/meta-python/recipes-devtools/python/python-dbusmock_0.16.7.bb
+++ b/meta-python/recipes-devtools/python/python-dbusmock_0.16.7.bb
@@ -20,7 +20,6 @@ inherit pypi setuptools
RDEPENDS_${PN} += "\
${PYTHON_PN}-dbus \
- ${PYTHON_PN}-importlib \
${PYTHON_PN}-pygobject \
${PYTHON_PN}-xml \
"
diff --git a/meta-python/recipes-devtools/python/python-django.inc b/meta-python/recipes-devtools/python/python-django.inc
index 9287715eab..3602a74aa8 100644
--- a/meta-python/recipes-devtools/python/python-django.inc
+++ b/meta-python/recipes-devtools/python/python-django.inc
@@ -19,7 +19,6 @@ RDEPENDS_${PN} += "\
${PYTHON_PN}-datetime \
${PYTHON_PN}-email \
${PYTHON_PN}-html \
- ${PYTHON_PN}-importlib \
${PYTHON_PN}-json \
${PYTHON_PN}-multiprocessing \
${PYTHON_PN}-netserver \
diff --git a/meta-python/recipes-devtools/python/python-pandas_0.22.0.bb b/meta-python/recipes-devtools/python/python-pandas_0.22.0.bb
index 355074cb25..b3bfab9693 100644
--- a/meta-python/recipes-devtools/python/python-pandas_0.22.0.bb
+++ b/meta-python/recipes-devtools/python/python-pandas_0.22.0.bb
@@ -4,5 +4,4 @@ require python-pandas.inc
RDEPENDS_${PN} += " \
${PYTHON_PN}-future \
${PYTHON_PN}-json \
- ${PYTHON_PN}-importlib \
"
diff --git a/meta-python/recipes-devtools/python/python-pyroute2.inc b/meta-python/recipes-devtools/python/python-pyroute2.inc
index f63ccbd660..24e3555c7e 100644
--- a/meta-python/recipes-devtools/python/python-pyroute2.inc
+++ b/meta-python/recipes-devtools/python/python-pyroute2.inc
@@ -13,7 +13,6 @@ inherit pypi
RDEPENDS_${PN} += " \
${PYTHON_PN}-ctypes \
${PYTHON_PN}-distutils \
- ${PYTHON_PN}-importlib \
${PYTHON_PN}-json \
${PYTHON_PN}-logging \
${PYTHON_PN}-multiprocessing \
diff --git a/meta-python/recipes-devtools/python/python-pyserial_3.4.bb b/meta-python/recipes-devtools/python/python-pyserial_3.4.bb
index 0497087ac3..fd852a2bf8 100644
--- a/meta-python/recipes-devtools/python/python-pyserial_3.4.bb
+++ b/meta-python/recipes-devtools/python/python-pyserial_3.4.bb
@@ -1,4 +1,4 @@
inherit setuptools
require python-pyserial.inc
-RDEPENDS_${PN} += "${PYTHON_PN}-argparse ${PYTHON_PN}-importlib"
+RDEPENDS_${PN} += "${PYTHON_PN}-argparse"