aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNeil Armstrong <narmstrong@baylibre.com>2018-07-19 15:45:25 +0200
committerKhem Raj <raj.khem@gmail.com>2018-07-20 16:07:12 -0700
commitb0caf1fb82b90a6b123ba4463a8405568eda0389 (patch)
tree9fd4d956642b9430ec4def36a4eb6ea6046399a6
parent46aa7d0608f1ab40f8a072d1e331172aa256b9de (diff)
downloadmeta-openembedded-contrib-b0caf1fb82b90a6b123ba4463a8405568eda0389.tar.gz
libiio: fix build of python bindins
In the actual form, the python bindings are never built since the recipe does not depend on python, thus the cmake script does not detect python and does not build the bindings. Add a summy PACKAGECONFIG for the python bindings to make it simpler to disable. Signed-off-by: Neil Armstrong <narmstrong@baylibre.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/libiio/libiio_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/libiio/libiio_git.bb b/meta-oe/recipes-support/libiio/libiio_git.bb
index ba380ed306..fa6f4c2ca5 100644
--- a/meta-oe/recipes-support/libiio/libiio_git.bb
+++ b/meta-oe/recipes-support/libiio/libiio_git.bb
@@ -24,10 +24,11 @@ EXTRA_OECMAKE = " \
${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '-DWITH_SYSTEMD=ON -DSYSTEMD_UNIT_INSTALL_DIR=${systemd_system_unitdir}', '', d)} \
"
-PACKAGECONFIG ??= "USB_BACKEND NETWORK_BACKEND"
+PACKAGECONFIG ??= "USB_BACKEND NETWORK_BACKEND PYTHON_BINDINGS"
PACKAGECONFIG[USB_BACKEND] = "-DWITH_USB_BACKEND=ON,-DWITH_USB_BACKEND=OFF,libusb1,libxml2"
PACKAGECONFIG[NETWORK_BACKEND] = "-DWITH_NETWORK_BACKEND=ON,-DWITH_NETWORK_BACKEND=OFF,libxml2"
+PACKAGECONFIG[PYTHON_BINDINGS] = ",,python"
PACKAGES =+ "${PN}-iiod ${PN}-tests ${PN}-python"