aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/zaurus-utils/nandlogical.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/zaurus-utils/nandlogical.bb')
-rw-r--r--recipes-bsp/zaurus-utils/nandlogical.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-bsp/zaurus-utils/nandlogical.bb b/recipes-bsp/zaurus-utils/nandlogical.bb
new file mode 100644
index 0000000..12aa326
--- /dev/null
+++ b/recipes-bsp/zaurus-utils/nandlogical.bb
@@ -0,0 +1,25 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:${THISDIR}/files:"
+
+DESCRIPTION = "Nandlogical for Sharp SL FTL reserved partition"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://nandlogical.c;endline=15;md5=77804e7fdf625e56869f32d9aec762a2"
+PV = "1.1.0"
+SRC_URI = "http://distro.ibiblio.org/pub/linux/distributions/pdaxrom/download/1.1.0beta4/src/survive-1.1.0.tar.bz2 \
+ file://oobblock-to-writesize.patch"
+
+SRC_URI[md5sum] = "b6cb17168a424a5d757309dce4a81841"
+SRC_URI[sha256sum] = "0d02edc12509f6dc98cded37c68238f939c522cbd398fd527785a1e7e3bcfcea"
+
+S = "${WORKDIR}/survive-1.1.0"
+
+do_compile () {
+ ${CC} ${CFLAGS} ${LDFLAGS} nandlogical.c -o nandlogical
+}
+
+do_install () {
+ install -d ${D}${bindir}/
+ install -m 0755 nandlogical ${D}${bindir}/
+}
+
+COMPATIBLE_MACHINE = "(poodle|c7x0|akita|spitz|tosa)"
+BBCLASSEXTEND = "klibc"