aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/layer.conf2
-rw-r--r--conf/machine/akita.conf4
-rw-r--r--conf/machine/ben-nanonote.conf4
-rw-r--r--conf/machine/c7x0.conf2
-rw-r--r--conf/machine/collie.conf4
-rw-r--r--conf/machine/gcw0.conf6
-rw-r--r--conf/machine/h1940.conf2
-rw-r--r--conf/machine/h3600.conf6
-rw-r--r--conf/machine/hx4700.conf34
-rw-r--r--conf/machine/include/zaurus.inc34
-rw-r--r--conf/machine/poodle.conf2
-rw-r--r--conf/machine/spitz.conf4
-rw-r--r--conf/machine/tosa.conf2
-rw-r--r--recipes-bsp/acx-firmware/acx-firmware_1.0.bb2
-rw-r--r--recipes-bsp/formfactor/formfactor_%.bbappend6
-rw-r--r--recipes-bsp/ipaq-boot-params/ipaq-boot-params.bb3
-rw-r--r--recipes-bsp/kbdd/kbdd_svn.bb6
-rw-r--r--recipes-bsp/kexecboot/kexecboot-handhelds.inc12
-rw-r--r--recipes-bsp/kexecboot/kexecboot_%.bbappend2
-rw-r--r--recipes-bsp/keymaps/keymaps_%.bbappend20
-rw-r--r--recipes-bsp/zaurus-utils/nandlogical.bb2
-rw-r--r--recipes-bsp/zaurus-utils/zaurus-installer.bb4
-rw-r--r--recipes-bsp/zaurusd/zaurusd/add_64bit_time_t.patch43
-rw-r--r--recipes-bsp/zaurusd/zaurusd_git.bb9
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xf86-config_%.bbappend2
-rw-r--r--recipes-kernel/linux/linux-handheld_4.0.bb18
-rw-r--r--recipes-kernel/linux/linux-handheld_4.14.bb8
-rw-r--r--recipes-kernel/linux/linux-handheld_4.4.bb16
-rw-r--r--recipes-kernel/linux/linux-kexecboot_4.4.bb2
-rw-r--r--recipes-kernel/linux/linux-qi-ben-nanonote_3.12.bb10
30 files changed, 157 insertions, 114 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 6086b8d..2f7ac69 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -18,5 +18,5 @@ BBFILE_PRIORITY_meta-handheld = "7"
LAYERDEPENDS_meta-handheld = "core meta-initramfs openembedded-layer"
-LAYERSERIES_COMPAT_meta-handheld = "sumo"
+LAYERSERIES_COMPAT_meta-handheld = "honister"
diff --git a/conf/machine/akita.conf b/conf/machine/akita.conf
index 94fa36e..54ceb89 100644
--- a/conf/machine/akita.conf
+++ b/conf/machine/akita.conf
@@ -6,9 +6,9 @@
# mtdparts=sharpsl-nand:7168k@0k(smf),59392k@7168k(root),-(home)
require conf/machine/include/zaurus.inc
-require conf/machine/include/tune-xscale.inc
+require conf/machine/include/arm/armv5/tune-xscale.inc
-PACKAGE_EXTRA_ARCHS_tune-xscale += "iwmmxt"
+PACKAGE_EXTRA_ARCHS:tune-xscale += "iwmmxt"
MACHINE_FEATURES += "iwmmxt"
JFFS2_ERASEBLOCK = "0x20000"
diff --git a/conf/machine/ben-nanonote.conf b/conf/machine/ben-nanonote.conf
index d5e86bd..7c4a1fb 100644
--- a/conf/machine/ben-nanonote.conf
+++ b/conf/machine/ben-nanonote.conf
@@ -2,7 +2,7 @@
#@NAME: Ben Nanonote
#@DESCRIPTION: Machine configuration for the Qi-Hardware's Ben Nanonote
-require conf/machine/include/tune-mips32.inc
+require conf/machine/include/mips/tune-mips32.inc
PREFERRED_PROVIDER_virtual/kernel = "linux-qi-ben-nanonote"
@@ -17,4 +17,4 @@ MACHINE_GUI_CLASS = "smallscreen"
MACHINE_DISPLAY_WIDTH_PIXELS = "320"
MACHINE_DISPLAY_HEIGHT_PIXELS = "240"
-MACHINE_FEATURES_append_ben-nanonote = " qvga"
+MACHINE_FEATURES:append:ben-nanonote = " qvga"
diff --git a/conf/machine/c7x0.conf b/conf/machine/c7x0.conf
index 28a09bb..3d14b67 100644
--- a/conf/machine/c7x0.conf
+++ b/conf/machine/c7x0.conf
@@ -9,7 +9,7 @@
# SL-C860 (Boxer) mtdparts=sharpsl-nand:7168k@0k(smf),54272k@7168k(root),-(home)
require conf/machine/include/zaurus.inc
-require conf/machine/include/tune-xscale.inc
+require conf/machine/include/arm/armv5/tune-xscale.inc
JFFS2_ERASEBLOCK = "0x4000"
diff --git a/conf/machine/collie.conf b/conf/machine/collie.conf
index 30e3df2..0743afe 100644
--- a/conf/machine/collie.conf
+++ b/conf/machine/collie.conf
@@ -3,11 +3,11 @@
#@DESCRIPTION: Machine configuration for the SA1100 based Sharp Zaurus SL-5000 and SL-5500 devices
require conf/machine/include/zaurus.inc
-require conf/machine/include/tune-strongarm1100.inc
+require conf/machine/include/arm/armv4/tune-strongarm1100.inc
JFFS2_ERASEBLOCK = "0x20000"
# For NOR flash we need the cleanmarkers so override the defaults
-EXTRA_IMAGECMD_jffs2 = "--pad=14680064 -l -e ${JFFS2_ERASEBLOCK}"
+EXTRA_IMAGECMD:jffs2 = "--pad=14680064 -l -e ${JFFS2_ERASEBLOCK}"
# sumtool does not accept the argument for --pad
JFFS2_SUM_EXTRA_ARGS = "-p -l -e ${JFFS2_ERASEBLOCK}"
diff --git a/conf/machine/gcw0.conf b/conf/machine/gcw0.conf
index b7c6100..75d0737 100644
--- a/conf/machine/gcw0.conf
+++ b/conf/machine/gcw0.conf
@@ -3,7 +3,7 @@
#@DESCRIPTION: Machine configuration for the Game Consoles Worldwide (GCW) Zero
DEFAULTTUNE = "mips32r2el"
-require conf/machine/include/tune-mips32r2.inc
+require conf/machine/include/mips/tune-mips32r2.inc
# Factory default are RO images: add following line to your target image
# IMAGE_FEATURES += "read-only-rootfs"
@@ -25,11 +25,11 @@ MACHINE_DISPLAY_HEIGHT_PIXELS = "240"
MACHINE_FEATURES = "apm alsa usbhost usbgadget wifi screen qvga vfat ext2"
# Install kernel and symlink in /boot
-MACHINE_ESSENTIAL_EXTRA_RDEPENDS_append = " kernel-base kernel-image"
+MACHINE_ESSENTIAL_EXTRA_RDEPENDS:append = " kernel-base kernel-image"
MACHINE_EXTRA_RRECOMMENDS = "kernel-modules"
# Install /boot/boot.cfg in target images and formfactor (psplash checks rotatio
-MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS_append = " kexecboot-cfg formfactor"
+MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS:append = " kexecboot-cfg formfactor"
SERIAL_CONSOLE = "57600 ttyS2"
diff --git a/conf/machine/h1940.conf b/conf/machine/h1940.conf
index d9ed33a..aa79f5a 100644
--- a/conf/machine/h1940.conf
+++ b/conf/machine/h1940.conf
@@ -6,7 +6,7 @@
# Hardware-based properties
#
# tune for armv4t
-require conf/machine/include/tune-arm920t.inc
+require conf/machine/include/arm/armv4/tune-arm920t.inc
# Set preferred providers
PREFERRED_PROVIDER_virtual/kernel = "linux-handheld"
diff --git a/conf/machine/h3600.conf b/conf/machine/h3600.conf
index f64817d..bc86734 100644
--- a/conf/machine/h3600.conf
+++ b/conf/machine/h3600.conf
@@ -5,7 +5,7 @@
#
# Hardware-based properties
#
-require conf/machine/include/tune-strongarm1100.inc
+require conf/machine/include/arm/armv4/tune-strongarm1100.inc
MACHINE_GUI_CLASS = "smallscreen"
MACHINE_DISPLAY_WIDTH_PIXELS = "240"
@@ -32,8 +32,8 @@ MACHINE_EXTRA_RRECOMMENDS = ""
JFFS2_ERASEBLOCK = "0x40000"
# For NOR flash we need the cleanmarkers so override the defaults
-EXTRA_IMAGECMD_jffs2 = "-p -l -e ${JFFS2_ERASEBLOCK}"
-EXTRA_IMAGECMD_jffs2_append = " ; echo '${IMAGE_NAME} ${IMAGE_NAME}.rootfs.jffs2 - root' >> ${IMGDEPLOYDIR}/reflash.ctl"
+EXTRA_IMAGECMD:jffs2 = "-p -l -e ${JFFS2_ERASEBLOCK}"
+EXTRA_IMAGECMD:jffs2:append = " ; echo '${IMAGE_NAME} ${IMAGE_NAME}.rootfs.jffs2 - root' >> ${IMGDEPLOYDIR}/reflash.ctl"
#
# Modules autoload and other boot properties
diff --git a/conf/machine/hx4700.conf b/conf/machine/hx4700.conf
index a67370c..3f2a90b 100644
--- a/conf/machine/hx4700.conf
+++ b/conf/machine/hx4700.conf
@@ -5,10 +5,10 @@
#
# Hardware-based properties
#
-require conf/machine/include/tune-xscale.inc
+require conf/machine/include/arm/armv5/tune-xscale.inc
MACHINE_FEATURES += "iwmmxt"
-PACKAGE_EXTRA_ARCHS_tune-xscale += "iwmmxt"
+PACKAGE_EXTRA_ARCHS:tune-xscale += "iwmmxt"
MACHINE_GUI_CLASS = "bigscreen"
MACHINE_DISPLAY_WIDTH_PIXELS = "480"
@@ -39,26 +39,26 @@ IMAGE_FSTYPES += "tar.gz jffs2"
JFFS2_ERASEBLOCK = "0x40000"
#write out a reflash.ctl with the appriate entries for the rootfs, the ones for the kernel should already be there
-EXTRA_IMAGECMD_jffs2_append = " ; echo '${IMAGE_NAME} ${IMAGE_NAME}.rootfs.jffs2 - root' >> ${IMGDEPLOYDIR}/reflash.ctl"
+EXTRA_IMAGECMD:jffs2:append = " ; echo '${IMAGE_NAME} ${IMAGE_NAME}.rootfs.jffs2 - root' >> ${IMGDEPLOYDIR}/reflash.ctl"
#
# Modules autoload and other boot properties
#
-module_autoload_evdev = "evdev"
-module_autoload_hx4700_power = "hx4700_power"
-module_autoload_pcmcia = "pcmcia"
-module_autoload_hx4700_pcmcia = "hx4700_pcmcia"
-module_autoload_asic3_mmc = "asic3_mmc"
-module_autoload_mmc_block = "mmc_block"
-module_autoload_hx4700_ts = "hx4700_ts"
-module_autoload_hx4700_navpt = "hx4700_navpt"
-module_autoload_hx4700_bt = "hx4700_bt"
-module_autoload_snd-hx4700_audio = "snd-hx4700_audio"
-module_autoload_snd-pcm-oss = "snd-pcm-oss"
-module_autoload_snd-mixer-oss = "snd-mixer-oss"
-module_autoload_pxa27x_udc = "pxa27x_udc"
+module_autoload:evdev = "evdev"
+module_autoload:hx4700_power = "hx4700_power"
+module_autoload:pcmcia = "pcmcia"
+module_autoload:hx4700_pcmcia = "hx4700_pcmcia"
+module_autoload:asic3_mmc = "asic3_mmc"
+module_autoload:mmc_block = "mmc_block"
+module_autoload:hx4700_ts = "hx4700_ts"
+module_autoload:hx4700_navpt = "hx4700_navpt"
+module_autoload:hx4700_bt = "hx4700_bt"
+module_autoload:snd-hx4700_audio = "snd-hx4700_audio"
+module_autoload:snd-pcm-oss = "snd-pcm-oss"
+module_autoload:snd-mixer-oss = "snd-mixer-oss"
+module_autoload:pxa27x_udc = "pxa27x_udc"
#FIXME: this should be controlled by a userspace utility later.
-module_autoload_g_ether = "g_ether"
+module_autoload:g_ether = "g_ether"
SERIAL_CONSOLE = "115200 ttyS0"
diff --git a/conf/machine/include/zaurus.inc b/conf/machine/include/zaurus.inc
index b311f70..5eb8f73 100644
--- a/conf/machine/include/zaurus.inc
+++ b/conf/machine/include/zaurus.inc
@@ -3,7 +3,7 @@
########################
IMAGE_FSTYPES ?= "tar.gz jffs2 jffs2.sum ubi ubifs"
-IMAGE_FSTYPES_collie ?= "tar.gz jffs2 jffs2.sum"
+IMAGE_FSTYPES:collie ?= "tar.gz jffs2 jffs2.sum"
JFFS2_SUM_EXTRA_ARGS = "-p -l -e ${JFFS2_ERASEBLOCK} -n"
INITRAMFS_FSTYPES ?= "cpio.gz cpio.xz"
@@ -35,27 +35,27 @@ XZ_COMPRESSION_LEVEL = "-2e"
################
ARM_INSTRUCTION_SET = "thumb"
-ARM_INSTRUCTION_SET_collie = "arm"
+ARM_INSTRUCTION_SET:collie = "arm"
SERIAL_CONSOLE = "115200 ttyS0"
-SERIAL_CONSOLE_collie = "115200 ttySA0"
+SERIAL_CONSOLE:collie = "115200 ttySA0"
-CMDLINE_akita = "console=ttyS0,115200n8 console=tty1 fbcon=rotate:1"
-CMDLINE_c7x0 = "console=ttyS0,115200n8 console=tty1"
-CMDLINE_collie = "console=ttySA0,115200n8 console=tty1 mem=64M fbcon=rotate:1"
-CMDLINE_poodle = "console=ttyS0,115200n8 console=tty1 fbcon=rotate:1"
-CMDLINE_spitz = "console=ttyS0,115200n8 console=tty1 fbcon=rotate:1"
-CMDLINE_tosa = "console=ttyS0,115200n8 console=tty1"
+CMDLINE:akita = "console=ttyS0,115200n8 console=tty1 fbcon=rotate:1"
+CMDLINE:c7x0 = "console=ttyS0,115200n8 console=tty1"
+CMDLINE:collie = "console=ttySA0,115200n8 console=tty1 mem=64M fbcon=rotate:1"
+CMDLINE:poodle = "console=ttyS0,115200n8 console=tty1 fbcon=rotate:1"
+CMDLINE:spitz = "console=ttyS0,115200n8 console=tty1 fbcon=rotate:1"
+CMDLINE:tosa = "console=ttyS0,115200n8 console=tty1"
MACHINE_FEATURES = "apm alsa pcmcia irda usbgadget keyboard touchscreen screen vfat ext2"
-MACHINE_FEATURES_append_akita = " usbhost"
-MACHINE_FEATURES_append_collie = " qvga"
-MACHINE_FEATURES_append_poodle = " qvga"
-MACHINE_FEATURES_append_spitz = " usbhost"
-MACHINE_FEATURES_append_tosa = " usbhost wifi"
+MACHINE_FEATURES:append:akita = " usbhost"
+MACHINE_FEATURES:append:collie = " qvga"
+MACHINE_FEATURES:append:poodle = " qvga"
+MACHINE_FEATURES:append:spitz = " usbhost"
+MACHINE_FEATURES:append:tosa = " usbhost wifi"
MACHINE_EXTRA_RDEPENDS = "zaurusd mtd-utils mtd-utils-jffs2 mtd-utils-ubifs nandlogical"
-MACHINE_EXTRA_RDEPENDS_collie = "zaurusd mtd-utils mtd-utils-jffs2 mtd-utils-ubifs"
+MACHINE_EXTRA_RDEPENDS:collie = "zaurusd mtd-utils mtd-utils-jffs2 mtd-utils-ubifs"
BAD_RECOMMENDATIONS += "eudev-hwdb"
@@ -68,7 +68,7 @@ BAD_RECOMMENDATIONS += "eudev-hwdb"
# EXTRA_IMAGEDEPENDS += "zaurus-installer"
# Install /boot/boot.cfg in target images and formfactor (psplash checks rotation)
-MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS_append = " kexecboot-cfg formfactor"
+MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS:append = " kexecboot-cfg formfactor"
# Install kernel and symlink in /boot
-MACHINE_ESSENTIAL_EXTRA_RDEPENDS_append = " kernel-base kernel-image"
+MACHINE_ESSENTIAL_EXTRA_RDEPENDS:append = " kernel-base kernel-image"
diff --git a/conf/machine/poodle.conf b/conf/machine/poodle.conf
index 3f54f92..cc5b28b 100644
--- a/conf/machine/poodle.conf
+++ b/conf/machine/poodle.conf
@@ -6,7 +6,7 @@
# SL-5600 (poodle) mtdparts=sharpsl-nand:7168k@0k(smf),22528k@7168k(root),-(home)
require conf/machine/include/zaurus.inc
-require conf/machine/include/tune-xscale.inc
+require conf/machine/include/arm/armv5/tune-xscale.inc
JFFS2_ERASEBLOCK = "0x4000"
diff --git a/conf/machine/spitz.conf b/conf/machine/spitz.conf
index f90bc92..159ae8f 100644
--- a/conf/machine/spitz.conf
+++ b/conf/machine/spitz.conf
@@ -17,10 +17,10 @@
# UBINIZE_ARGS = "-m 512 -p 16384 -s 256"
require conf/machine/include/zaurus.inc
-require conf/machine/include/tune-xscale.inc
+require conf/machine/include/arm/armv5/tune-xscale.inc
MACHINE_FEATURES += "iwmmxt"
-PACKAGE_EXTRA_ARCHS_tune-xscale += "iwmmxt"
+PACKAGE_EXTRA_ARCHS:tune-xscale += "iwmmxt"
JFFS2_ERASEBLOCK = "0x20000"
diff --git a/conf/machine/tosa.conf b/conf/machine/tosa.conf
index 58d27cc..90367da 100644
--- a/conf/machine/tosa.conf
+++ b/conf/machine/tosa.conf
@@ -6,7 +6,7 @@
# mtdparts=sharpsl-nand:7168k@0k(smf),28672k@7168k(root),-(home)
require conf/machine/include/zaurus.inc
-require conf/machine/include/tune-xscale.inc
+require conf/machine/include/arm/armv5/tune-xscale.inc
JFFS2_ERASEBLOCK = "0x4000"
diff --git a/recipes-bsp/acx-firmware/acx-firmware_1.0.bb b/recipes-bsp/acx-firmware/acx-firmware_1.0.bb
index 3791587..47aca3f 100644
--- a/recipes-bsp/acx-firmware/acx-firmware_1.0.bb
+++ b/recipes-bsp/acx-firmware/acx-firmware_1.0.bb
@@ -9,7 +9,7 @@ SRC_URI = "http://sdgsystems.net/pub/ipaq/hx4700/src/RADIO0d.BIN;name=radio0d \
http://sdgsystems.net/pub/ipaq/hx4700/src/WLANGEN.BIN;name=wlangen "
S = "${WORKDIR}"
-FILES_${PN} = "/lib"
+FILES:${PN} = "/lib"
do_install() {
install -d ${D}/lib/firmware/
diff --git a/recipes-bsp/formfactor/formfactor_%.bbappend b/recipes-bsp/formfactor/formfactor_%.bbappend
index 5c85433..7e26476 100644
--- a/recipes-bsp/formfactor/formfactor_%.bbappend
+++ b/recipes-bsp/formfactor/formfactor_%.bbappend
@@ -1,11 +1,11 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
-do_install_prepend () {
+do_install:prepend () {
# provide machine-specific /etc/rotation for psplash
sed -n 's/^[ \t]*DISPLAY_ORIENTATION[ \t]*//p' ${S}/machconfig | tr -dc '[0-9]' > ${S}/rotation
}
-do_install_append () {
+do_install:append () {
# Only install file if it has a content
if [ -s "${S}/rotation" ]; then
install -d ${D}${sysconfdir}
diff --git a/recipes-bsp/ipaq-boot-params/ipaq-boot-params.bb b/recipes-bsp/ipaq-boot-params/ipaq-boot-params.bb
index c8ea1d7..649eac6 100644
--- a/recipes-bsp/ipaq-boot-params/ipaq-boot-params.bb
+++ b/recipes-bsp/ipaq-boot-params/ipaq-boot-params.bb
@@ -13,6 +13,5 @@ do_install() {
install -m 0644 ${WORKDIR}/params ${D}/boot/
}
-FILES_${PN} = "/boot/params"
+FILES:${PN} = "/boot/params"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-
diff --git a/recipes-bsp/kbdd/kbdd_svn.bb b/recipes-bsp/kbdd/kbdd_svn.bb
index bf99716..381d6f9 100644
--- a/recipes-bsp/kbdd/kbdd_svn.bb
+++ b/recipes-bsp/kbdd/kbdd_svn.bb
@@ -35,15 +35,15 @@ do_install() {
install -m 0644 ${WORKDIR}/kbdd-modules ${D}${sysconfdir}/modutils/
}
-pkg_postinst_${PN} () {
+pkg_postinst:${PN} () {
update-modules
}
-pkg_postrm_${PN} () {
+pkg_postrm:${PN} () {
update-modules
}
INITSCRIPT_NAME = "kbdd"
INITSCRIPT_PARAMS = "defaults"
-RRECOMMENDS_${PN} = "kernel-module-keybdev kernel-module-uinput"
+RRECOMMENDS:${PN} = "kernel-module-keybdev kernel-module-uinput"
diff --git a/recipes-bsp/kexecboot/kexecboot-handhelds.inc b/recipes-bsp/kexecboot/kexecboot-handhelds.inc
index f7f9a37..115138a 100644
--- a/recipes-bsp/kexecboot/kexecboot-handhelds.inc
+++ b/recipes-bsp/kexecboot/kexecboot-handhelds.inc
@@ -1,6 +1,6 @@
-EXTRA_OECONF_akita = "--enable-delay=2 --enable-evdev-rate=1000,250 --enable-fbui-width=480 --enable-bpp=16"
-EXTRA_OECONF_c7x0 = "--enable-delay=2 --enable-evdev-rate=1000,250 --enable-fbui-width=480 --enable-bpp=16"
-EXTRA_OECONF_spitz = "--enable-delay=3 --enable-evdev-rate=1000,250 --enable-fbui-width=480 --enable-bpp=16"
-EXTRA_OECONF_poodle = "--enable-delay=2 --enable-evdev-rate=1000,250 --enable-bpp=16"
-EXTRA_OECONF_tosa = "--enable-delay=2 --enable-evdev-rate=1000,250 --enable-bpp=16"
-EXTRA_OECONF_collie = "--enable-delay=2 --enable-evdev-rate=1000,250 --enable-bpp=16"
+EXTRA_OECONF:akita = "--enable-delay=2 --enable-evdev-rate=1000,250 --enable-fbui-width=480 --enable-bpp=16 --enable-atags --enable-no-checks"
+EXTRA_OECONF:c7x0 = "--enable-delay=2 --enable-evdev-rate=1000,250 --enable-fbui-width=480 --enable-bpp=16 --enable-atags --enable-no-checks"
+EXTRA_OECONF:spitz = "--enable-delay=3 --enable-evdev-rate=1000,250 --enable-fbui-width=480 --enable-bpp=16 --enable-atags --enable-no-checks"
+EXTRA_OECONF:poodle = "--enable-delay=2 --enable-evdev-rate=1000,250 --enable-bpp=16 --enable-atags --enable-no-checks"
+EXTRA_OECONF:tosa = "--enable-delay=2 --enable-evdev-rate=1000,250 --enable-bpp=16 --enable-atags --enable-no-checks"
+EXTRA_OECONF:collie = "--enable-delay=2 --enable-evdev-rate=1000,250 --enable-bpp=16 --enable-atags --enable-no-checks"
diff --git a/recipes-bsp/kexecboot/kexecboot_%.bbappend b/recipes-bsp/kexecboot/kexecboot_%.bbappend
index 61ba802..e2b3aed 100644
--- a/recipes-bsp/kexecboot/kexecboot_%.bbappend
+++ b/recipes-bsp/kexecboot/kexecboot_%.bbappend
@@ -1,3 +1,3 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
require kexecboot-handhelds.inc
diff --git a/recipes-bsp/keymaps/keymaps_%.bbappend b/recipes-bsp/keymaps/keymaps_%.bbappend
index e9f0159..03ce95b 100644
--- a/recipes-bsp/keymaps/keymaps_%.bbappend
+++ b/recipes-bsp/keymaps/keymaps_%.bbappend
@@ -1,19 +1,19 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
-SRC_URI_append_c7x0 = " file://keymap-2.6.map"
-SRC_URI_append_tosa = " file://keymap-2.6.map"
-SRC_URI_append_akita = " file://keymap-2.6.map"
-SRC_URI_append_spitz = " file://keymap-2.6.map"
-SRC_URI_append_collie = " file://keymap-2.6.map"
-SRC_URI_append_poodle = " file://keymap-2.6.map"
-SRC_URI_append_hx4700 = " file://keymap-2.6.map"
+SRC_URI:append:c7x0 = " file://keymap-2.6.map"
+SRC_URI:append:tosa = " file://keymap-2.6.map"
+SRC_URI:append:akita = " file://keymap-2.6.map"
+SRC_URI:append:spitz = " file://keymap-2.6.map"
+SRC_URI:append:collie = " file://keymap-2.6.map"
+SRC_URI:append:poodle = " file://keymap-2.6.map"
+SRC_URI:append:hx4700 = " file://keymap-2.6.map"
# we still use keymap-2.6.map files
-do_configure_append () {
+do_configure:append () {
sed -i -e 's/KERNEL_MAJMIN=.*$/KERNEL_MAJMIN="2.6"/' ${WORKDIR}/keymap.sh
}
-do_install_append () {
+do_install:append () {
case ${MACHINE} in
c7x0 | tosa | akita | spitz | collie | poodle | hx4700 )
install -d ${D}${sysconfdir}
diff --git a/recipes-bsp/zaurus-utils/nandlogical.bb b/recipes-bsp/zaurus-utils/nandlogical.bb
index 12aa326..7965950 100644
--- a/recipes-bsp/zaurus-utils/nandlogical.bb
+++ b/recipes-bsp/zaurus-utils/nandlogical.bb
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:${THISDIR}/files:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:${THISDIR}/files:"
DESCRIPTION = "Nandlogical for Sharp SL FTL reserved partition"
LICENSE = "GPLv2+"
diff --git a/recipes-bsp/zaurus-utils/zaurus-installer.bb b/recipes-bsp/zaurus-utils/zaurus-installer.bb
index 24d0fe1..4a2604f 100644
--- a/recipes-bsp/zaurus-utils/zaurus-installer.bb
+++ b/recipes-bsp/zaurus-utils/zaurus-installer.bb
@@ -3,8 +3,8 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
DEPENDS = "zaurus-updater linux-kexecboot"
-DEPENDS_collie = "linux-kexecboot"
-DEPENDS_append_spitz = " zaurus-legacy-tar"
+DEPENDS:collie = "linux-kexecboot"
+DEPENDS:append:spitz = " zaurus-legacy-tar"
PV = "2017.05"
diff --git a/recipes-bsp/zaurusd/zaurusd/add_64bit_time_t.patch b/recipes-bsp/zaurusd/zaurusd/add_64bit_time_t.patch
new file mode 100644
index 0000000..5f9587a
--- /dev/null
+++ b/recipes-bsp/zaurusd/zaurusd/add_64bit_time_t.patch
@@ -0,0 +1,43 @@
+From d15b20fd9e8927db5dc4303f2e6c11cfa8d6fe95 Mon Sep 17 00:00:00 2001
+From: Andrea Adami <andrea.adami@gmail.com>
+Date: Mon, 20 Apr 2020 16:21:22 +0200
+Subject: [PATCH] tskeys.c: add support for 64bit time_t
+
+Upgrade the recipe to cope with the 64-bit time changes introduced in 4.16
+
+Fix:
+
+| tskeys.c: In function 'press_key':
+| tskeys.c:141:4: error: 'struct input_event' has no member named 'time'
+| 141 | ev.time.tv_sec = time(0);
+| | ^
+| tskeys.c:142:4: error: 'struct input_event' has no member named 'time'
+| 142 | ev.time.tv_usec = 0;
+| | ^
+
+Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
+---
+ apps/tskeys/tskeys.c | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/apps/tskeys/tskeys.c b/apps/tskeys/tskeys.c
+index 264dfb7..36e3bfd 100644
+--- a/apps/tskeys/tskeys.c
++++ b/apps/tskeys/tskeys.c
+@@ -138,8 +138,13 @@ void press_key(int fd, int key, int pressed)
+ struct input_event ev;
+ int r;
+
++#if !defined(__USE_TIME_BITS64)
+ ev.time.tv_sec = time(0);
+ ev.time.tv_usec = 0;
++#else
++ ev.input_event_sec = time(0);
++ ev.input_event_usec = 0;
++#endif
+ ev.type = EV_KEY;
+ ev.code = key;
+ ev.value = pressed;
+--
+2.17.1
+
diff --git a/recipes-bsp/zaurusd/zaurusd_git.bb b/recipes-bsp/zaurusd/zaurusd_git.bb
index d69805b..3109002 100644
--- a/recipes-bsp/zaurusd/zaurusd_git.bb
+++ b/recipes-bsp/zaurusd/zaurusd_git.bb
@@ -24,18 +24,19 @@ SRC_URI = "git://git.yoctoproject.org/${BPN} \
file://01-check-toggle-portait \
file://use-ts-symlink-instead-of-hardcoding.diff \
file://0001-zaurusd-add-support-for-collie.patch \
- file://allow-newer-tslib.patch"
+ file://allow-newer-tslib.patch \
+ file://add_64bit_time_t.patch"
S = "${WORKDIR}/git"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-do_configure_prepend () {
+do_configure:prepend () {
cp ${WORKDIR}/zaurus-hinge.in ${S}/scripts
}
-do_install_append() {
+do_install:append() {
install -d "${D}/etc/zaurusd/hinge-landscape.d"
install -d "${D}/etc/zaurusd/hinge-portrait.d"
install -d "${D}/etc/zaurusd/hinge-close.d"
@@ -58,5 +59,5 @@ inherit autotools-brokensep pkgconfig update-rc.d
INITSCRIPT_NAME = "zaurusd"
INITSCRIPT_PARAMS = "start 99 5 2 . stop 20 0 1 6 ."
-RRECOMMENDS_${PN} += "kernel-module-uinput"
+RRECOMMENDS:${PN} += "kernel-module-uinput"
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config_%.bbappend b/recipes-graphics/xorg-xserver/xserver-xf86-config_%.bbappend
index 72d991c..4fc41d0 100644
--- a/recipes-graphics/xorg-xserver/xserver-xf86-config_%.bbappend
+++ b/recipes-graphics/xorg-xserver/xserver-xf86-config_%.bbappend
@@ -1 +1 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
diff --git a/recipes-kernel/linux/linux-handheld_4.0.bb b/recipes-kernel/linux/linux-handheld_4.0.bb
index b5884f1..8f78af9 100644
--- a/recipes-kernel/linux/linux-handheld_4.0.bb
+++ b/recipes-kernel/linux/linux-handheld_4.0.bb
@@ -33,19 +33,19 @@ SRC_URI += "\
file://locomo/0020-irq-HACK-around-for-handling-irq0-when-we-should.patch \
\
"
-SRC_URI_append_akita = " \
+SRC_URI:append:akita = " \
file://defconfig \
file://OE-vga-logo.patch \
"
-SRC_URI_append_c7x0 = " \
+SRC_URI:append:c7x0 = " \
file://defconfig \
file://OE-vga-logo.patch \
"
-SRC_URI_append_collie = " \
+SRC_URI:append:collie = " \
file://defconfig \
file://OE-qvga-logo.patch \
"
-SRC_URI_append_h1940 = " \
+SRC_URI:append:h1940 = " \
file://defconfig \
file://OE-qvga-logo.patch \
file://0001-rfkill-add-IR-type.patch \
@@ -64,17 +64,17 @@ SRC_URI_append_h1940 = " \
file://0014-i2c-s3c2410-fix-oops-in-suspend-callback-for-non-dt-.patch \
file://0015-ASoC-uda1380-Avoid-accessing-i2c-bus-when-codec-is-d.patch \
"
-SRC_URI_append_h3600 = " \
+SRC_URI:append:h3600 = " \
file://defconfig \
file://OE-qvga-logo.patch \
file://0002-input-driver-for-microcontroller-keys-on-the-iPaq-h3.patch \
"
-SRC_URI_append_hx4700 = " \
+SRC_URI:append:hx4700 = " \
file://defconfig \
file://OE-vga-logo.patch \
file://hx4700-change-led-trigger-assignments.patch \
"
-SRC_URI_append_poodle = " \
+SRC_URI:append:poodle = " \
file://defconfig \
file://OE-qvga-logo.patch \
file://0001-ARM-pxa-add-gpio-charger-configuration-on-poodle.patch \
@@ -82,11 +82,11 @@ SRC_URI_append_poodle = " \
file://0003-ARM-pxa-declare-battery-device-on-poodle.patch \
file://0004-power-add-poodle-battery-driver.patch \
"
-SRC_URI_append_spitz = " \
+SRC_URI:append:spitz = " \
file://defconfig \
file://OE-vga-logo.patch \
"
-SRC_URI_append_tosa = " \
+SRC_URI:append:tosa = " \
file://defconfig \
file://OE-vga-logo.patch \
file://0001-HACK-video-move-backlight-to-the-end-of-Makefile.patch \
diff --git a/recipes-kernel/linux/linux-handheld_4.14.bb b/recipes-kernel/linux/linux-handheld_4.14.bb
index d1b3180..470a2b3 100644
--- a/recipes-kernel/linux/linux-handheld_4.14.bb
+++ b/recipes-kernel/linux/linux-handheld_4.14.bb
@@ -23,19 +23,19 @@ SRC_URI += "\
DEPENDS += "lz4-native"
-SRC_URI_append_akita = " \
+SRC_URI:append:akita = " \
file://defconfig \
file://OE-vga-logo.patch \
"
-SRC_URI_append_c7x0 = " \
+SRC_URI:append:c7x0 = " \
file://defconfig \
file://OE-vga-logo.patch \
"
-SRC_URI_append_spitz = " \
+SRC_URI:append:spitz = " \
file://defconfig \
file://OE-vga-logo.patch \
"
-SRC_URI_append_tosa = " \
+SRC_URI:append:tosa = " \
file://defconfig \
file://OE-vga-logo.patch \
file://0001-HACK-video-move-backlight-to-the-end-of-Makefile.patch \
diff --git a/recipes-kernel/linux/linux-handheld_4.4.bb b/recipes-kernel/linux/linux-handheld_4.4.bb
index 421003f..ae29174 100644
--- a/recipes-kernel/linux/linux-handheld_4.4.bb
+++ b/recipes-kernel/linux/linux-handheld_4.4.bb
@@ -60,38 +60,38 @@ LOCOMO_PATCHES = "\
"
LOCOMO_PATCHES += "file://locomo/0090-locomokbd.c-fix-missing-KEY_CENTER.patch"
-SRC_URI_append_akita = " \
+SRC_URI:append:akita = " \
file://defconfig \
file://OE-vga-logo.patch \
"
-SRC_URI_append_c7x0 = " \
+SRC_URI:append:c7x0 = " \
file://defconfig \
file://OE-vga-logo.patch \
"
-SRC_URI_append_collie = " \
+SRC_URI:append:collie = " \
${LOCOMO_PATCHES} \
file://defconfig \
file://OE-qvga-logo.patch \
"
-SRC_URI_append_h3600 = " \
+SRC_URI:append:h3600 = " \
file://defconfig \
file://OE-qvga-logo.patch \
"
-SRC_URI_append_hx4700 = " \
+SRC_URI:append:hx4700 = " \
file://defconfig \
file://OE-vga-logo.patch \
file://hx4700-change-led-trigger-assignments.patch \
"
-SRC_URI_append_poodle = " \
+SRC_URI:append:poodle = " \
${LOCOMO_PATCHES} \
file://defconfig \
file://OE-qvga-logo.patch \
"
-SRC_URI_append_spitz = " \
+SRC_URI:append:spitz = " \
file://defconfig \
file://OE-vga-logo.patch \
"
-SRC_URI_append_tosa = " \
+SRC_URI:append:tosa = " \
file://defconfig \
file://OE-vga-logo.patch \
file://0001-HACK-video-move-backlight-to-the-end-of-Makefile.patch \
diff --git a/recipes-kernel/linux/linux-kexecboot_4.4.bb b/recipes-kernel/linux/linux-kexecboot_4.4.bb
index 4a3df18..83561a8 100644
--- a/recipes-kernel/linux/linux-kexecboot_4.4.bb
+++ b/recipes-kernel/linux/linux-kexecboot_4.4.bb
@@ -1,5 +1,5 @@
require recipes-kernel/linux/linux-handheld_${PV}.bb
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-${PV}:${THISDIR}/linux-handheld-${PV}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}-${PV}:${THISDIR}/linux-handheld-${PV}:"
SUMMARY = "Linux kernel embedding a minimalistic kexecboot initramfs"
diff --git a/recipes-kernel/linux/linux-qi-ben-nanonote_3.12.bb b/recipes-kernel/linux/linux-qi-ben-nanonote_3.12.bb
index 8d97b26..d6d3bc3 100644
--- a/recipes-kernel/linux/linux-qi-ben-nanonote_3.12.bb
+++ b/recipes-kernel/linux/linux-qi-ben-nanonote_3.12.bb
@@ -18,13 +18,13 @@ S = "${WORKDIR}/git"
inherit kernel
-FILES_${KERNEL_PACKAGE_NAME}-image = "/boot/uImage*"
+FILES:${KERNEL_PACKAGE_NAME}-image = "/boot/uImage*"
-do_configure_prepend() {
+do_configure:prepend() {
install -m 0644 ${S}/arch/mips/configs/qi_lb60_defconfig ${S}/.config
}
-do_install_append() {
+do_install:append() {
cd ${S}
kernel_entry=`nm vmlinux | grep " kernel_entry" | cut -d' ' -f1`
@@ -38,10 +38,10 @@ do_install_append() {
install -m 0644 uImage-${KERNEL_VERSION} ${D}/boot
}
-pkg_postinst_kernel() {
+pkg_postinst:kernel() {
cd /${KERNEL_IMAGEDEST}; update-alternatives --install /${KERNEL_IMAGEDEST}/uImage uImage uImage-${KERNEL_VERSION} ${KERNEL_PRIORITY} || true
}
-pkg_postrm_kernel() {
+pkg_postrm:kernel() {
cd /${KERNEL_IMAGEDEST}; update-alternatives --remove uImage uImage-${KERNEL_VERSION} || true
}