aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2018-08-13 10:21:34 +0200
committerPaul Eggleton <paul.eggleton@linux.intel.com>2018-08-21 11:18:24 +1200
commit2eccc0d9e5dfb14d2694b8d7d88d98fad774f0dd (patch)
tree5fac6110e6486528a5d1fa105ea41c8958274b2b /recipes-kernel
parent3ee3cbfbc09953021cd41ddf8434227ff0633ec7 (diff)
downloadmeta-handheld-2eccc0d9e5dfb14d2694b8d7d88d98fad774f0dd.tar.gz
linux-handheld_4.14: upgrade to 4.14.62
Get latest fixes for gcc8 warnings. Minor edit (one line) to rebase sharpsl patchset with upstream source. Signed-off-by: Andrea Adami <andrea.adami@gmail.com> Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-handheld-4.14/sharpslpart/0001-mtd-sharpslpart-Add-sharpslpart-partition-parser.patch9
-rw-r--r--recipes-kernel/linux/linux-handheld_4.14.bb6
2 files changed, 8 insertions, 7 deletions
diff --git a/recipes-kernel/linux/linux-handheld-4.14/sharpslpart/0001-mtd-sharpslpart-Add-sharpslpart-partition-parser.patch b/recipes-kernel/linux/linux-handheld-4.14/sharpslpart/0001-mtd-sharpslpart-Add-sharpslpart-partition-parser.patch
index 069bc4b..655ce96 100644
--- a/recipes-kernel/linux/linux-handheld-4.14/sharpslpart/0001-mtd-sharpslpart-Add-sharpslpart-partition-parser.patch
+++ b/recipes-kernel/linux/linux-handheld-4.14/sharpslpart/0001-mtd-sharpslpart-Add-sharpslpart-partition-parser.patch
@@ -58,8 +58,8 @@ Reviewed-by: Boris Brezillon <boris.brezillon@free-electrons.com>
---
drivers/mtd/parsers/Kconfig | 8 +
drivers/mtd/parsers/Makefile | 1 +
- drivers/mtd/parsers/sharpslpart.c | 398 ++++++++++++++++++++++++++++++++++++++
- 3 files changed, 407 insertions(+)
+ drivers/mtd/parsers/sharpslpart.c | 399 +++++++++++++++++++++++++++++++++++++++
+ 3 files changed, 408 insertions(+)
create mode 100644 drivers/mtd/parsers/sharpslpart.c
diff --git a/drivers/mtd/parsers/Kconfig b/drivers/mtd/parsers/Kconfig
@@ -90,7 +90,7 @@ new file mode 100644
index 0000000..5fe0079
--- /dev/null
+++ b/drivers/mtd/parsers/sharpslpart.c
-@@ -0,0 +1,398 @@
+@@ -0,0 +1,399 @@
+/*
+ * sharpslpart.c - MTD partition parser for NAND flash using the SHARP FTL
+ * for logical addressing, as used on the PXA models of the SHARP SL Series.
@@ -456,7 +456,8 @@ index 0000000..5fe0079
+ }
+
+ sharpsl_nand_parts = kcalloc(SHARPSL_NAND_PARTS,
-+ sizeof(*sharpsl_nand_parts), GFP_KERNEL);
++ sizeof(*sharpsl_nand_parts),
++ GFP_KERNEL);
+ if (!sharpsl_nand_parts)
+ return -ENOMEM;
+
diff --git a/recipes-kernel/linux/linux-handheld_4.14.bb b/recipes-kernel/linux/linux-handheld_4.14.bb
index b50b1b8..d1b3180 100644
--- a/recipes-kernel/linux/linux-handheld_4.14.bb
+++ b/recipes-kernel/linux/linux-handheld_4.14.bb
@@ -6,12 +6,12 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
COMPATIBLE_MACHINE = "akita|c7x0|spitz|tosa"
SRC_URI = "${KERNELORG_MIRROR}/linux/kernel/v4.x/linux-${PV}.tar.xz;name=kernel \
- ${KERNELORG_MIRROR}/linux/kernel/v4.x/patch-${PV}.56.xz;apply=yes;name=stablepatch \
+ ${KERNELORG_MIRROR}/linux/kernel/v4.x/patch-${PV}.62.xz;apply=yes;name=stablepatch \
"
SRC_URI[kernel.md5sum] = "bacdb9ffdcd922aa069a5e1520160e24"
SRC_URI[kernel.sha256sum] = "f81d59477e90a130857ce18dc02f4fbe5725854911db1e7ba770c7cd350f96a7"
-SRC_URI[stablepatch.md5sum] = "8c115e6026000b0e8ec5311f9fef92c5"
-SRC_URI[stablepatch.sha256sum] = "a6d6b834e7df08aef500053fc007633166d6d01416c6bd3413c164e260a5d809"
+SRC_URI[stablepatch.md5sum] = "725687486363ba8f6b21e7c56e8066ea"
+SRC_URI[stablepatch.sha256sum] = "2595a071c6253fb579fa0401b3deb9a9d1ddb74dd1dcd1e668ed4d8726dc4b6c"
SRC_URI += "\
file://sharpslpart/0001-mtd-sharpslpart-Add-sharpslpart-partition-parser.patch \