aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/zaurus-utils/nandlogical_1.1.0.bb
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2013-09-29 01:54:52 +0200
committerPaul Eggleton <paul.eggleton@linux.intel.com>2013-09-30 21:59:16 +0100
commit86bf074ab313fc6b37dee430f66ec88344c308cd (patch)
treee244e13dd7eae3a7dc30548cc171d935d7f77f9e /recipes-bsp/zaurus-utils/nandlogical_1.1.0.bb
parent5854e4b25598e2c062c03f1e1eaeb32914e10962 (diff)
downloadmeta-handheld-86bf074ab313fc6b37dee430f66ec88344c308cd.tar.gz
nandlogical: move to 1.1.0 and add BBCLASSEXTEND for the klibc version
Remove nandlogical-klibc recipe Sync PV to 1.1.0 like the source tarball Remove PR Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
Diffstat (limited to 'recipes-bsp/zaurus-utils/nandlogical_1.1.0.bb')
-rw-r--r--recipes-bsp/zaurus-utils/nandlogical_1.1.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-bsp/zaurus-utils/nandlogical_1.1.0.bb b/recipes-bsp/zaurus-utils/nandlogical_1.1.0.bb
new file mode 100644
index 0000000..0fb6e2c
--- /dev/null
+++ b/recipes-bsp/zaurus-utils/nandlogical_1.1.0.bb
@@ -0,0 +1,27 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:${THISDIR}/files:"
+
+DESCRIPTION = "Nandlogical for Sharp mtd1"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://nandlogical.c;endline=15;md5=77804e7fdf625e56869f32d9aec762a2"
+
+SRC_URI = "http://distro.ibiblio.org/pub/linux/distributions/pdaxrom/download/1.1.0beta4/src/survive-1.1.0.tar.bz2 \
+ file://oobblock-to-writesize.patch"
+
+SRC_URI[md5sum] = "b6cb17168a424a5d757309dce4a81841"
+SRC_URI[sha256sum] = "0d02edc12509f6dc98cded37c68238f939c522cbd398fd527785a1e7e3bcfcea"
+
+S = "${WORKDIR}/survive-1.1.0"
+
+EXTRA_OEMAKE_class-klibc = "-static -I${STAGING_INCDIR}"
+
+do_compile () {
+ ${CC} ${CFLAGS} ${LDFLAGS} nandlogical.c -o nandlogical
+}
+
+do_install () {
+ install -d ${D}${bindir}/
+ install -m 0755 nandlogical ${D}${bindir}/
+}
+
+COMPATIBLE_MACHINE = "(poodle|c7x0|akita|spitz|tosa)"
+BBCLASSEXTEND = "klibc"