aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/h2200-bootloader
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 19:12:32 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 19:12:32 +0100
commitb1cb3dec64aa744280b886927ec476b885c831f5 (patch)
tree7dc4a9b6d7beeaa2f670196a7f52a4a493898165 /recipes-bsp/h2200-bootloader
downloadmeta-handheld-b1cb3dec64aa744280b886927ec476b885c831f5.tar.gz
initial commit of meta-handheld
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-bsp/h2200-bootloader')
-rw-r--r--recipes-bsp/h2200-bootloader/h2200-bootloader.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes-bsp/h2200-bootloader/h2200-bootloader.bb b/recipes-bsp/h2200-bootloader/h2200-bootloader.bb
new file mode 100644
index 0000000..92194e5
--- /dev/null
+++ b/recipes-bsp/h2200-bootloader/h2200-bootloader.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Bootloader firmware extractor for the h2200 iPAQ"
+LICENSE = "MIT"
+ALLOW_EMPTY = "1"
+PR = "r4"
+
+COMPATIBLE_MACHINE = "h2200"
+#it is a shell script, but lets protect the innocent some more
+PACKAGE_ARCH = "h2200"
+
+pkg_postinst() {
+#!/bin/sh
+mkdir -p /lib/firmware
+dd if=/dev/mtdblock0 of=/lib/firmware/h2200_bootloader.bin 2>/dev/null
+}