aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2014-07-26 16:58:47 +0200
committerPaul Eggleton <paul.eggleton@linux.intel.com>2014-07-28 12:06:55 +0100
commita36a62fef377be55a13808f23bc2924627ecfcf3 (patch)
treee1d12cbd867a1757d6e4c01b3241935469f39422
parent5a7c9592c64b2c543d3138933b317081af7ec12d (diff)
downloadmeta-handheld-a36a62fef377be55a13808f23bc2924627ecfcf3.tar.gz
linux-gcw0-kexecboot_3.12: update defconfig
Follow upstream changes. While there, fix a potential issue with do_package_qa like done in meta-initramfs for the main -kexecboot kernel. Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
-rw-r--r--recipes-kernel/linux/linux-gcw0-kexecboot-3.12/gcw0/defconfig8
-rw-r--r--recipes-kernel/linux/linux-gcw0-kexecboot_3.12.bb1
2 files changed, 6 insertions, 3 deletions
diff --git a/recipes-kernel/linux/linux-gcw0-kexecboot-3.12/gcw0/defconfig b/recipes-kernel/linux/linux-gcw0-kexecboot-3.12/gcw0/defconfig
index e5c5d7e..97e2e82 100644
--- a/recipes-kernel/linux/linux-gcw0-kexecboot-3.12/gcw0/defconfig
+++ b/recipes-kernel/linux/linux-gcw0-kexecboot-3.12/gcw0/defconfig
@@ -7,6 +7,7 @@ CONFIG_PREEMPT_VOLUNTARY=y
CONFIG_KEXEC=y
# CONFIG_SECCOMP is not set
CONFIG_LOCALVERSION="-dingux"
+# CONFIG_LOCALVERSION_AUTO is not set
CONFIG_DEFAULT_HOSTNAME="gcw-zero"
CONFIG_SYSVIPC=y
CONFIG_NO_HZ_IDLE=y
@@ -21,10 +22,8 @@ CONFIG_PROFILING=y
CONFIG_OPROFILE=y
CONFIG_MODULES=y
CONFIG_MODULE_UNLOAD=y
-# CONFIG_LBDAF is not set
# CONFIG_BLK_DEV_BSG is not set
CONFIG_PARTITION_ADVANCED=y
-# CONFIG_EFI_PARTITION is not set
# CONFIG_IOSCHED_CFQ is not set
# CONFIG_CORE_DUMP_DEFAULT_ELF_HEADERS is not set
# CONFIG_SUSPEND is not set
@@ -68,8 +67,10 @@ CONFIG_KEYBOARD_GPIO=y
# CONFIG_INPUT_MOUSE is not set
CONFIG_INPUT_JOYSTICK=y
CONFIG_JOYSTICK_JZ_SADC=y
+CONFIG_JOYSTICK_MXC6225=m
CONFIG_INPUT_MISC=y
CONFIG_INPUT_UINPUT=y
+CONFIG_INPUT_PWM_HAPTIC=y
# CONFIG_SERIO is not set
CONFIG_LEGACY_PTY_COUNT=2
# CONFIG_DEVMEM is not set
@@ -82,6 +83,7 @@ CONFIG_I2C=y
# CONFIG_I2C_COMPAT is not set
CONFIG_I2C_CHARDEV=y
CONFIG_I2C_GPIO=y
+CONFIG_PINCTRL_JZ4770=y
CONFIG_GPIO_SYSFS=y
CONFIG_POWER_SUPPLY=y
CONFIG_PMU_ACT8600_SUPPORT=y
@@ -175,7 +177,7 @@ CONFIG_LEDS_TRIGGERS=y
CONFIG_LEDS_TRIGGER_TIMER=y
CONFIG_RTC_CLASS=y
# CONFIG_RTC_INTF_PROC is not set
-CONFIG_RTC_DRV_JZ4770=y
+CONFIG_RTC_DRV_JZ4740=y
# CONFIG_IOMMU_SUPPORT is not set
CONFIG_PWM=y
CONFIG_PWM_JZ4770=y
diff --git a/recipes-kernel/linux/linux-gcw0-kexecboot_3.12.bb b/recipes-kernel/linux/linux-gcw0-kexecboot_3.12.bb
index 45a18c0..aada422 100644
--- a/recipes-kernel/linux/linux-gcw0-kexecboot_3.12.bb
+++ b/recipes-kernel/linux/linux-gcw0-kexecboot_3.12.bb
@@ -16,6 +16,7 @@ INITRAMFS_TASK = "${INITRAMFS_IMAGE}:do_rootfs"
# disable unneeded tasks
do_install[noexec] = "1"
do_package[noexec] = "1"
+do_package_qa[noexec] = "1"
do_packagedata[noexec] = "1"
do_package_deb[noexec] = "1"
do_package_ipk[noexec] = "1"