aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2014-01-17 21:14:00 +0100
committerAndrea Adami <andrea.adami@gmail.com>2014-01-22 00:42:55 +0100
commit3c13ec4fb851122f3ca5fdd714d0609c43eb6320 (patch)
treec09e74cb520752d96b84a9b66318e21bb79bc23c
parentc6a8de4178eca022fdb6e48296f57614a1854968 (diff)
downloadmeta-handheld-3c13ec4fb851122f3ca5fdd714d0609c43eb6320.tar.gz
linux-yocto*: collie: remove previous MTD CFI patches
Remove the single patches and squash together with next patch preparing for future upstream submission. Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
-rw-r--r--recipes-kernel/linux/linux-yocto-3.10/collie/collie.scc3
-rw-r--r--recipes-kernel/linux/linux-yocto-3.10/patches/patches-mtd/collie-PCR.patch71
-rw-r--r--recipes-kernel/linux/linux-yocto-3.10/patches/patches-mtd/collie-cfi-partitions.patch48
-rw-r--r--recipes-kernel/linux/linux-yocto-3.10/patches/patches-mtd/collie-force-unlock.patch22
-rw-r--r--recipes-kernel/linux/linux-yocto-dev/collie/collie.scc3
-rw-r--r--recipes-kernel/linux/linux-yocto-dev/patches/patches-mtd/collie-PCR.patch71
-rw-r--r--recipes-kernel/linux/linux-yocto-dev/patches/patches-mtd/collie-cfi-partitions.patch48
-rw-r--r--recipes-kernel/linux/linux-yocto-dev/patches/patches-mtd/collie-force-unlock.patch22
-rw-r--r--recipes-kernel/linux/linux-yocto-tiny-kexecboot-3.10/patches/patches-mtd/collie-PCR.patch71
-rw-r--r--recipes-kernel/linux/linux-yocto-tiny-kexecboot-3.10/patches/patches-mtd/collie-cfi-partitions.patch48
-rw-r--r--recipes-kernel/linux/linux-yocto-tiny-kexecboot-3.10/patches/patches-mtd/collie-force-unlock.patch22
-rw-r--r--recipes-kernel/linux/linux-yocto-tiny-kexecboot_3.10.bbappend3
12 files changed, 0 insertions, 432 deletions
diff --git a/recipes-kernel/linux/linux-yocto-3.10/collie/collie.scc b/recipes-kernel/linux/linux-yocto-3.10/collie/collie.scc
index 8d3e8be..0d4b52d 100644
--- a/recipes-kernel/linux/linux-yocto-3.10/collie/collie.scc
+++ b/recipes-kernel/linux/linux-yocto-3.10/collie/collie.scc
@@ -11,10 +11,7 @@ patch ../patches/patches-mtd/collie-eraseinfo.patch
// for 3.12
patch ../patches/patches-mtd/collie-cfi-probe-again.patch
patch ../patches/patches-mtd/collie-mtd-resize.patch
-patch ../patches/patches-mtd/collie-force-unlock.patch
-patch ../patches/patches-mtd/collie-PCR.patch
patch ../patches/patches-mtd/collie-match-cfi-qry.patch
-patch ../patches/patches-mtd/collie-cfi-partitions.patch
patch ../patches/patches-sa1100/collie-irda.patch
patch ../patches/patches-sa1100/collie-add-bootblock.patch
patch ../patches/patches-sa1100/arm-sa1100-add-cpu-clock.patch
diff --git a/recipes-kernel/linux/linux-yocto-3.10/patches/patches-mtd/collie-PCR.patch b/recipes-kernel/linux/linux-yocto-3.10/patches/patches-mtd/collie-PCR.patch
deleted file mode 100644
index 38e9d8a..0000000
--- a/recipes-kernel/linux/linux-yocto-3.10/patches/patches-mtd/collie-PCR.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-From 26bb41a25e95365adfc34e8c48d7a2e0a3bc6670 Mon Sep 17 00:00:00 2001
-From: Andrea Adami <andrea.adami@gmail.com>
-Date: Tue, 31 Dec 2013 17:33:20 +0100
-Subject: [PATCH] mtd: cfi_probe.c: add PCR fixup for collie NOR flash
-
-The Partition Configuration Register on collie defaults to
-an asymmetric configuration of 2 partitions, P0 composed by 3 planes
-and P1 by one plane.
-The cfi code requires equal-sized partitions so we have only 3 choices:
-
-1 single partition (no Dual Work)
-2 symmetric partitions
-4 symmetric partitions
-
-Considering that Sharp-Specific Extended Query hardcodes the value of
-2 (really asymmetric but 2) partitions we reset the PCR here to 0x200
-after the first Read Identifier Codes/OTP command (90H).
-
-Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
----
-diff --git a/drivers/mtd/chips/cfi_probe.c b/drivers/mtd/chips/cfi_probe.c
-index d255352..18b03cd 100644
---- a/drivers/mtd/chips/cfi_probe.c
-+++ b/drivers/mtd/chips/cfi_probe.c
-@@ -228,6 +228,46 @@ static int __xipram cfi_chip_setup(struct map_info *map,
- cfi->mfr = cfi_read_query16(map, base);
- cfi->id = cfi_read_query16(map, base + ofs_factor);
-
-+ /* Sharp LH28F640BFHE partitioning fixup
-+ * The device at boot has 2 asymmetrical partitions:
-+ * HEX = BIN
-+ * 400 = 100 2 P0 3 planes, P1 1 plane (boot default)
-+ */
-+ if (cfi->mfr == CFI_MFR_SHARP && cfi->id == 0x00b0) {
-+ /* read PCR */
-+ unsigned long PCR, SR;
-+ PCR = cfi_read_query16(map, base + 6 * ofs_factor);
-+ //printk ("Partition Configuration Register was:%lx\n", PCR);
-+
-+ /* Set PCR two-cycle command sequence.
-+ * After executing this commands the device returns to
-+ * read array mode and status registers are cleared
-+ *
-+ * HEX BIN NR PARTITIONS
-+ * 400 = 100 2 3 planes + 1 plane (boot default)
-+ *
-+ * 000 = 000 1 1 partition of 4 planes, no Dual Work
-+ * 200 = 010 2 2 partitions of 2 planes
-+ * 700 = 111 4 4 partitions of 1 plane
-+ */
-+ cfi_send_gen_cmd(0x60, 0x200, base, map, cfi, cfi->device_type, NULL);
-+ cfi_send_gen_cmd(0x04, 0x200, base, map, cfi, cfi->device_type, NULL);
-+
-+ /* check Status Register */
-+ cfi_send_gen_cmd(0x70, 0, base, map, cfi, cfi->device_type, NULL);
-+ SR = cfi_read_query16(map, base + 6 * ofs_factor);
-+
-+ /* Optionally Check SR.4, 5
-+ * Both 1 = Command Sequence Error
-+ */
-+ //printk ("Status Register is:%lx\n", SR);
-+
-+ /* read again PCR */
-+ cfi_send_gen_cmd(0x90, addr_unlock1, base, map, cfi, cfi->device_type, NULL);
-+ PCR = cfi_read_query16(map, base + 6 * ofs_factor);
-+ //printk ("Partition Configuration Register is now:%lx\n", PCR);
-+ }
-+
- /* Get AMD/Spansion extended JEDEC ID */
- if (cfi->mfr == CFI_MFR_AMD && (cfi->id & 0xff) == 0x7e)
- cfi->id = cfi_read_query(map, base + 0xe * ofs_factor) << 8 |
diff --git a/recipes-kernel/linux/linux-yocto-3.10/patches/patches-mtd/collie-cfi-partitions.patch b/recipes-kernel/linux/linux-yocto-3.10/patches/patches-mtd/collie-cfi-partitions.patch
deleted file mode 100644
index 1e16311..0000000
--- a/recipes-kernel/linux/linux-yocto-3.10/patches/patches-mtd/collie-cfi-partitions.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From 70890e8687b3d99a575a58e21fe1d13dad157bfe Mon Sep 17 00:00:00 2001
-From: Andrea Adami <andrea.adami@gmail.com>
-Date: Tue, 31 Dec 2013 16:47:48 +0100
-Subject: [PATCH 765/765] mtd: cfi_cmdset_001.c: fixup for reading nr of hw
- partitions on Sharp LH28F640BF
-
-Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
----
- drivers/mtd/chips/cfi_cmdset_0001.c | 16 ++++++++++++++++
- 1 file changed, 16 insertions(+)
-
-diff --git a/drivers/mtd/chips/cfi_cmdset_0001.c b/drivers/mtd/chips/cfi_cmdset_0001.c
-index a5c984a..be0da9a 100644
---- a/drivers/mtd/chips/cfi_cmdset_0001.c
-+++ b/drivers/mtd/chips/cfi_cmdset_0001.c
-@@ -388,6 +388,14 @@ read_pri_intelext(struct map_info *map, __u16 adr)
- if (extp->MinorVersion >= '3') {
- int nb_parts, i;
-
-+ /* Sharp LH28F640BFHE doesn't respect the nr of synch modes/fields
-+ * the value is 0 but there are three fields:
-+ * Synchronous mode read capability configuration 1,2,3
-+ * The first one seems always present, listed as reserved
-+ */
-+ if (cfi->mfr == CFI_MFR_SHARP && cfi->id == 0x00b0)
-+ extra_size += 3;
-+
- /* Number of hardware-partitions */
- extra_size += 1;
- if (extp_size < sizeof(*extp) + extra_size)
-@@ -657,6 +665,14 @@ static int cfi_intelext_partition_fixup(struct mtd_info *mtd,
- /* Burst Read info */
- offs += extp->extra[offs+1]+2;
-
-+ /* Sharp LH28F640BFHE doesn't respect the nr of synch modes/fields
-+ * the value is 0 but there are three fields:
-+ * Synchronous mode read capability configuration 1,2,3
-+ * The first one seems always present, listed as reserved
-+ */
-+ if (cfi->mfr == CFI_MFR_SHARP && cfi->id == 0x00b0)
-+ offs += 3;
-+
- /* Number of partition regions */
- numregions = extp->extra[offs];
- offs += 1;
---
-1.8.1.5
-
diff --git a/recipes-kernel/linux/linux-yocto-3.10/patches/patches-mtd/collie-force-unlock.patch b/recipes-kernel/linux/linux-yocto-3.10/patches/patches-mtd/collie-force-unlock.patch
deleted file mode 100644
index d599d1d..0000000
--- a/recipes-kernel/linux/linux-yocto-3.10/patches/patches-mtd/collie-force-unlock.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From c39115ed52359eb5f0475ea2b4a2e71acb5da54b Mon Sep 17 00:00:00 2001
-From: Andrea Adami <andrea.adami@gmail.com>
-Date: Thu, 7 Nov 2013 23:17:36 +0100
-Subject: [PATCH] collie: force flash unlock on boot
-
-Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
----
- drivers/mtd/chips/cfi_cmdset_0001.c | 1 +
- 1 file changed, 1 insertions(+), 0 deletion(-)
-
-diff --git a/drivers/mtd/chips/cfi_cmdset_0001.c b/drivers/mtd/chips/cfi_cmdset_0001.c
-index 7751443..d9d6f0e 100644
---- a/drivers/mtd/chips/cfi_cmdset_0001.c
-+++ b/drivers/mtd/chips/cfi_cmdset_0001.c
-@@ -310,6 +310,7 @@ static struct cfi_fixup cfi_fixup_table[] = {
- { CFI_MFR_ST, 0x00ba, /* M28W320CT */ fixup_st_m28w320ct },
- { CFI_MFR_ST, 0x00bb, /* M28W320CB */ fixup_st_m28w320cb },
- { CFI_MFR_INTEL, CFI_ID_ANY, fixup_unlock_powerup_lock },
-+ { CFI_MFR_SHARP, 0x00b0, fixup_unlock_powerup_lock },
- { 0, 0, NULL }
- };
-
diff --git a/recipes-kernel/linux/linux-yocto-dev/collie/collie.scc b/recipes-kernel/linux/linux-yocto-dev/collie/collie.scc
index 328c062..ef9551e 100644
--- a/recipes-kernel/linux/linux-yocto-dev/collie/collie.scc
+++ b/recipes-kernel/linux/linux-yocto-dev/collie/collie.scc
@@ -5,10 +5,7 @@ include ../zaurus-common.scc
patch ../patches/patches-locomokbd/locomo_kbd_tweak-r2.patch
patch ../patches/patches-mtd/collie-cfi-probe-again.patch
patch ../patches/patches-mtd/collie-mtd-resize.patch
-patch ../patches/patches-mtd/collie-force-unlock.patch
-patch ../patches/patches-mtd/collie-PCR.patch
patch ../patches/patches-mtd/collie-match-cfi-qry.patch
-patch ../patches/patches-mtd/collie-cfi-partitions.patch
patch ../patches/patches-sa1100/collie-irda.patch
patch ../patches/patches-sa1100/collie-add-bootblock.patch
patch ../patches/patches-sa1100/arm-sa1100-add-cpu-clock.patch
diff --git a/recipes-kernel/linux/linux-yocto-dev/patches/patches-mtd/collie-PCR.patch b/recipes-kernel/linux/linux-yocto-dev/patches/patches-mtd/collie-PCR.patch
deleted file mode 100644
index 38e9d8a..0000000
--- a/recipes-kernel/linux/linux-yocto-dev/patches/patches-mtd/collie-PCR.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-From 26bb41a25e95365adfc34e8c48d7a2e0a3bc6670 Mon Sep 17 00:00:00 2001
-From: Andrea Adami <andrea.adami@gmail.com>
-Date: Tue, 31 Dec 2013 17:33:20 +0100
-Subject: [PATCH] mtd: cfi_probe.c: add PCR fixup for collie NOR flash
-
-The Partition Configuration Register on collie defaults to
-an asymmetric configuration of 2 partitions, P0 composed by 3 planes
-and P1 by one plane.
-The cfi code requires equal-sized partitions so we have only 3 choices:
-
-1 single partition (no Dual Work)
-2 symmetric partitions
-4 symmetric partitions
-
-Considering that Sharp-Specific Extended Query hardcodes the value of
-2 (really asymmetric but 2) partitions we reset the PCR here to 0x200
-after the first Read Identifier Codes/OTP command (90H).
-
-Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
----
-diff --git a/drivers/mtd/chips/cfi_probe.c b/drivers/mtd/chips/cfi_probe.c
-index d255352..18b03cd 100644
---- a/drivers/mtd/chips/cfi_probe.c
-+++ b/drivers/mtd/chips/cfi_probe.c
-@@ -228,6 +228,46 @@ static int __xipram cfi_chip_setup(struct map_info *map,
- cfi->mfr = cfi_read_query16(map, base);
- cfi->id = cfi_read_query16(map, base + ofs_factor);
-
-+ /* Sharp LH28F640BFHE partitioning fixup
-+ * The device at boot has 2 asymmetrical partitions:
-+ * HEX = BIN
-+ * 400 = 100 2 P0 3 planes, P1 1 plane (boot default)
-+ */
-+ if (cfi->mfr == CFI_MFR_SHARP && cfi->id == 0x00b0) {
-+ /* read PCR */
-+ unsigned long PCR, SR;
-+ PCR = cfi_read_query16(map, base + 6 * ofs_factor);
-+ //printk ("Partition Configuration Register was:%lx\n", PCR);
-+
-+ /* Set PCR two-cycle command sequence.
-+ * After executing this commands the device returns to
-+ * read array mode and status registers are cleared
-+ *
-+ * HEX BIN NR PARTITIONS
-+ * 400 = 100 2 3 planes + 1 plane (boot default)
-+ *
-+ * 000 = 000 1 1 partition of 4 planes, no Dual Work
-+ * 200 = 010 2 2 partitions of 2 planes
-+ * 700 = 111 4 4 partitions of 1 plane
-+ */
-+ cfi_send_gen_cmd(0x60, 0x200, base, map, cfi, cfi->device_type, NULL);
-+ cfi_send_gen_cmd(0x04, 0x200, base, map, cfi, cfi->device_type, NULL);
-+
-+ /* check Status Register */
-+ cfi_send_gen_cmd(0x70, 0, base, map, cfi, cfi->device_type, NULL);
-+ SR = cfi_read_query16(map, base + 6 * ofs_factor);
-+
-+ /* Optionally Check SR.4, 5
-+ * Both 1 = Command Sequence Error
-+ */
-+ //printk ("Status Register is:%lx\n", SR);
-+
-+ /* read again PCR */
-+ cfi_send_gen_cmd(0x90, addr_unlock1, base, map, cfi, cfi->device_type, NULL);
-+ PCR = cfi_read_query16(map, base + 6 * ofs_factor);
-+ //printk ("Partition Configuration Register is now:%lx\n", PCR);
-+ }
-+
- /* Get AMD/Spansion extended JEDEC ID */
- if (cfi->mfr == CFI_MFR_AMD && (cfi->id & 0xff) == 0x7e)
- cfi->id = cfi_read_query(map, base + 0xe * ofs_factor) << 8 |
diff --git a/recipes-kernel/linux/linux-yocto-dev/patches/patches-mtd/collie-cfi-partitions.patch b/recipes-kernel/linux/linux-yocto-dev/patches/patches-mtd/collie-cfi-partitions.patch
deleted file mode 100644
index 1e16311..0000000
--- a/recipes-kernel/linux/linux-yocto-dev/patches/patches-mtd/collie-cfi-partitions.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From 70890e8687b3d99a575a58e21fe1d13dad157bfe Mon Sep 17 00:00:00 2001
-From: Andrea Adami <andrea.adami@gmail.com>
-Date: Tue, 31 Dec 2013 16:47:48 +0100
-Subject: [PATCH 765/765] mtd: cfi_cmdset_001.c: fixup for reading nr of hw
- partitions on Sharp LH28F640BF
-
-Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
----
- drivers/mtd/chips/cfi_cmdset_0001.c | 16 ++++++++++++++++
- 1 file changed, 16 insertions(+)
-
-diff --git a/drivers/mtd/chips/cfi_cmdset_0001.c b/drivers/mtd/chips/cfi_cmdset_0001.c
-index a5c984a..be0da9a 100644
---- a/drivers/mtd/chips/cfi_cmdset_0001.c
-+++ b/drivers/mtd/chips/cfi_cmdset_0001.c
-@@ -388,6 +388,14 @@ read_pri_intelext(struct map_info *map, __u16 adr)
- if (extp->MinorVersion >= '3') {
- int nb_parts, i;
-
-+ /* Sharp LH28F640BFHE doesn't respect the nr of synch modes/fields
-+ * the value is 0 but there are three fields:
-+ * Synchronous mode read capability configuration 1,2,3
-+ * The first one seems always present, listed as reserved
-+ */
-+ if (cfi->mfr == CFI_MFR_SHARP && cfi->id == 0x00b0)
-+ extra_size += 3;
-+
- /* Number of hardware-partitions */
- extra_size += 1;
- if (extp_size < sizeof(*extp) + extra_size)
-@@ -657,6 +665,14 @@ static int cfi_intelext_partition_fixup(struct mtd_info *mtd,
- /* Burst Read info */
- offs += extp->extra[offs+1]+2;
-
-+ /* Sharp LH28F640BFHE doesn't respect the nr of synch modes/fields
-+ * the value is 0 but there are three fields:
-+ * Synchronous mode read capability configuration 1,2,3
-+ * The first one seems always present, listed as reserved
-+ */
-+ if (cfi->mfr == CFI_MFR_SHARP && cfi->id == 0x00b0)
-+ offs += 3;
-+
- /* Number of partition regions */
- numregions = extp->extra[offs];
- offs += 1;
---
-1.8.1.5
-
diff --git a/recipes-kernel/linux/linux-yocto-dev/patches/patches-mtd/collie-force-unlock.patch b/recipes-kernel/linux/linux-yocto-dev/patches/patches-mtd/collie-force-unlock.patch
deleted file mode 100644
index d599d1d..0000000
--- a/recipes-kernel/linux/linux-yocto-dev/patches/patches-mtd/collie-force-unlock.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From c39115ed52359eb5f0475ea2b4a2e71acb5da54b Mon Sep 17 00:00:00 2001
-From: Andrea Adami <andrea.adami@gmail.com>
-Date: Thu, 7 Nov 2013 23:17:36 +0100
-Subject: [PATCH] collie: force flash unlock on boot
-
-Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
----
- drivers/mtd/chips/cfi_cmdset_0001.c | 1 +
- 1 file changed, 1 insertions(+), 0 deletion(-)
-
-diff --git a/drivers/mtd/chips/cfi_cmdset_0001.c b/drivers/mtd/chips/cfi_cmdset_0001.c
-index 7751443..d9d6f0e 100644
---- a/drivers/mtd/chips/cfi_cmdset_0001.c
-+++ b/drivers/mtd/chips/cfi_cmdset_0001.c
-@@ -310,6 +310,7 @@ static struct cfi_fixup cfi_fixup_table[] = {
- { CFI_MFR_ST, 0x00ba, /* M28W320CT */ fixup_st_m28w320ct },
- { CFI_MFR_ST, 0x00bb, /* M28W320CB */ fixup_st_m28w320cb },
- { CFI_MFR_INTEL, CFI_ID_ANY, fixup_unlock_powerup_lock },
-+ { CFI_MFR_SHARP, 0x00b0, fixup_unlock_powerup_lock },
- { 0, 0, NULL }
- };
-
diff --git a/recipes-kernel/linux/linux-yocto-tiny-kexecboot-3.10/patches/patches-mtd/collie-PCR.patch b/recipes-kernel/linux/linux-yocto-tiny-kexecboot-3.10/patches/patches-mtd/collie-PCR.patch
deleted file mode 100644
index 38e9d8a..0000000
--- a/recipes-kernel/linux/linux-yocto-tiny-kexecboot-3.10/patches/patches-mtd/collie-PCR.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-From 26bb41a25e95365adfc34e8c48d7a2e0a3bc6670 Mon Sep 17 00:00:00 2001
-From: Andrea Adami <andrea.adami@gmail.com>
-Date: Tue, 31 Dec 2013 17:33:20 +0100
-Subject: [PATCH] mtd: cfi_probe.c: add PCR fixup for collie NOR flash
-
-The Partition Configuration Register on collie defaults to
-an asymmetric configuration of 2 partitions, P0 composed by 3 planes
-and P1 by one plane.
-The cfi code requires equal-sized partitions so we have only 3 choices:
-
-1 single partition (no Dual Work)
-2 symmetric partitions
-4 symmetric partitions
-
-Considering that Sharp-Specific Extended Query hardcodes the value of
-2 (really asymmetric but 2) partitions we reset the PCR here to 0x200
-after the first Read Identifier Codes/OTP command (90H).
-
-Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
----
-diff --git a/drivers/mtd/chips/cfi_probe.c b/drivers/mtd/chips/cfi_probe.c
-index d255352..18b03cd 100644
---- a/drivers/mtd/chips/cfi_probe.c
-+++ b/drivers/mtd/chips/cfi_probe.c
-@@ -228,6 +228,46 @@ static int __xipram cfi_chip_setup(struct map_info *map,
- cfi->mfr = cfi_read_query16(map, base);
- cfi->id = cfi_read_query16(map, base + ofs_factor);
-
-+ /* Sharp LH28F640BFHE partitioning fixup
-+ * The device at boot has 2 asymmetrical partitions:
-+ * HEX = BIN
-+ * 400 = 100 2 P0 3 planes, P1 1 plane (boot default)
-+ */
-+ if (cfi->mfr == CFI_MFR_SHARP && cfi->id == 0x00b0) {
-+ /* read PCR */
-+ unsigned long PCR, SR;
-+ PCR = cfi_read_query16(map, base + 6 * ofs_factor);
-+ //printk ("Partition Configuration Register was:%lx\n", PCR);
-+
-+ /* Set PCR two-cycle command sequence.
-+ * After executing this commands the device returns to
-+ * read array mode and status registers are cleared
-+ *
-+ * HEX BIN NR PARTITIONS
-+ * 400 = 100 2 3 planes + 1 plane (boot default)
-+ *
-+ * 000 = 000 1 1 partition of 4 planes, no Dual Work
-+ * 200 = 010 2 2 partitions of 2 planes
-+ * 700 = 111 4 4 partitions of 1 plane
-+ */
-+ cfi_send_gen_cmd(0x60, 0x200, base, map, cfi, cfi->device_type, NULL);
-+ cfi_send_gen_cmd(0x04, 0x200, base, map, cfi, cfi->device_type, NULL);
-+
-+ /* check Status Register */
-+ cfi_send_gen_cmd(0x70, 0, base, map, cfi, cfi->device_type, NULL);
-+ SR = cfi_read_query16(map, base + 6 * ofs_factor);
-+
-+ /* Optionally Check SR.4, 5
-+ * Both 1 = Command Sequence Error
-+ */
-+ //printk ("Status Register is:%lx\n", SR);
-+
-+ /* read again PCR */
-+ cfi_send_gen_cmd(0x90, addr_unlock1, base, map, cfi, cfi->device_type, NULL);
-+ PCR = cfi_read_query16(map, base + 6 * ofs_factor);
-+ //printk ("Partition Configuration Register is now:%lx\n", PCR);
-+ }
-+
- /* Get AMD/Spansion extended JEDEC ID */
- if (cfi->mfr == CFI_MFR_AMD && (cfi->id & 0xff) == 0x7e)
- cfi->id = cfi_read_query(map, base + 0xe * ofs_factor) << 8 |
diff --git a/recipes-kernel/linux/linux-yocto-tiny-kexecboot-3.10/patches/patches-mtd/collie-cfi-partitions.patch b/recipes-kernel/linux/linux-yocto-tiny-kexecboot-3.10/patches/patches-mtd/collie-cfi-partitions.patch
deleted file mode 100644
index 1e16311..0000000
--- a/recipes-kernel/linux/linux-yocto-tiny-kexecboot-3.10/patches/patches-mtd/collie-cfi-partitions.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From 70890e8687b3d99a575a58e21fe1d13dad157bfe Mon Sep 17 00:00:00 2001
-From: Andrea Adami <andrea.adami@gmail.com>
-Date: Tue, 31 Dec 2013 16:47:48 +0100
-Subject: [PATCH 765/765] mtd: cfi_cmdset_001.c: fixup for reading nr of hw
- partitions on Sharp LH28F640BF
-
-Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
----
- drivers/mtd/chips/cfi_cmdset_0001.c | 16 ++++++++++++++++
- 1 file changed, 16 insertions(+)
-
-diff --git a/drivers/mtd/chips/cfi_cmdset_0001.c b/drivers/mtd/chips/cfi_cmdset_0001.c
-index a5c984a..be0da9a 100644
---- a/drivers/mtd/chips/cfi_cmdset_0001.c
-+++ b/drivers/mtd/chips/cfi_cmdset_0001.c
-@@ -388,6 +388,14 @@ read_pri_intelext(struct map_info *map, __u16 adr)
- if (extp->MinorVersion >= '3') {
- int nb_parts, i;
-
-+ /* Sharp LH28F640BFHE doesn't respect the nr of synch modes/fields
-+ * the value is 0 but there are three fields:
-+ * Synchronous mode read capability configuration 1,2,3
-+ * The first one seems always present, listed as reserved
-+ */
-+ if (cfi->mfr == CFI_MFR_SHARP && cfi->id == 0x00b0)
-+ extra_size += 3;
-+
- /* Number of hardware-partitions */
- extra_size += 1;
- if (extp_size < sizeof(*extp) + extra_size)
-@@ -657,6 +665,14 @@ static int cfi_intelext_partition_fixup(struct mtd_info *mtd,
- /* Burst Read info */
- offs += extp->extra[offs+1]+2;
-
-+ /* Sharp LH28F640BFHE doesn't respect the nr of synch modes/fields
-+ * the value is 0 but there are three fields:
-+ * Synchronous mode read capability configuration 1,2,3
-+ * The first one seems always present, listed as reserved
-+ */
-+ if (cfi->mfr == CFI_MFR_SHARP && cfi->id == 0x00b0)
-+ offs += 3;
-+
- /* Number of partition regions */
- numregions = extp->extra[offs];
- offs += 1;
---
-1.8.1.5
-
diff --git a/recipes-kernel/linux/linux-yocto-tiny-kexecboot-3.10/patches/patches-mtd/collie-force-unlock.patch b/recipes-kernel/linux/linux-yocto-tiny-kexecboot-3.10/patches/patches-mtd/collie-force-unlock.patch
deleted file mode 100644
index d599d1d..0000000
--- a/recipes-kernel/linux/linux-yocto-tiny-kexecboot-3.10/patches/patches-mtd/collie-force-unlock.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From c39115ed52359eb5f0475ea2b4a2e71acb5da54b Mon Sep 17 00:00:00 2001
-From: Andrea Adami <andrea.adami@gmail.com>
-Date: Thu, 7 Nov 2013 23:17:36 +0100
-Subject: [PATCH] collie: force flash unlock on boot
-
-Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
----
- drivers/mtd/chips/cfi_cmdset_0001.c | 1 +
- 1 file changed, 1 insertions(+), 0 deletion(-)
-
-diff --git a/drivers/mtd/chips/cfi_cmdset_0001.c b/drivers/mtd/chips/cfi_cmdset_0001.c
-index 7751443..d9d6f0e 100644
---- a/drivers/mtd/chips/cfi_cmdset_0001.c
-+++ b/drivers/mtd/chips/cfi_cmdset_0001.c
-@@ -310,6 +310,7 @@ static struct cfi_fixup cfi_fixup_table[] = {
- { CFI_MFR_ST, 0x00ba, /* M28W320CT */ fixup_st_m28w320ct },
- { CFI_MFR_ST, 0x00bb, /* M28W320CB */ fixup_st_m28w320cb },
- { CFI_MFR_INTEL, CFI_ID_ANY, fixup_unlock_powerup_lock },
-+ { CFI_MFR_SHARP, 0x00b0, fixup_unlock_powerup_lock },
- { 0, 0, NULL }
- };
-
diff --git a/recipes-kernel/linux/linux-yocto-tiny-kexecboot_3.10.bbappend b/recipes-kernel/linux/linux-yocto-tiny-kexecboot_3.10.bbappend
index f6a7fc9..8a29956 100644
--- a/recipes-kernel/linux/linux-yocto-tiny-kexecboot_3.10.bbappend
+++ b/recipes-kernel/linux/linux-yocto-tiny-kexecboot_3.10.bbappend
@@ -44,10 +44,7 @@ SRC_URI_append_collie = " \
file://patches/patches-mtd/collie-eraseinfo.patch \
file://patches/patches-mtd/collie-cfi-probe-again.patch \
file://patches/patches-mtd/collie-mtd-resize.patch \
- file://patches/patches-mtd/collie-force-unlock.patch \
- file://patches/patches-mtd/collie-PCR.patch \
file://patches/patches-mtd/collie-match-cfi-qry.patch \
- file://patches/patches-mtd/collie-cfi-partitions.patch \
file://patches/patches-sa1100/collie-irda.patch \
file://patches/patches-sa1100/collie-add-bootblock.patch \
file://patches/patches-sa1100/arm-sa1100-add-cpu-clock.patch \