aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2014-10-13 00:03:46 +0200
committerPaul Eggleton <paul.eggleton@linux.intel.com>2014-11-01 11:01:28 +0000
commit82c56a6acf38895bd4387540f7ab08a80f3bd522 (patch)
tree717bb0f6ac2550b1d92beebc414368c4508d9a56
parent57044c88e22443f312fe812cc481449c0110f2ef (diff)
downloadmeta-handheld-82c56a6acf38895bd4387540f7ab08a80f3bd522.tar.gz
linux-yocto(-tiny-kexecboot): collie: fixup for mtd resume after pm suspend
Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
-rw-r--r--recipes-kernel/linux/linux-yocto-3.17/collie/mtd-resume.patch34
-rw-r--r--recipes-kernel/linux/linux-yocto-tiny-kexecboot_3.17.bbappend1
-rw-r--r--recipes-kernel/linux/linux-yocto_3.17.bbappend1
3 files changed, 36 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-yocto-3.17/collie/mtd-resume.patch b/recipes-kernel/linux/linux-yocto-3.17/collie/mtd-resume.patch
new file mode 100644
index 0000000..3cee9b3
--- /dev/null
+++ b/recipes-kernel/linux/linux-yocto-3.17/collie/mtd-resume.patch
@@ -0,0 +1,34 @@
+From 6d34f776e8dba9cba5520db7d27a31102238f66e Mon Sep 17 00:00:00 2001
+From: Andrea Adami <andrea.adami@gmail.com>
+Date: Sun, 12 Oct 2014 12:31:36 +0200
+Subject: [PATCH 1130/1130] mtd: cfi_cmdset_0001.c: fix resume for LH28F640BF
+ chips
+
+After '#echo mem > /sys/power/state' the device can not be resumed
+because apparently the Partition Configuration Register has been reset
+to default. This should only happen after cold/boot or hard reset but
+the behavior is confirmed on 2 different end-user devices.
+
+Tested on zaurus collie with kernel 3.17-rc7
+
+Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
+---
+ drivers/mtd/chips/cfi_cmdset_0001.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/drivers/mtd/chips/cfi_cmdset_0001.c b/drivers/mtd/chips/cfi_cmdset_0001.c
+index a7543ba..59e2355 100644
+--- a/drivers/mtd/chips/cfi_cmdset_0001.c
++++ b/drivers/mtd/chips/cfi_cmdset_0001.c
+@@ -2590,6 +2590,8 @@ static void cfi_intelext_resume(struct mtd_info *mtd)
+
+ /* Go to known state. Chip may have been power cycled */
+ if (chip->state == FL_PM_SUSPENDED) {
++ /* Refresh LH28F640BF Partition Configuration Register */
++ fixup_LH28F640BF(mtd);
+ map_write(map, CMD(0xFF), cfi->chips[i].start);
+ chip->oldstate = chip->state = FL_READY;
+ wake_up(&chip->wq);
+--
+1.9.1
+
diff --git a/recipes-kernel/linux/linux-yocto-tiny-kexecboot_3.17.bbappend b/recipes-kernel/linux/linux-yocto-tiny-kexecboot_3.17.bbappend
index 11d7f11..909d66e 100644
--- a/recipes-kernel/linux/linux-yocto-tiny-kexecboot_3.17.bbappend
+++ b/recipes-kernel/linux/linux-yocto-tiny-kexecboot_3.17.bbappend
@@ -54,6 +54,7 @@ SRC_URI_append_collie = " \
file://locomolcd-suspend-resume.patch \
\
file://collie-use-gpio-charger.patch \
+ file://mtd-resume.patch \
\
"
diff --git a/recipes-kernel/linux/linux-yocto_3.17.bbappend b/recipes-kernel/linux/linux-yocto_3.17.bbappend
index 116c7ce..992bc85 100644
--- a/recipes-kernel/linux/linux-yocto_3.17.bbappend
+++ b/recipes-kernel/linux/linux-yocto_3.17.bbappend
@@ -51,6 +51,7 @@ SRC_URI_append_collie = " \
file://locomolcd-suspend-resume.patch \
\
file://collie-use-gpio-charger.patch \
+ file://mtd-resume.patch \
\
"