aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2013-12-29 23:41:41 +0100
committerAndrea Adami <andrea.adami@gmail.com>2013-12-31 18:37:59 +0100
commit96a35cfddb247a55adf15af12f1ca396073eb338 (patch)
tree75c1ffb8c6de18f09d398f3b7042c0dcce5a744f
parentb3a19b00c9caebd02f41aaa28e3a764e8c56c510 (diff)
downloadmeta-handheld-96a35cfddb247a55adf15af12f1ca396073eb338.tar.gz
linux-yocto*: collie: revert brute hack for CFI detection
We have now a less intrusive hack to 'fix' QRY answer. Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
-rw-r--r--recipes-kernel/linux/linux-yocto-3.10/collie/collie.scc1
-rw-r--r--recipes-kernel/linux/linux-yocto-3.10/patches/patches-mtd/collie-force-cfi.patch30
-rw-r--r--recipes-kernel/linux/linux-yocto-dev/collie/collie.scc1
-rw-r--r--recipes-kernel/linux/linux-yocto-dev/patches/patches-mtd/collie-force-cfi.patch30
-rw-r--r--recipes-kernel/linux/linux-yocto-tiny-kexecboot-3.10/patches/patches-mtd/collie-force-cfi.patch30
-rw-r--r--recipes-kernel/linux/linux-yocto-tiny-kexecboot_3.10.bbappend1
6 files changed, 0 insertions, 93 deletions
diff --git a/recipes-kernel/linux/linux-yocto-3.10/collie/collie.scc b/recipes-kernel/linux/linux-yocto-3.10/collie/collie.scc
index 9980c68..cd28890 100644
--- a/recipes-kernel/linux/linux-yocto-3.10/collie/collie.scc
+++ b/recipes-kernel/linux/linux-yocto-3.10/collie/collie.scc
@@ -10,7 +10,6 @@ patch ../patches/patches-mtd/collie-jedec-probe.patch
patch ../patches/patches-mtd/collie-eraseinfo.patch
// for 3.12
patch ../patches/patches-mtd/collie-cfi-probe-again.patch
-patch ../patches/patches-mtd/collie-force-cfi.patch
patch ../patches/patches-mtd/collie-mtd-resize.patch
patch ../patches/patches-mtd/collie-force-unlock.patch
patch ../patches/patches-mtd/collie-PCR.patch
diff --git a/recipes-kernel/linux/linux-yocto-3.10/patches/patches-mtd/collie-force-cfi.patch b/recipes-kernel/linux/linux-yocto-3.10/patches/patches-mtd/collie-force-cfi.patch
deleted file mode 100644
index 958fce7..0000000
--- a/recipes-kernel/linux/linux-yocto-3.10/patches/patches-mtd/collie-force-cfi.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From c39115ed52359eb5f0475ea2b4a2e71acb5da54b Mon Sep 17 00:00:00 2001
-From: Andrea Adami <andrea.adami@gmail.com>
-Date: Thu, 7 Nov 2013 23:17:36 +0100
-Subject: [PATCH] cfi_util.c: force CFI detection even if Q R Y test
- fails
-
-Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
----
- drivers/mtd/chips/cfi_util.c | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/drivers/mtd/chips/cfi_util.c b/drivers/mtd/chips/cfi_util.c
-index f992418..bdee7b9 100644
---- a/drivers/mtd/chips/cfi_util.c
-+++ b/drivers/mtd/chips/cfi_util.c
-@@ -85,7 +85,10 @@ int __xipram cfi_qry_mode_on(uint32_t base, struct map_info *map,
- if (cfi_qry_present(map, base, cfi))
- return 1;
- /* QRY not found */
-- return 0;
-+/* return 0; */
-+
-+/* FIXME: UGLY HACK: FORCE DETECTION */
-+ return 1;
- }
- EXPORT_SYMBOL_GPL(cfi_qry_mode_on);
-
---
-1.8.1.5
-
diff --git a/recipes-kernel/linux/linux-yocto-dev/collie/collie.scc b/recipes-kernel/linux/linux-yocto-dev/collie/collie.scc
index 816d2c2..afdc808 100644
--- a/recipes-kernel/linux/linux-yocto-dev/collie/collie.scc
+++ b/recipes-kernel/linux/linux-yocto-dev/collie/collie.scc
@@ -4,7 +4,6 @@ include ../zaurus-common.scc
patch ../patches/patches-locomokbd/locomo_kbd_tweak-r2.patch
patch ../patches/patches-mtd/collie-cfi-probe-again.patch
-patch ../patches/patches-mtd/collie-force-cfi.patch
patch ../patches/patches-mtd/collie-mtd-resize.patch
patch ../patches/patches-mtd/collie-force-unlock.patch
patch ../patches/patches-mtd/collie-PCR.patch
diff --git a/recipes-kernel/linux/linux-yocto-dev/patches/patches-mtd/collie-force-cfi.patch b/recipes-kernel/linux/linux-yocto-dev/patches/patches-mtd/collie-force-cfi.patch
deleted file mode 100644
index 958fce7..0000000
--- a/recipes-kernel/linux/linux-yocto-dev/patches/patches-mtd/collie-force-cfi.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From c39115ed52359eb5f0475ea2b4a2e71acb5da54b Mon Sep 17 00:00:00 2001
-From: Andrea Adami <andrea.adami@gmail.com>
-Date: Thu, 7 Nov 2013 23:17:36 +0100
-Subject: [PATCH] cfi_util.c: force CFI detection even if Q R Y test
- fails
-
-Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
----
- drivers/mtd/chips/cfi_util.c | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/drivers/mtd/chips/cfi_util.c b/drivers/mtd/chips/cfi_util.c
-index f992418..bdee7b9 100644
---- a/drivers/mtd/chips/cfi_util.c
-+++ b/drivers/mtd/chips/cfi_util.c
-@@ -85,7 +85,10 @@ int __xipram cfi_qry_mode_on(uint32_t base, struct map_info *map,
- if (cfi_qry_present(map, base, cfi))
- return 1;
- /* QRY not found */
-- return 0;
-+/* return 0; */
-+
-+/* FIXME: UGLY HACK: FORCE DETECTION */
-+ return 1;
- }
- EXPORT_SYMBOL_GPL(cfi_qry_mode_on);
-
---
-1.8.1.5
-
diff --git a/recipes-kernel/linux/linux-yocto-tiny-kexecboot-3.10/patches/patches-mtd/collie-force-cfi.patch b/recipes-kernel/linux/linux-yocto-tiny-kexecboot-3.10/patches/patches-mtd/collie-force-cfi.patch
deleted file mode 100644
index 958fce7..0000000
--- a/recipes-kernel/linux/linux-yocto-tiny-kexecboot-3.10/patches/patches-mtd/collie-force-cfi.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From c39115ed52359eb5f0475ea2b4a2e71acb5da54b Mon Sep 17 00:00:00 2001
-From: Andrea Adami <andrea.adami@gmail.com>
-Date: Thu, 7 Nov 2013 23:17:36 +0100
-Subject: [PATCH] cfi_util.c: force CFI detection even if Q R Y test
- fails
-
-Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
----
- drivers/mtd/chips/cfi_util.c | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/drivers/mtd/chips/cfi_util.c b/drivers/mtd/chips/cfi_util.c
-index f992418..bdee7b9 100644
---- a/drivers/mtd/chips/cfi_util.c
-+++ b/drivers/mtd/chips/cfi_util.c
-@@ -85,7 +85,10 @@ int __xipram cfi_qry_mode_on(uint32_t base, struct map_info *map,
- if (cfi_qry_present(map, base, cfi))
- return 1;
- /* QRY not found */
-- return 0;
-+/* return 0; */
-+
-+/* FIXME: UGLY HACK: FORCE DETECTION */
-+ return 1;
- }
- EXPORT_SYMBOL_GPL(cfi_qry_mode_on);
-
---
-1.8.1.5
-
diff --git a/recipes-kernel/linux/linux-yocto-tiny-kexecboot_3.10.bbappend b/recipes-kernel/linux/linux-yocto-tiny-kexecboot_3.10.bbappend
index 2238cbc..b729841 100644
--- a/recipes-kernel/linux/linux-yocto-tiny-kexecboot_3.10.bbappend
+++ b/recipes-kernel/linux/linux-yocto-tiny-kexecboot_3.10.bbappend
@@ -43,7 +43,6 @@ SRC_URI_append_collie = " \
file://patches/patches-mtd/collie-jedec-probe.patch \
file://patches/patches-mtd/collie-eraseinfo.patch \
file://patches/patches-mtd/collie-cfi-probe-again.patch \
- file://patches/patches-mtd/collie-force-cfi.patch \
file://patches/patches-mtd/collie-mtd-resize.patch \
file://patches/patches-mtd/collie-force-unlock.patch \
file://patches/patches-mtd/collie-PCR.patch \