aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2014-04-30 00:38:43 +0200
committerPaul Eggleton <paul.eggleton@linux.intel.com>2014-05-20 09:35:17 +0100
commit675ed509acb1faa0db7fafc003fb79f4da62537c (patch)
tree81c45089926d9bd27079e66b9d5e3623642532a3
parent66d3353c65a94f984c77d4eddf5b3f684b509d44 (diff)
downloadmeta-handheld-675ed509acb1faa0db7fafc003fb79f4da62537c.tar.gz
linux-yocto*: explicitly declare KCONFIG_MODE
The default for fragment-based recipes is '--alldefconfig' but using defconfig it is necessary to specify it. (An hidden bug in the kernel tools has masked that until now...) Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
-rw-r--r--recipes-kernel/linux/linux-yocto-dev.bbappend4
-rw-r--r--recipes-kernel/linux/linux-yocto-tiny-kexecboot_3.10.bbappend14
-rw-r--r--recipes-kernel/linux/linux-yocto_3.10.bbappend11
-rw-r--r--recipes-kernel/linux/linux-yocto_3.14.bbappend9
4 files changed, 34 insertions, 4 deletions
diff --git a/recipes-kernel/linux/linux-yocto-dev.bbappend b/recipes-kernel/linux/linux-yocto-dev.bbappend
index a3571c8..4594c6d 100644
--- a/recipes-kernel/linux/linux-yocto-dev.bbappend
+++ b/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -8,6 +8,10 @@ COMPATIBLE_MACHINE .= "|h1940"
KERNEL_EXTRA_FEATURES_h1940 ?= ""
KMACHINE_h1940 = "h1940"
+# Note: Providing "defconfig" we bypass the linux-yocto processing
+# re-expand the defconfig produced by "make_savedefconfig"
+KCONFIG_MODE_h1940 = "--alldefconfig"
+
SRC_URI_append_h1940 = " \
file://defconfig \
file://0001-s3c24xx-DMA-don-t-use-autoreload-feature.patch \
diff --git a/recipes-kernel/linux/linux-yocto-tiny-kexecboot_3.10.bbappend b/recipes-kernel/linux/linux-yocto-tiny-kexecboot_3.10.bbappend
index 69179f3..a6a7741 100644
--- a/recipes-kernel/linux/linux-yocto-tiny-kexecboot_3.10.bbappend
+++ b/recipes-kernel/linux/linux-yocto-tiny-kexecboot_3.10.bbappend
@@ -1,8 +1,5 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-3.10:${THISDIR}/linux-yocto-3.10:${THISDIR}/files:"
-# re-expand the defconfig produced by 'make savedefconfig'
-KCONFIG_MODE = "--alldefconfig"
-
COMPATIBLE_MACHINE .= "|akita|c7x0|collie|poodle|spitz|tosa"
# Zaurus machines need kernel size-check.
@@ -10,8 +7,8 @@ KERNEL_IMAGE_MAXSIZE_akita = "1294336"
KERNEL_IMAGE_MAXSIZE_c7x0 = "1294336"
KERNEL_IMAGE_MAXSIZE_collie = "1048576"
KERNEL_IMAGE_MAXSIZE_poodle = "1294336"
-KERNEL_IMAGE_MAXSIZE_tosa = "1294336"
KERNEL_IMAGE_MAXSIZE_spitz = "1294336"
+KERNEL_IMAGE_MAXSIZE_tosa = "1294336"
KMACHINE_akita = "akita"
KMACHINE_c7x0 = "c7x0"
@@ -20,6 +17,15 @@ KMACHINE_poodle = "poodle"
KMACHINE_spitz = "spitz"
KMACHINE_tosa = "tosa"
+# Note: Providing "defconfig" we bypass the linux-yocto processing
+# re-expand the defconfig produced by "make_savedefconfig"
+KCONFIG_MODE_akita = "--alldefconfig"
+KCONFIG_MODE_c7x0 = "--alldefconfig"
+KCONFIG_MODE_collie = "--alldefconfig"
+KCONFIG_MODE_poodle = "--alldefconfig"
+KCONFIG_MODE_spitz = "--alldefconfig"
+KCONFIG_MODE_tosa = "--alldefconfig"
+
SRC_URI_append_akita = " \
file://defconfig \
file://patches/patches-pxa/sharpsl_param.patch \
diff --git a/recipes-kernel/linux/linux-yocto_3.10.bbappend b/recipes-kernel/linux/linux-yocto_3.10.bbappend
index c7f43ad..d4ad6b3 100644
--- a/recipes-kernel/linux/linux-yocto_3.10.bbappend
+++ b/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -23,6 +23,17 @@ KMACHINE_poodle = "poodle"
KMACHINE_spitz = "spitz"
KMACHINE_tosa = "tosa"
+# Note: Providing "defconfig" we bypass the linux-yocto processing
+# re-expand the defconfig produced by "make_savedefconfig"
+KCONFIG_MODE_akita = "--alldefconfig"
+KCONFIG_MODE_c7x0 = "--alldefconfig"
+KCONFIG_MODE_collie = "--alldefconfig"
+KCONFIG_MODE_h3600 = "--alldefconfig"
+KCONFIG_MODE_hx4700 = "--alldefconfig"
+KCONFIG_MODE_poodle = "--alldefconfig"
+KCONFIG_MODE_spitz = "--alldefconfig"
+KCONFIG_MODE_tosa = "--alldefconfig"
+
SRC_URI_append_akita = " \
file://feature-top.scc \
file://vga/logo_linux_clut224.ppm.bz2 \
diff --git a/recipes-kernel/linux/linux-yocto_3.14.bbappend b/recipes-kernel/linux/linux-yocto_3.14.bbappend
index 95d0a0e..335fe27 100644
--- a/recipes-kernel/linux/linux-yocto_3.14.bbappend
+++ b/recipes-kernel/linux/linux-yocto_3.14.bbappend
@@ -22,6 +22,15 @@ KMACHINE_spitz = "spitz"
KMACHINE_tosa = "tosa"
# Note: Providing "defconfig" we bypass the linux-yocto processing
+# re-expand the defconfig produced by "make_savedefconfig"
+KCONFIG_MODE_akita = "--alldefconfig"
+KCONFIG_MODE_c7x0 = "--alldefconfig"
+KCONFIG_MODE_collie = "--alldefconfig"
+KCONFIG_MODE_h3600 = "--alldefconfig"
+KCONFIG_MODE_hx4700 = "--alldefconfig"
+KCONFIG_MODE_poodle = "--alldefconfig"
+KCONFIG_MODE_spitz = "--alldefconfig"
+KCONFIG_MODE_tosa = "--alldefconfig"
SRC_URI_append_akita = " \
file://defconfig \