aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2014-01-17 17:45:52 +0100
committerAndrea Adami <andrea.adami@gmail.com>2014-01-22 00:42:47 +0100
commit10c89598f68e2f6980065d51982d3eb33d420d65 (patch)
tree50e1fb8d5d4c8a06033a0870bfce941632a6a320
parent066a4d4da6e2a2b6398b96e2144215d36f686104 (diff)
downloadmeta-handheld-10c89598f68e2f6980065d51982d3eb33d420d65.tar.gz
linux-yocto*: collie: re-enable buffered write for NOR flash
After debugging we have a patch solving the issue. It appears these chips need the start address for the buffer write program. Revert af54b196e7d6ced6d308fc84c2d03a98ed2e5bfd Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
-rw-r--r--recipes-kernel/linux/linux-yocto-3.10/collie/collie.scc1
-rw-r--r--recipes-kernel/linux/linux-yocto-3.10/patches/patches-mtd/collie-no-buf-write.patch31
-rw-r--r--recipes-kernel/linux/linux-yocto-dev/collie/collie.scc1
-rw-r--r--recipes-kernel/linux/linux-yocto-dev/patches/patches-mtd/collie-no-buf-write.patch31
-rw-r--r--recipes-kernel/linux/linux-yocto-tiny-kexecboot-3.10/patches/patches-mtd/collie-no-buf-write.patch31
-rw-r--r--recipes-kernel/linux/linux-yocto-tiny-kexecboot_3.10.bbappend1
6 files changed, 0 insertions, 96 deletions
diff --git a/recipes-kernel/linux/linux-yocto-3.10/collie/collie.scc b/recipes-kernel/linux/linux-yocto-3.10/collie/collie.scc
index 4699a58..8d3e8be 100644
--- a/recipes-kernel/linux/linux-yocto-3.10/collie/collie.scc
+++ b/recipes-kernel/linux/linux-yocto-3.10/collie/collie.scc
@@ -15,7 +15,6 @@ patch ../patches/patches-mtd/collie-force-unlock.patch
patch ../patches/patches-mtd/collie-PCR.patch
patch ../patches/patches-mtd/collie-match-cfi-qry.patch
patch ../patches/patches-mtd/collie-cfi-partitions.patch
-patch ../patches/patches-mtd/collie-no-buf-write.patch
patch ../patches/patches-sa1100/collie-irda.patch
patch ../patches/patches-sa1100/collie-add-bootblock.patch
patch ../patches/patches-sa1100/arm-sa1100-add-cpu-clock.patch
diff --git a/recipes-kernel/linux/linux-yocto-3.10/patches/patches-mtd/collie-no-buf-write.patch b/recipes-kernel/linux/linux-yocto-3.10/patches/patches-mtd/collie-no-buf-write.patch
deleted file mode 100644
index 02f06c3..0000000
--- a/recipes-kernel/linux/linux-yocto-3.10/patches/patches-mtd/collie-no-buf-write.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 5f535adb0a2cd914eb1d6ef5fd2a703b9886bec0 Mon Sep 17 00:00:00 2001
-From: Andrea Adami <andrea.adami@gmail.com>
-Date: Sun, 15 Dec 2013 16:53:27 +0100
-Subject: [PATCH] MTD: HACK - disable CFI buffered write
-
-Something bad (timeout ?) is happening and the fs is corrupted
-on remount/reboot.
-
-Going back to word write offers a stable base for further debugging.
-
-Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
----
- drivers/mtd/chips/cfi_cmdset_0001.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/drivers/mtd/chips/cfi_cmdset_0001.c b/drivers/mtd/chips/cfi_cmdset_0001.c
-index d9d6f0e..a5c984a 100644
---- a/drivers/mtd/chips/cfi_cmdset_0001.c
-+++ b/drivers/mtd/chips/cfi_cmdset_0001.c
-@@ -40,7 +40,7 @@
- /* #define CMDSET0001_DISABLE_WRITE_SUSPEND */
-
- // debugging, turns off buffer write mode if set to 1
--#define FORCE_WORD_WRITE 0
-+#define FORCE_WORD_WRITE 1
-
- /* Intel chips */
- #define I82802AB 0x00ad
---
-1.8.1.5
-
diff --git a/recipes-kernel/linux/linux-yocto-dev/collie/collie.scc b/recipes-kernel/linux/linux-yocto-dev/collie/collie.scc
index 2351c08..328c062 100644
--- a/recipes-kernel/linux/linux-yocto-dev/collie/collie.scc
+++ b/recipes-kernel/linux/linux-yocto-dev/collie/collie.scc
@@ -9,7 +9,6 @@ patch ../patches/patches-mtd/collie-force-unlock.patch
patch ../patches/patches-mtd/collie-PCR.patch
patch ../patches/patches-mtd/collie-match-cfi-qry.patch
patch ../patches/patches-mtd/collie-cfi-partitions.patch
-patch ../patches/patches-mtd/collie-no-buf-write.patch
patch ../patches/patches-sa1100/collie-irda.patch
patch ../patches/patches-sa1100/collie-add-bootblock.patch
patch ../patches/patches-sa1100/arm-sa1100-add-cpu-clock.patch
diff --git a/recipes-kernel/linux/linux-yocto-dev/patches/patches-mtd/collie-no-buf-write.patch b/recipes-kernel/linux/linux-yocto-dev/patches/patches-mtd/collie-no-buf-write.patch
deleted file mode 100644
index 02f06c3..0000000
--- a/recipes-kernel/linux/linux-yocto-dev/patches/patches-mtd/collie-no-buf-write.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 5f535adb0a2cd914eb1d6ef5fd2a703b9886bec0 Mon Sep 17 00:00:00 2001
-From: Andrea Adami <andrea.adami@gmail.com>
-Date: Sun, 15 Dec 2013 16:53:27 +0100
-Subject: [PATCH] MTD: HACK - disable CFI buffered write
-
-Something bad (timeout ?) is happening and the fs is corrupted
-on remount/reboot.
-
-Going back to word write offers a stable base for further debugging.
-
-Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
----
- drivers/mtd/chips/cfi_cmdset_0001.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/drivers/mtd/chips/cfi_cmdset_0001.c b/drivers/mtd/chips/cfi_cmdset_0001.c
-index d9d6f0e..a5c984a 100644
---- a/drivers/mtd/chips/cfi_cmdset_0001.c
-+++ b/drivers/mtd/chips/cfi_cmdset_0001.c
-@@ -40,7 +40,7 @@
- /* #define CMDSET0001_DISABLE_WRITE_SUSPEND */
-
- // debugging, turns off buffer write mode if set to 1
--#define FORCE_WORD_WRITE 0
-+#define FORCE_WORD_WRITE 1
-
- /* Intel chips */
- #define I82802AB 0x00ad
---
-1.8.1.5
-
diff --git a/recipes-kernel/linux/linux-yocto-tiny-kexecboot-3.10/patches/patches-mtd/collie-no-buf-write.patch b/recipes-kernel/linux/linux-yocto-tiny-kexecboot-3.10/patches/patches-mtd/collie-no-buf-write.patch
deleted file mode 100644
index 02f06c3..0000000
--- a/recipes-kernel/linux/linux-yocto-tiny-kexecboot-3.10/patches/patches-mtd/collie-no-buf-write.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 5f535adb0a2cd914eb1d6ef5fd2a703b9886bec0 Mon Sep 17 00:00:00 2001
-From: Andrea Adami <andrea.adami@gmail.com>
-Date: Sun, 15 Dec 2013 16:53:27 +0100
-Subject: [PATCH] MTD: HACK - disable CFI buffered write
-
-Something bad (timeout ?) is happening and the fs is corrupted
-on remount/reboot.
-
-Going back to word write offers a stable base for further debugging.
-
-Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
----
- drivers/mtd/chips/cfi_cmdset_0001.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/drivers/mtd/chips/cfi_cmdset_0001.c b/drivers/mtd/chips/cfi_cmdset_0001.c
-index d9d6f0e..a5c984a 100644
---- a/drivers/mtd/chips/cfi_cmdset_0001.c
-+++ b/drivers/mtd/chips/cfi_cmdset_0001.c
-@@ -40,7 +40,7 @@
- /* #define CMDSET0001_DISABLE_WRITE_SUSPEND */
-
- // debugging, turns off buffer write mode if set to 1
--#define FORCE_WORD_WRITE 0
-+#define FORCE_WORD_WRITE 1
-
- /* Intel chips */
- #define I82802AB 0x00ad
---
-1.8.1.5
-
diff --git a/recipes-kernel/linux/linux-yocto-tiny-kexecboot_3.10.bbappend b/recipes-kernel/linux/linux-yocto-tiny-kexecboot_3.10.bbappend
index c6e239c..f6a7fc9 100644
--- a/recipes-kernel/linux/linux-yocto-tiny-kexecboot_3.10.bbappend
+++ b/recipes-kernel/linux/linux-yocto-tiny-kexecboot_3.10.bbappend
@@ -48,7 +48,6 @@ SRC_URI_append_collie = " \
file://patches/patches-mtd/collie-PCR.patch \
file://patches/patches-mtd/collie-match-cfi-qry.patch \
file://patches/patches-mtd/collie-cfi-partitions.patch \
- file://patches/patches-mtd/collie-no-buf-write.patch \
file://patches/patches-sa1100/collie-irda.patch \
file://patches/patches-sa1100/collie-add-bootblock.patch \
file://patches/patches-sa1100/arm-sa1100-add-cpu-clock.patch \