aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2012-04-01 01:43:44 +0200
committerPaul Eggleton <paul.eggleton@linux.intel.com>2012-04-02 12:08:12 +0100
commitf193531fcbcc9572a44c555b397bf7b791cd88a2 (patch)
treeebaa9db7579055f587527e3e59f40b8fc17ba02e
parent1cbe2f0aa8e051f256792701da1bb8ca0fbbfac9 (diff)
downloadmeta-handheld-f193531fcbcc9572a44c555b397bf7b791cd88a2.tar.gz
udev: generalize the check in touchscreen rule
* The rule only works for devices reporting ts pressure * and ignores the other touchscreens (happens e.g. on ipaq h1940). * a0,1,*18 a = absolute axes (ABS_X 0x00 ABS_Y 0x01 ABS_PRESSURE 0x18) * (see include/linux/input.h) * * Guidelines for touchscreen suggest only ABS_X and ABS_Y are mandatory * (http://kernel.org/doc/Documentation/input/event-codes.txt) * * Side-effect of the patch is to remove a dependency on meta-oe * but using older udev from oe-core. Signed-off-by: Andrea Adami <andrea.adami@gmail.com> Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
-rw-r--r--recipes-core/udev/udev/local.rules (renamed from recipes-core/udev/udev/touchscreen.rules)21
-rw-r--r--recipes-core/udev/udev_164.bbappend (renamed from recipes-core/udev/udev_173.bbappend)0
2 files changed, 17 insertions, 4 deletions
diff --git a/recipes-core/udev/udev/touchscreen.rules b/recipes-core/udev/udev/local.rules
index b2307cf..49e8d28 100644
--- a/recipes-core/udev/udev/touchscreen.rules
+++ b/recipes-core/udev/udev/local.rules
@@ -13,9 +13,22 @@
# %% the '%' char itself
#
+# Media automounting
+SUBSYSTEM=="block", ACTION=="add" RUN+="/etc/udev/scripts/mount.sh"
+SUBSYSTEM=="block", ACTION=="remove" RUN+="/etc/udev/scripts/mount.sh"
+
+# Handle network interface setup
+SUBSYSTEM=="net", ACTION=="add" RUN+="/etc/udev/scripts/network.sh"
+SUBSYSTEM=="net", ACTION=="remove" RUN+="/etc/udev/scripts/network.sh"
+
+# The first framebuffer is symlinked to /dev/fb
+KERNEL=="fb0", SYMLINK+="fb"
+
+# The first rtc device is symlinked to /dev/rtc
+KERNEL=="rtc0", SYMLINK+="rtc"
+
+# Try and modprobe for drivers for new hardware
+ACTION=="add", DEVPATH=="/devices/*", ENV{MODALIAS}=="?*", RUN+="/sbin/modprobe $env{MODALIAS}"
+
# Create a symlink to any touchscreen input device
-SUBSYSTEM=="input", KERNEL=="event[0-9]*", ATTRS{modalias}=="input:*-e0*,3,*a0,1,*18,*", SYMLINK+="input/touchscreen0"
-SUBSYSTEM=="input", KERNEL=="event[0-9]*", ATTRS{modalias}=="ads7846", SYMLINK+="input/touchscreen0"
-# This one is necessary for h1940
SUBSYSTEM=="input", KERNEL=="event[0-9]*", ATTRS{modalias}=="input:*-e0*,3,*a0,1,*", SYMLINK+="input/touchscreen0"
-
diff --git a/recipes-core/udev/udev_173.bbappend b/recipes-core/udev/udev_164.bbappend
index 446ea84..446ea84 100644
--- a/recipes-core/udev/udev_173.bbappend
+++ b/recipes-core/udev/udev_164.bbappend