aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2012-04-02 21:29:40 +0000
committerPaul Eggleton <paul.eggleton@linux.intel.com>2012-04-09 22:26:00 +0100
commitcf760550558b2a23a4bd362f7daceaca64772615 (patch)
tree5015e39d14170443efb82344dcf84269c1287323
parent3d3284fc9181293ad38877ebb2f1c5bf37976e1f (diff)
downloadmeta-handheld-cf760550558b2a23a4bd362f7daceaca64772615.tar.gz
udev: better mangling of oe-core local.rules
* do not keep a copy of local.rules * bump PR * (this patch will be superfluous if/when accepted by oe-core) Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
-rw-r--r--recipes-core/udev/udev/local.rules34
-rw-r--r--recipes-core/udev/udev_164.bbappend6
2 files changed, 5 insertions, 35 deletions
diff --git a/recipes-core/udev/udev/local.rules b/recipes-core/udev/udev/local.rules
deleted file mode 100644
index 49e8d28..0000000
--- a/recipes-core/udev/udev/local.rules
+++ /dev/null
@@ -1,34 +0,0 @@
-# There are a number of modifiers that are allowed to be used in some
-# of the different fields. They provide the following subsitutions:
-#
-# %n the "kernel number" of the device.
-# For example, 'sda3' has a "kernel number" of '3'
-# %e the smallest number for that name which does not matches an existing node
-# %k the kernel name for the device
-# %M the kernel major number for the device
-# %m the kernel minor number for the device
-# %b the bus id for the device
-# %c the string returned by the PROGRAM
-# %s{filename} the content of a sysfs attribute
-# %% the '%' char itself
-#
-
-# Media automounting
-SUBSYSTEM=="block", ACTION=="add" RUN+="/etc/udev/scripts/mount.sh"
-SUBSYSTEM=="block", ACTION=="remove" RUN+="/etc/udev/scripts/mount.sh"
-
-# Handle network interface setup
-SUBSYSTEM=="net", ACTION=="add" RUN+="/etc/udev/scripts/network.sh"
-SUBSYSTEM=="net", ACTION=="remove" RUN+="/etc/udev/scripts/network.sh"
-
-# The first framebuffer is symlinked to /dev/fb
-KERNEL=="fb0", SYMLINK+="fb"
-
-# The first rtc device is symlinked to /dev/rtc
-KERNEL=="rtc0", SYMLINK+="rtc"
-
-# Try and modprobe for drivers for new hardware
-ACTION=="add", DEVPATH=="/devices/*", ENV{MODALIAS}=="?*", RUN+="/sbin/modprobe $env{MODALIAS}"
-
-# Create a symlink to any touchscreen input device
-SUBSYSTEM=="input", KERNEL=="event[0-9]*", ATTRS{modalias}=="input:*-e0*,3,*a0,1,*", SYMLINK+="input/touchscreen0"
diff --git a/recipes-core/udev/udev_164.bbappend b/recipes-core/udev/udev_164.bbappend
index 446ea84..4d263b0 100644
--- a/recipes-core/udev/udev_164.bbappend
+++ b/recipes-core/udev/udev_164.bbappend
@@ -1,5 +1,9 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-PRINC := "${@int(PRINC) + 1}"
+PRINC := "${@int(PRINC) + 2}"
+# check only for ABS_X (0x00) and ABS_Y (0x01), ignore ABS_PRESSURE (0x18)
+do_configure_append () {
+ sed -i -e 's/"input:*-e0*,3,*a0,1,*18,*"/"input:*-e0*,3,*a0,1,*"/' ${WORKDIR}/local.rules
+}