aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2012-04-09 22:05:34 +0000
committerPaul Eggleton <paul.eggleton@linux.intel.com>2012-04-09 23:30:31 +0100
commit770a14fa7cad8622a30271cf950bd490de0411bd (patch)
tree0c49f6b46732b17a915298a8a9b71217ae68497f
parent0e7a4582a5a107adfe34db445c1506e796b9edbc (diff)
downloadmeta-handheld-770a14fa7cad8622a30271cf950bd490de0411bd.tar.gz
linux(-kexecboot)_3.1: add CC_OPTIMIZE_FOR_SIZE=y
* to Zaurus kernels * bump PR Signed-off-by: Andrea Adami <andrea.adami@gmail.com> Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
-rw-r--r--recipes-kernel/linux/linux-3.1/akita/defconfig1
-rw-r--r--recipes-kernel/linux/linux-3.1/c7x0/defconfig1
-rw-r--r--recipes-kernel/linux/linux-3.1/collie/defconfig1
-rw-r--r--recipes-kernel/linux/linux-3.1/poodle/defconfig1
-rw-r--r--recipes-kernel/linux/linux-3.1/spitz/defconfig1
-rw-r--r--recipes-kernel/linux/linux-3.1/tosa/defconfig1
-rw-r--r--recipes-kernel/linux/linux-kexecboot-3.1/akita/defconfig1
-rw-r--r--recipes-kernel/linux/linux-kexecboot-3.1/c7x0/defconfig1
-rw-r--r--recipes-kernel/linux/linux-kexecboot-3.1/collie/defconfig1
-rw-r--r--recipes-kernel/linux/linux-kexecboot-3.1/poodle/defconfig1
-rw-r--r--recipes-kernel/linux/linux-kexecboot-3.1/spitz/defconfig1
-rw-r--r--recipes-kernel/linux/linux-kexecboot-3.1/tosa/defconfig1
-rw-r--r--recipes-kernel/linux/linux-kexecboot_3.1.bbappend1
-rw-r--r--recipes-kernel/linux/linux_3.1.bb2
14 files changed, 14 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-3.1/akita/defconfig b/recipes-kernel/linux/linux-3.1/akita/defconfig
index 3dc0ee3..0f08d40 100644
--- a/recipes-kernel/linux/linux-3.1/akita/defconfig
+++ b/recipes-kernel/linux/linux-3.1/akita/defconfig
@@ -11,6 +11,7 @@ CONFIG_BLK_DEV_INITRD=y
CONFIG_RD_BZIP2=y
CONFIG_RD_LZMA=y
CONFIG_RD_LZO=y
+CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_EMBEDDED=y
CONFIG_SLOB=y
CONFIG_PROFILING=y
diff --git a/recipes-kernel/linux/linux-3.1/c7x0/defconfig b/recipes-kernel/linux/linux-3.1/c7x0/defconfig
index 025008b..1889e09 100644
--- a/recipes-kernel/linux/linux-3.1/c7x0/defconfig
+++ b/recipes-kernel/linux/linux-3.1/c7x0/defconfig
@@ -11,6 +11,7 @@ CONFIG_BLK_DEV_INITRD=y
CONFIG_RD_BZIP2=y
CONFIG_RD_LZMA=y
CONFIG_RD_LZO=y
+CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_EMBEDDED=y
CONFIG_SLOB=y
CONFIG_PROFILING=y
diff --git a/recipes-kernel/linux/linux-3.1/collie/defconfig b/recipes-kernel/linux/linux-3.1/collie/defconfig
index 679532b..1af2dc8 100644
--- a/recipes-kernel/linux/linux-3.1/collie/defconfig
+++ b/recipes-kernel/linux/linux-3.1/collie/defconfig
@@ -12,6 +12,7 @@ CONFIG_BLK_DEV_INITRD=y
CONFIG_RD_BZIP2=y
CONFIG_RD_LZMA=y
CONFIG_RD_LZO=y
+CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_EMBEDDED=y
CONFIG_SLOB=y
CONFIG_PROFILING=y
diff --git a/recipes-kernel/linux/linux-3.1/poodle/defconfig b/recipes-kernel/linux/linux-3.1/poodle/defconfig
index 0124824..5419365 100644
--- a/recipes-kernel/linux/linux-3.1/poodle/defconfig
+++ b/recipes-kernel/linux/linux-3.1/poodle/defconfig
@@ -11,6 +11,7 @@ CONFIG_BLK_DEV_INITRD=y
CONFIG_RD_BZIP2=y
CONFIG_RD_LZMA=y
CONFIG_RD_LZO=y
+CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_EMBEDDED=y
CONFIG_SLOB=y
CONFIG_PROFILING=y
diff --git a/recipes-kernel/linux/linux-3.1/spitz/defconfig b/recipes-kernel/linux/linux-3.1/spitz/defconfig
index dfab582..4b8d8bc 100644
--- a/recipes-kernel/linux/linux-3.1/spitz/defconfig
+++ b/recipes-kernel/linux/linux-3.1/spitz/defconfig
@@ -11,6 +11,7 @@ CONFIG_BLK_DEV_INITRD=y
CONFIG_RD_BZIP2=y
CONFIG_RD_LZMA=y
CONFIG_RD_LZO=y
+CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_EMBEDDED=y
CONFIG_SLOB=y
CONFIG_PROFILING=y
diff --git a/recipes-kernel/linux/linux-3.1/tosa/defconfig b/recipes-kernel/linux/linux-3.1/tosa/defconfig
index 187bab2..9056e6d 100644
--- a/recipes-kernel/linux/linux-3.1/tosa/defconfig
+++ b/recipes-kernel/linux/linux-3.1/tosa/defconfig
@@ -11,6 +11,7 @@ CONFIG_BLK_DEV_INITRD=y
CONFIG_RD_BZIP2=y
CONFIG_RD_LZMA=y
CONFIG_RD_LZO=y
+CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_EMBEDDED=y
CONFIG_SLOB=y
CONFIG_PROFILING=y
diff --git a/recipes-kernel/linux/linux-kexecboot-3.1/akita/defconfig b/recipes-kernel/linux/linux-kexecboot-3.1/akita/defconfig
index 32530a3..c0f03b3 100644
--- a/recipes-kernel/linux/linux-kexecboot-3.1/akita/defconfig
+++ b/recipes-kernel/linux/linux-kexecboot-3.1/akita/defconfig
@@ -6,6 +6,7 @@ CONFIG_LOG_BUF_SHIFT=14
CONFIG_BLK_DEV_INITRD=y
CONFIG_INITRAMFS_SOURCE="initramfs.cpio.lzma"
CONFIG_RD_LZMA=y
+CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_INITRAMFS_COMPRESSION_LZMA=y
# CONFIG_UID16 is not set
# CONFIG_SYSCTL_SYSCALL is not set
diff --git a/recipes-kernel/linux/linux-kexecboot-3.1/c7x0/defconfig b/recipes-kernel/linux/linux-kexecboot-3.1/c7x0/defconfig
index b08e27e..58132cb 100644
--- a/recipes-kernel/linux/linux-kexecboot-3.1/c7x0/defconfig
+++ b/recipes-kernel/linux/linux-kexecboot-3.1/c7x0/defconfig
@@ -6,6 +6,7 @@ CONFIG_LOG_BUF_SHIFT=14
CONFIG_BLK_DEV_INITRD=y
CONFIG_INITRAMFS_SOURCE="initramfs.cpio.lzma"
CONFIG_RD_LZMA=y
+CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_INITRAMFS_COMPRESSION_LZMA=y
# CONFIG_UID16 is not set
# CONFIG_SYSCTL_SYSCALL is not set
diff --git a/recipes-kernel/linux/linux-kexecboot-3.1/collie/defconfig b/recipes-kernel/linux/linux-kexecboot-3.1/collie/defconfig
index ce1299d..7f371ff 100644
--- a/recipes-kernel/linux/linux-kexecboot-3.1/collie/defconfig
+++ b/recipes-kernel/linux/linux-kexecboot-3.1/collie/defconfig
@@ -6,6 +6,7 @@ CONFIG_LOG_BUF_SHIFT=14
CONFIG_BLK_DEV_INITRD=y
CONFIG_INITRAMFS_SOURCE="initramfs.cpio.lzma"
CONFIG_RD_LZMA=y
+CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_INITRAMFS_COMPRESSION_LZMA=y
# CONFIG_UID16 is not set
# CONFIG_SYSCTL_SYSCALL is not set
diff --git a/recipes-kernel/linux/linux-kexecboot-3.1/poodle/defconfig b/recipes-kernel/linux/linux-kexecboot-3.1/poodle/defconfig
index 68c37e6..e6e9481 100644
--- a/recipes-kernel/linux/linux-kexecboot-3.1/poodle/defconfig
+++ b/recipes-kernel/linux/linux-kexecboot-3.1/poodle/defconfig
@@ -6,6 +6,7 @@ CONFIG_LOG_BUF_SHIFT=14
CONFIG_BLK_DEV_INITRD=y
CONFIG_INITRAMFS_SOURCE="initramfs.cpio.lzma"
CONFIG_RD_LZMA=y
+CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_INITRAMFS_COMPRESSION_LZMA=y
# CONFIG_UID16 is not set
# CONFIG_SYSCTL_SYSCALL is not set
diff --git a/recipes-kernel/linux/linux-kexecboot-3.1/spitz/defconfig b/recipes-kernel/linux/linux-kexecboot-3.1/spitz/defconfig
index b066839..098042d 100644
--- a/recipes-kernel/linux/linux-kexecboot-3.1/spitz/defconfig
+++ b/recipes-kernel/linux/linux-kexecboot-3.1/spitz/defconfig
@@ -6,6 +6,7 @@ CONFIG_LOG_BUF_SHIFT=14
CONFIG_BLK_DEV_INITRD=y
CONFIG_INITRAMFS_SOURCE="initramfs.cpio.lzma"
CONFIG_RD_LZMA=y
+CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_INITRAMFS_COMPRESSION_LZMA=y
# CONFIG_UID16 is not set
# CONFIG_SYSCTL_SYSCALL is not set
diff --git a/recipes-kernel/linux/linux-kexecboot-3.1/tosa/defconfig b/recipes-kernel/linux/linux-kexecboot-3.1/tosa/defconfig
index 59cf640..8109ecd 100644
--- a/recipes-kernel/linux/linux-kexecboot-3.1/tosa/defconfig
+++ b/recipes-kernel/linux/linux-kexecboot-3.1/tosa/defconfig
@@ -6,6 +6,7 @@ CONFIG_LOG_BUF_SHIFT=14
CONFIG_BLK_DEV_INITRD=y
CONFIG_INITRAMFS_SOURCE="initramfs.cpio.lzma"
CONFIG_RD_LZMA=y
+CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_INITRAMFS_COMPRESSION_LZMA=y
# CONFIG_UID16 is not set
# CONFIG_SYSCTL_SYSCALL is not set
diff --git a/recipes-kernel/linux/linux-kexecboot_3.1.bbappend b/recipes-kernel/linux/linux-kexecboot_3.1.bbappend
index 74d63bb..d4911b6 100644
--- a/recipes-kernel/linux/linux-kexecboot_3.1.bbappend
+++ b/recipes-kernel/linux/linux-kexecboot_3.1.bbappend
@@ -1,5 +1,6 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/linux-kexecboot-${PV}:${THISDIR}/files:"
+PR = "${INC_PR}.1"
COMPATIBLE_MACHINE = "(akita|c7x0|collie|poodle|tosa|spitz)"
# Note we set loglevel=3 and master console on serial to protect bootlogo.
diff --git a/recipes-kernel/linux/linux_3.1.bb b/recipes-kernel/linux/linux_3.1.bb
index 5e9a714..40487d1 100644
--- a/recipes-kernel/linux/linux_3.1.bb
+++ b/recipes-kernel/linux/linux_3.1.bb
@@ -1,6 +1,6 @@
require linux.inc
-PR = "${INC_PR}.9"
+PR = "${INC_PR}.10"
COMPATIBLE_MACHINE = "(akita|c7x0|collie|poodle|tosa|spitz|h1940)"
SRC_URI += "${KERNELORG_MIRROR}/linux/kernel/v3.x/linux-${PV}.tar.bz2;name=kernel \