aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2012-04-09 22:05:36 +0000
committerPaul Eggleton <paul.eggleton@linux.intel.com>2012-04-09 23:30:39 +0100
commit1f05a15aceb4c3a19fa070463b58125b5658b2a9 (patch)
tree472c70490371fa4f0244f0c4a26b3279ad6967d0
parentb8cf27ca877d0574637fe2849f693e6229488757 (diff)
downloadmeta-handheld-1f05a15aceb4c3a19fa070463b58125b5658b2a9.tar.gz
linux(-kexecboot)_git: add CC_OPTIMIZE_FOR_SIZE=y
* to spitz kernel * bump PR Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
-rw-r--r--recipes-kernel/linux/linux-kexecboot/spitz/defconfig1
-rw-r--r--recipes-kernel/linux/linux-kexecboot_git.bbappend2
-rw-r--r--recipes-kernel/linux/linux/spitz/defconfig1
-rw-r--r--recipes-kernel/linux/linux_git.bb2
4 files changed, 5 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-kexecboot/spitz/defconfig b/recipes-kernel/linux/linux-kexecboot/spitz/defconfig
index c64f831..60960d7 100644
--- a/recipes-kernel/linux/linux-kexecboot/spitz/defconfig
+++ b/recipes-kernel/linux/linux-kexecboot/spitz/defconfig
@@ -11,6 +11,7 @@ CONFIG_INITRAMFS_COMPRESSION_LZMA=y
# CONFIG_KALLSYMS is not set
# CONFIG_ELF_CORE is not set
# CONFIG_BASE_FULL is not set
+CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_EMBEDDED=y
# CONFIG_VM_EVENT_COUNTERS is not set
# CONFIG_COMPAT_BRK is not set
diff --git a/recipes-kernel/linux/linux-kexecboot_git.bbappend b/recipes-kernel/linux/linux-kexecboot_git.bbappend
index 1acab8a..49dd75f 100644
--- a/recipes-kernel/linux/linux-kexecboot_git.bbappend
+++ b/recipes-kernel/linux/linux-kexecboot_git.bbappend
@@ -1,6 +1,8 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/linux-kexecboot-${PV}:${THISDIR}/files:"
DEFAULT_PREFERENCE = "-2"
+
+PR = "${INC_PR}.1"
#COMPATIBLE_MACHINE = "(akita|c7x0|collie|poodle|tosa|spitz)"
COMPATIBLE_MACHINE = "(spitz)"
diff --git a/recipes-kernel/linux/linux/spitz/defconfig b/recipes-kernel/linux/linux/spitz/defconfig
index 4370819..fb5eaee 100644
--- a/recipes-kernel/linux/linux/spitz/defconfig
+++ b/recipes-kernel/linux/linux/spitz/defconfig
@@ -17,6 +17,7 @@ CONFIG_BLK_DEV_INITRD=y
CONFIG_RD_BZIP2=y
CONFIG_RD_LZMA=y
CONFIG_RD_LZO=y
+CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_EMBEDDED=y
CONFIG_SLOB=y
CONFIG_PROFILING=y
diff --git a/recipes-kernel/linux/linux_git.bb b/recipes-kernel/linux/linux_git.bb
index 222df31..2897d19 100644
--- a/recipes-kernel/linux/linux_git.bb
+++ b/recipes-kernel/linux/linux_git.bb
@@ -1,6 +1,6 @@
require linux.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
COMPATIBLE_MACHINE = "spitz"
DEFAULT_PREFERENCE = "-2"