aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-08-11 09:31:09 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-08-11 09:33:27 +0200
commit8d5d9701a13371da6718b09290d03773189ed865 (patch)
treee6287c660096e0e94fe4e83d439e59c61cd7e9a5
parenta4c72e350c199adbd02fc526c5ca07ff44976749 (diff)
downloadopenembedded-8d5d9701a13371da6718b09290d03773189ed865.tar.gz
xfsprogs: stage dev headers, used later by xfsdump
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes/xfsprogs/xfsprogs_3.1.2.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes/xfsprogs/xfsprogs_3.1.2.bb b/recipes/xfsprogs/xfsprogs_3.1.2.bb
index 736d458ec5..832d5ab727 100644
--- a/recipes/xfsprogs/xfsprogs_3.1.2.bb
+++ b/recipes/xfsprogs/xfsprogs_3.1.2.bb
@@ -3,6 +3,7 @@ HOMEPAGE = "http://oss.sgi.com/projects/xfs"
LICENSE = "GPL"
SECTION = "base"
DEPENDS = "util-linux-ng"
+PR = "r1"
SRC_URI = "ftp://oss.sgi.com/projects/xfs/cmd_tars/${P}.tar.gz"
SRC_URI[md5sum] = "86d10178ee6897cb099c97303e6d9da0"
@@ -13,6 +14,8 @@ inherit autotools
EXTRA_OECONF = "--enable-gettext=no"
TARGET_CC_ARCH += "${LDFLAGS}"
+FILES_${PN}-dev += "${base_libdir}/libhandle.la \
+ ${base_libdir}/libhandle.so"
do_configure () {
export LIBTOOL="${STAGING_BINDIR_NATIVE}/${HOST_SYS}-libtool"
@@ -23,5 +26,16 @@ do_configure () {
do_install () {
export DIST_ROOT=${D}
oe_runmake install
+ # needed for xfsdump
+ oe_runmake install-dev
+ # replace extra links to /usr/lib with relative links (otherwise autotools_prepackage_lamangler fails to read nonexistent link)
+ rm -f ${D}/${base_libdir}/libhandle.la
+ rm -f ${D}/${base_libdir}/libhandle.a
+ ln -s ../usr/lib/libhandle.la ${D}/${base_libdir}/libhandle.la
+ ln -s ../usr/lib/libhandle.a ${D}/${base_libdir}/libhandle.a
+
+ # and link from /usr/lib/libhandle.so to /lib/libhandle.so
+ rm -f ${D}/${libdir}/libhandle.so
+ ln -s ../../lib/libhandle.a ${D}/${libdir}/libhandle.so
}