aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-08-22 20:09:21 -0700
committerKhem Raj <raj.khem@gmail.com>2010-08-23 08:12:08 -0700
commit231757d9f3e9aa4c57c3afd2d4b86860d805e5b0 (patch)
tree243ab72311e0d776d9181e4e2d23071bd851ed22
parentde2e9637017afd18a895140ac85bb98cf1aef3e2 (diff)
downloadopenembedded-231757d9f3e9aa4c57c3afd2d4b86860d805e5b0.tar.gz
u-boot-efikamx_1.1.8.bb: Efika MX bootloader
Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
-rw-r--r--recipes/u-boot/u-boot-efikamx_1.1.8.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/u-boot/u-boot-efikamx_1.1.8.bb b/recipes/u-boot/u-boot-efikamx_1.1.8.bb
new file mode 100644
index 0000000000..2094bf7e13
--- /dev/null
+++ b/recipes/u-boot/u-boot-efikamx_1.1.8.bb
@@ -0,0 +1,25 @@
+require u-boot.inc
+PR ="r0"
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "http://www.powerdeveloper.org/asset/by-id/89;name=uboot-efikamx \
+ "
+SRC_URI[uboot-efikamx.md5sum] = "072fbd97b293ac96d3f166e261c56131"
+SRC_URI[uboot-efikamx.sha256sum] = "ee813d15e0e699340e5099641e01ac2952d42329d168deb48692a22a66d48965"
+
+S = "${WORKDIR}/uboot-efikamx-${PV}"
+
+python do_fetch () {
+ import os,shutil
+ bb.build.exec_func("base_do_fetch", d)
+ if os.access(bb.data.expand("${DL_DIR}/89", d), os.R_OK):
+ shutil.copy(bb.data.expand("${DL_DIR}/89", d), bb.data.expand("${DL_DIR}/${PN}-${PV}.tar.lzma", d))
+}
+
+python do_unpack () {
+ bb.build.exec_func('efikamx_uboot_do_unpack', d)
+}
+
+efikamx_uboot_do_unpack (){
+ (cd ${WORKDIR}; tar xf ${DL_DIR}/${PN}-${PV}.tar.lzma)
+}