aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-08-11 09:31:24 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-08-11 09:33:27 +0200
commit1816ba36398c620c6c57edc5a623bf775fd1a558 (patch)
tree3d40250be8a90a9087dde556e4a7712ea284c844
parent8d5d9701a13371da6718b09290d03773189ed865 (diff)
downloadopenembedded-1816ba36398c620c6c57edc5a623bf775fd1a558.tar.gz
xfsdump: add recipe
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes/xfsprogs/xfsdump_3.0.4.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/xfsprogs/xfsdump_3.0.4.bb b/recipes/xfsprogs/xfsdump_3.0.4.bb
new file mode 100644
index 0000000000..da6381646b
--- /dev/null
+++ b/recipes/xfsprogs/xfsdump_3.0.4.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "XFS Filesystem Dump Utility"
+HOMEPAGE = "http://oss.sgi.com/projects/xfs"
+LICENSE = "GPL"
+SECTION = "base"
+DEPENDS = "util-linux-ng"
+
+SRC_URI = "ftp://oss.sgi.com/projects/xfs/cmd_tars/${P}.tar.gz"
+SRC_URI[md5sum] = "af6932cfcd95ce64dc583128a190ffd7"
+SRC_URI[sha256sum] = "d3932f0d482f6f77ec8519ce24c00edbe006262751bfb4ad4b4bc3e219d807d1"
+
+PARALLEL_MAKE = ""
+inherit autotools
+EXTRA_OECONF = "--enable-gettext=no"
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+
+do_configure () {
+ export LIBTOOL="${STAGING_BINDIR_NATIVE}/${HOST_SYS}-libtool"
+ export DEBUG="-DNDEBUG"
+ oe_runconf
+}
+
+do_install () {
+ export DIST_ROOT=${D}
+ oe_runmake install
+}
+