aboutsummaryrefslogtreecommitdiffstats
path: root/classes
diff options
context:
space:
mode:
Diffstat (limited to 'classes')
-rw-r--r--classes/base.bbclass26
1 files changed, 13 insertions, 13 deletions
diff --git a/classes/base.bbclass b/classes/base.bbclass
index 71d9ec165..18093961a 100644
--- a/classes/base.bbclass
+++ b/classes/base.bbclass
@@ -38,30 +38,30 @@ bbfatal() {
addtask showdata
do_showdata[nostamp] = "1"
python do_showdata() {
- import sys
- # emit variables and shell functions
- bb.data.emit_env(sys.__stdout__, d, True)
- # emit the metadata which isnt valid shell
- for e in bb.data.keys(d):
- if d.getVarFlag(e, 'python', False):
- bb.plain("\npython %s () {\n%s}" % (e, d.getVar(e, True)))
+ import sys
+ # emit variables and shell functions
+ bb.data.emit_env(sys.__stdout__, d, True)
+ # emit the metadata which isn't valid shell
+ for e in bb.data.keys(d):
+ if d.getVarFlag(e, 'python', False):
+ bb.plain("\npython %s () {\n%s}" % (e, d.getVar(e)))
}
addtask listtasks
do_listtasks[nostamp] = "1"
python do_listtasks() {
- import sys
- for e in bb.data.keys(d):
- if d.getVarFlag(e, 'task', False):
- bb.plain("%s" % e)
+ import sys
+ for e in bb.data.keys(d):
+ if d.getVarFlag(e, 'task', False):
+ bb.plain("%s" % e)
}
addtask build
do_build[dirs] = "${TOPDIR}"
do_build[nostamp] = "1"
python base_do_build () {
- bb.note("The included, default BB base.bbclass does not define a useful default task.")
- bb.note("Try running the 'listtasks' task against a .bb to see what tasks are defined.")
+ bb.note("The included, default BB base.bbclass does not define a useful default task.")
+ bb.note("Try running the 'listtasks' task against a .bb to see what tasks are defined.")
}
EXPORT_FUNCTIONS do_clean do_mrproper do_build