aboutsummaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2006-03-19 23:02:27 +0000
committerHolger Hans Peter Freyther <zecke@selfish.org>2006-03-19 23:02:27 +0000
commita2a7d6a6cf38627a6005069a080845dcb11af831 (patch)
tree2f5fa1d373c36983dd54b4a56f21becf0a1530b4 /bin
parent75dafa252a42b9f27f426f6e1e1a666db9b698d3 (diff)
downloadbitbake-a2a7d6a6cf38627a6005069a080845dcb11af831.tar.gz
bitbake/bin/bitbake:
Create a ordinary main method. This makes invoking the hotshot profiling tool much more easy
Diffstat (limited to 'bin')
-rwxr-xr-xbin/bitbake8
1 files changed, 6 insertions, 2 deletions
diff --git a/bin/bitbake b/bin/bitbake
index e6bdbee4d..62539b7c4 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -1076,8 +1076,7 @@ class BBCooker:
# main
#============================================================================#
-if __name__ == "__main__":
-
+def main():
parser = optparse.OptionParser( version = "BitBake Build Tool Core version %s, %%prog version %s" % ( bb.__version__, __version__ ),
usage = """%prog [options] [package ...]
@@ -1129,3 +1128,8 @@ Default BBFILES are the .bb files in the current directory.""" )
cooker = BBCooker()
cooker.cook( BBConfiguration( options ), args[1:] )
+
+
+
+if __name__ == "__main__":
+ main()