aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Dechesne <nicolas.dechesne@linaro.org>2020-07-30 18:19:08 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-09-16 18:13:44 +0100
commit35fdc18549607e195d424f554e8d4b74e87fd245 (patch)
tree287ef4bc3a64455d9673f5fe87540fafaff94a37
parente11d2dd1adbcb35b45d6d0f3a47f8d06caab0b49 (diff)
downloadbitbake-35fdc18549607e195d424f554e8d4b74e87fd245.tar.gz
sphinx: fixes all remaining warnings
This patch fixes a handful of remaining warnings reported by Sphinx. Signed-off-by: Nicolas Dechesne <nicolas.dechesne@linaro.org>
-rw-r--r--doc/bitbake-user-manual/bitbake-user-manual-hello.rst2
-rw-r--r--doc/bitbake-user-manual/bitbake-user-manual-metadata.rst14
-rw-r--r--doc/bitbake-user-manual/bitbake-user-manual-ref-variables.rst6
3 files changed, 11 insertions, 11 deletions
diff --git a/doc/bitbake-user-manual/bitbake-user-manual-hello.rst b/doc/bitbake-user-manual/bitbake-user-manual-hello.rst
index 5edf97eaa..3d3c9b48c 100644
--- a/doc/bitbake-user-manual/bitbake-user-manual-hello.rst
+++ b/doc/bitbake-user-manual/bitbake-user-manual-hello.rst
@@ -287,7 +287,7 @@ Following is the complete "Hello World" example.
$ mkdir conf Move to the ``conf`` directory and create a
``layer.conf`` file that has the following: BBPATH .=
":${:term:`LAYERDIR`}" :term:`BBFILES`
- += "${LAYERDIR}/*.bb"
+ += "${LAYERDIR}/\*.bb"
:term:`BBFILE_COLLECTIONS` += "mylayer"
`BBFILE_PATTERN_mylayer <#var-bb-BBFILE_PATTERN>`__ :=
"^${LAYERDIR_RE}/" For information on these variables, click the
diff --git a/doc/bitbake-user-manual/bitbake-user-manual-metadata.rst b/doc/bitbake-user-manual/bitbake-user-manual-metadata.rst
index c0eb118eb..c98b3a9e7 100644
--- a/doc/bitbake-user-manual/bitbake-user-manual-metadata.rst
+++ b/doc/bitbake-user-manual/bitbake-user-manual-metadata.rst
@@ -973,7 +973,7 @@ Tasks
Tasks are BitBake execution units that make up the steps that BitBake
can run for a given recipe. Tasks are only supported in recipes and
classes (i.e. in ``.bb`` files and files included or inherited from
-``.bb`` files). By convention, tasks have names that start with "do_".
+``.bb`` files). By convention, tasks have names that start with "do\_".
Promoting a Function to a Task
------------------------------
@@ -987,8 +987,8 @@ task and declare some dependencies: python do_printdate () { import time
print time.strftime('%Y%m%d', time.gmtime()) } addtask printdate after
do_fetch before do_build The first argument to ``addtask`` is the name
of the function to promote to a task. If the name does not start with
-"do_", "do_" is implicitly added, which enforces the convention that all
-task names start with "do_".
+"do\_", "do\_" is implicitly added, which enforces the convention that all
+task names start with "do\_".
In the previous example, the ``do_printdate`` task becomes a dependency
of the ``do_build`` task, which is the default task (i.e. the task run
@@ -1030,7 +1030,7 @@ Additionally, the ``do_printdate`` task becomes dependent upon the
-c
NBSP
task
- command, you can omit the "do_" prefix as part of the task name.
+ command, you can omit the "do\_" prefix as part of the task name.
You might wonder about the practical effects of using ``addtask``
without specifying any dependencies as is done in the following example:
@@ -1714,10 +1714,10 @@ Support for wildcard use in variables varies depending on the context in
which it is used. For example, some variables and file names allow
limited use of wildcards through the "``%``" and "``*``" characters.
Other variables or names support Python's
-```glob`https://docs.python.org/3/library/glob.html syntax,
-```fnmatch`https://docs.python.org/3/library/fnmatch.html#module-fnmatch
+`glob <https://docs.python.org/3/library/glob.html>`_ syntax,
+`fnmatch <https://docs.python.org/3/library/fnmatch.html#module-fnmatch>`_
syntax, or
-```Regular Expression (re)`https://docs.python.org/3/library/re.html#re
+`Regular Expression (re) <https://docs.python.org/3/library/re.html#re>`_
syntax.
For variables that have wildcard suport, the documentation describes
diff --git a/doc/bitbake-user-manual/bitbake-user-manual-ref-variables.rst b/doc/bitbake-user-manual/bitbake-user-manual-ref-variables.rst
index d5c07e4aa..04a69482b 100644
--- a/doc/bitbake-user-manual/bitbake-user-manual-ref-variables.rst
+++ b/doc/bitbake-user-manual/bitbake-user-manual-ref-variables.rst
@@ -51,7 +51,7 @@ overview of their function and contents.
- Limited support for the "``*``" wildcard character for matching
against the beginning of host names exists. For example, the
following setting matches ``git.gnu.org``, ``ftp.gnu.org``, and
- ``foo.git.gnu.org``. BB_ALLOWED_NETWORKS = "*.gnu.org"
+ ``foo.git.gnu.org``. BB_ALLOWED_NETWORKS = "\*.gnu.org"
.. note::
@@ -368,7 +368,7 @@ overview of their function and contents.
BB_RUNTASK
Contains the name of the currently executing task. The value includes
- the "do_" prefix. For example, if the currently executing task is
+ the "do\_" prefix. For example, if the currently executing task is
``do_config``, the value is "do_config".
BB_SCHEDULER
@@ -617,7 +617,7 @@ overview of their function and contents.
software.
When specifying recipe files, you can pattern match using Python's
- ```glob`https://docs.python.org/3/library/glob.html syntax.
+ `glob <https://docs.python.org/3/library/glob.html>`_ syntax.
For details on the syntax, see the documentation by following the
previous link.